]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- sync some things with DEVEL for easier merging; fixed glib dependency
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6 Summary:        aRts sound server
7 Summary(pl):    Serwer d¼wiêku
8 Summary(pt_BR): Servidor de sons usado pelo KDE
9 Name:           arts
10 Version:        1.1.4
11 Release:        1
12 Epoch:          12
13 License:        LGPL
14 Vendor:         The KDE Team
15 Group:          Libraries
16 Source0:        ftp://ftp.kde.org/pub/kde/stable/3.1.4/src/%{name}-%{version}.tar.bz2
17 # Source0-md5:  aa4bef1e80cd3795e3fd832471e348e9
18 URL:            http://www.kde.org/
19 %{?with_alsa:BuildRequires:     alsa-lib-devel}
20 BuildRequires:  audiofile-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  glib2-devel >= 2.0.0
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libmad-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtool >= 2:1.5-2
28 BuildRequires:  libvorbis-devel
29 %{?with_nas:BuildRequires:      nas-devel}
30 BuildRequires:  pkgconfig
31 BuildRequires:  qt-devel >= 3.1
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 aRts sound server.
36
37 %description -l pl
38 Serwer d¼wiêku aRts.
39
40 %description -l pt_BR
41 O aRts é um sintetizador analógico em tempo real que é completamente
42 modular. Você pode criar sons e músicas (síntese em tempo real de
43 midi) usando pequenos módulos como oscilador para criar waveforms,
44 vários filtros, mixers, faders, etc. Você pode configurar tudo através
45 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
46 design foi escolhido para permitir que outras aplicações usem o aRts
47 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
48 outros.
49
50 %package devel
51 Summary:        Sound server - header files
52 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
53 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
54 Group:          Development/Libraries
55 Requires:       %{name} = %{epoch}:%{version}
56 Requires:       qt-devel >= 3.1
57
58 %description devel
59 Header files required to compile programs using arts.
60
61 %description devel -l pl
62 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
63 arts.
64
65 %description devel -l pt_BR
66 Arquivos para desenvolvimento com o o aRts.
67
68 %package X11
69 Summary:        X11 dependent part of aRts
70 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
71 Group:          X11/Libraries
72 Requires:       %{name} = %{epoch}:%{version}
73
74 %description X11
75 X11 dependent part of aRts.
76
77 %description X11 -l pl
78 Czê¶æ aRts wymagaj±ca X11.
79
80 %package glib
81 Summary:        GLib dependend part of aRts
82 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
83 Group:          Libraries
84 Requires:       %{name} = %{epoch}:%{version}
85 Requires:       glib >= 2.0.0
86
87 %description glib
88 GLib dependend part of aRts.
89
90 %description glib -l pl
91 Czê¶æ aRts wymagaj±ca GLib.
92
93 %package qt
94 Summary:        QT dependend part of aRts
95 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
96 Group:          X11/Libraries
97 Requires:       %{name} = %{epoch}:%{version}
98 Requires:       qt >= 3.1
99
100 %description qt
101 QT dependend part of aRts.
102
103 %description qt -l pl
104 Czê¶æ aRts wymagaj±ca QT.
105
106 %prep
107 %setup -q
108
109 %build
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %{__perl} admin/am_edit
116
117 %configure \
118         --%{?debug:en}%{!?debug:dis}able-debug \
119         --disable-rpath \
120         --enable-final \
121         --with%{!?with_alsa:out}-alsa
122
123 %if %{without nas}
124 # Cannot patch configure.in because it does not rebuild correctly on ac25
125 sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
126         < config.h \
127         > config.h.tmp
128 mv -f config.h{.tmp,}
129 %endif
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %post   X11 -p /sbin/ldconfig
146 %postun X11 -p /sbin/ldconfig
147
148 %post   glib -p /sbin/ldconfig
149 %postun glib -p /sbin/ldconfig
150
151 %post   qt -p /sbin/ldconfig
152 %postun qt -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/artscat
157 %attr(755,root,root) %{_bindir}/artsd
158 %attr(755,root,root) %{_bindir}/artsdsp
159 %attr(755,root,root) %{_bindir}/artsplay
160 %attr(755,root,root) %{_bindir}/artsrec
161 %attr(755,root,root) %{_bindir}/artsshell
162 %attr(755,root,root) %{_bindir}/artswrapper
163 %attr(755,root,root) %{_bindir}/testdhandle
164 # shared libraries
165 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
166 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
167 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
168 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
169 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
170 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
171 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
172 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
173 # lt_dlopened modules (*.la needed)
174 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
175 %{_libdir}/libartscbackend.la
176 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
177 %{_libdir}/libartsdsp.la
178 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
179 %{_libdir}/libartsdsp_st.la
180 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
181 %{_libdir}/libartsgslplayobject.la
182 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
183 %{_libdir}/libartswavplayobject.la
184 #
185 %{_libdir}/mcop
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/artsc-config
190 %attr(755,root,root) %{_bindir}/mcopidl
191 %attr(755,root,root) %{_libdir}/libartsc.so
192 %attr(755,root,root) %{_libdir}/libartsflow.so
193 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
194 # some apps (incorrectly?) link with libarts*playobject (gg with -lartswavplayobject only?)
195 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
196 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
197 %attr(755,root,root) %{_libdir}/libkmedia2.so
198 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
199 %attr(755,root,root) %{_libdir}/libmcop.so
200 %attr(755,root,root) %{_libdir}/libmcop_mt.so
201 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
202 # shared libraries
203 %{_libdir}/libartsc.la
204 %{_libdir}/libartsflow.la
205 %{_libdir}/libartsflow_idl.la
206 %{_libdir}/libkmedia2.la
207 %{_libdir}/libkmedia2_idl.la
208 %{_libdir}/libmcop.la
209 %{_libdir}/libmcop_mt.la
210 %{_libdir}/libsoundserver_idl.la
211 # devel for -glib and -qt
212 %attr(755,root,root) %{_libdir}/libgmcop.so
213 %attr(755,root,root) %{_libdir}/libqtmcop.so
214 %{_libdir}/libgmcop.la
215 %{_libdir}/libqtmcop.la
216 #
217 %{_includedir}/arts
218 %{_includedir}/artsc
219
220 %files X11
221 %defattr(644,root,root,755)
222 # lt_dlopened module (.la needed)
223 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
224 %{_libdir}/libx11globalcomm.la
225
226 %files glib
227 %defattr(644,root,root,755)
228 # shared library
229 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
230
231 %files qt
232 %defattr(644,root,root,755)
233 # shared library
234 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.152114 seconds and 3 git commands to generate.