]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
85b52a21627784e6e25165dea06663942527a3c9
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6
7 %define         _state          snapshots
8 %define         _ver            1.2.90
9 %define         _snap           040401
10
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}.%{_snap}
16 Release:        1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
21 #Source0:       http://ep09.pld-linux.org/~adgor/kde/%{name}.tar.bz2
22 Source0:        http://ep09.pld-linux.org/~djurban/kde/%{name}-%{_snap}.tar.bz2
23 # Source0-md5:  ff498b5cc743213ab8a1d0d5dc65b418
24 URL:            http://www.kde.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel}
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  docbook-dtd41-sgml
30 BuildRequires:  docbook-utils >= 0.6.13-3
31 BuildRequires:  esound-devel
32 BuildRequires:  glib2-devel >= 2.0.0
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt-devel >= 6:3.2.1-4
39 BuildRequires:  unsermake
40 Obsoletes:      arts-glib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 aRts sound server.
45
46 %description -l pl
47 Serwer d¼wiêku aRts.
48
49 %description -l pt_BR
50 O aRts é um sintetizador analógico em tempo real que é completamente
51 modular. Você pode criar sons e músicas (síntese em tempo real de
52 midi) usando pequenos módulos como oscilador para criar waveforms,
53 vários filtros, mixers, faders, etc. Você pode configurar tudo através
54 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
55 design foi escolhido para permitir que outras aplicações usem o aRts
56 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
57 outros.
58
59 %package devel
60 Summary:        Sound server - header files
61 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
62 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
63 Group:          Development/Libraries
64 Requires:       %{name} = %{epoch}:%{version}-%{release}
65 # not necessary for all libs (e.g. mcop), but propagated by artsflow
66 %{?with_alsa:Requires:  alsa-lib-devel}
67 Requires:       audiofile-devel
68 Requires:       esound-devel
69 Requires:       glib2-devel >= 2.0.0
70 Requires:       libmad-devel
71 Requires:       libvorbis-devel
72 %{?with_nas:Requires:   nas-devel}
73
74 %description devel
75 Header files required to compile programs using arts.
76
77 %description devel -l pl
78 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
79 arts.
80
81 %description devel -l pt_BR
82 Arquivos para desenvolvimento com o o aRts.
83
84 # separate from arts-devel because they are mostly independent and have very
85 # different deps
86 # there is no artsc base - it would be small and would require arts - so there
87 # is no reason to separate
88 %package -n artsc-devel
89 Summary:        Development files for artsc libraries
90 Summary(pl):    Pliki programistyczne bibliotek artsc
91 Group:          Development/Libraries
92 Requires:       %{name} = %{epoch}:%{version}-%{release}
93 Requires:       glib2-devel >= 2.0.0
94 Conflicts:      arts-devel < 12:1.2.0.031126-2
95
96 %description -n artsc-devel
97 Development files for artsc libraries (C interface to aRts sound
98 system).
99
100 %description -n artsc-devel -l pl
101 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
102 d¼wiêku aRts).
103
104 %package X11
105 Summary:        X11 dependent part of aRts
106 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
107 Group:          X11/Libraries
108 Requires:       %{name} = %{epoch}:%{version}-%{release}
109
110 %description X11
111 X11 dependent part of aRts (x11globalcomm module).
112
113 %description X11 -l pl
114 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
115
116 %package qt
117 Summary:        QT dependend part of aRts
118 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
119 Group:          X11/Libraries
120 Requires:       %{name} = %{epoch}:%{version}-%{release}
121 Requires:       qt >= 6:3.2.1-4
122
123 %description qt
124 QT dependend part of aRts (qtmcop library).
125
126 %description qt -l pl
127 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
128
129 %package qt-devel
130 Summary:        Development files for qtmcop library
131 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
132 Group:          X11/Development/Libraries
133 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
134 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
135 Requires:       qt-devel >= 6:3.2.1-4
136
137 %description qt-devel
138 Development files for qtmcop library.
139
140 %description qt-devel -l pl
141 Pliki programistyczne dla biblioteki qtmcop.
142
143 %prep
144 #%setup -q -n %{name}
145 %setup -q -n %{name}-%{_snap}
146
147 %build
148 cp /usr/share/automake/config.sub admin
149
150 export UNSERMAKE=/usr/share/unsermake/unsermake
151
152 %{__make} -f admin/Makefile.common cvs
153
154 %configure \
155         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
156         --%{?debug:en}%{!?debug:dis}able-debug \
157         --disable-rpath \
158         --enable-final \
159         --with-qt-libraries=%{_libdir} \
160         --with%{!?with_alsa:out}-alsa
161
162 %{__make}
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 # Debian manpages
171 install -d $RPM_BUILD_ROOT%{_mandir}/man1
172 cd debian/man
173 for f in *.sgml ; do
174         base="$(basename $f .sgml)"
175         upper="$(echo ${base} | tr a-z A-Z)"
176         db2man $f
177         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
178 done
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post   -p /sbin/ldconfig
184 %postun -p /sbin/ldconfig
185
186 %post   X11 -p /sbin/ldconfig
187 %postun X11 -p /sbin/ldconfig
188
189 %post   qt -p /sbin/ldconfig
190 %postun qt -p /sbin/ldconfig
191
192 %files
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/artscat
195 %attr(755,root,root) %{_bindir}/artsd
196 %attr(755,root,root) %{_bindir}/artsdsp
197 %attr(755,root,root) %{_bindir}/artsplay
198 %attr(755,root,root) %{_bindir}/artsrec
199 %attr(755,root,root) %{_bindir}/artsshell
200 %attr(755,root,root) %{_bindir}/artswrapper
201 # shared libraries
202 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
208 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
209 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
210 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
211 # lt_dlopened modules (*.la needed)
212 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
213 %{_libdir}/libartscbackend.la
214 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
215 %{_libdir}/libartsdsp.la
216 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
217 %{_libdir}/libartsdsp_st.la
218 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
219 %{_libdir}/libartsgslplayobject.la
220 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
221 %{_libdir}/libartswavplayobject.la
222 #
223 %{_libdir}/mcop
224 %{_mandir}/man1/artscat.1*
225 %{_mandir}/man1/artsd.1*
226 %{_mandir}/man1/artsdsp.1*
227 %{_mandir}/man1/artsplay.1*
228 %{_mandir}/man1/artsrec.1*
229 %{_mandir}/man1/artsshell.1*
230 %{_mandir}/man1/artswrapper.1*
231
232 %files devel
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_bindir}/mcopidl
235 %attr(755,root,root) %{_libdir}/libartsflow.so
236 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
237 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
238 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
239 %attr(755,root,root) %{_libdir}/libgmcop.so
240 %attr(755,root,root) %{_libdir}/libkmedia2.so
241 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
242 %attr(755,root,root) %{_libdir}/libmcop.so
243 %attr(755,root,root) %{_libdir}/libmcop_mt.so
244 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
245 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
246 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
247 # shared libraries
248 %{_libdir}/libartsflow.la
249 %{_libdir}/libartsflow_idl.la
250 %{_libdir}/libgmcop.la
251 %{_libdir}/libkmedia2.la
252 %{_libdir}/libkmedia2_idl.la
253 %{_libdir}/libmcop.la
254 %{_libdir}/libmcop_mt.la
255 %{_libdir}/libsoundserver_idl.la
256 #
257 %{_includedir}/arts
258 %exclude %{_includedir}/arts/qiomanager.h
259 %{_mandir}/man1/mcopidl.1*
260
261 %files -n artsc-devel
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_bindir}/artsc-config
264 %attr(755,root,root) %{_libdir}/libartsc.so
265 %attr(755,root,root) %{_libdir}/libartscbackend.so
266 %attr(755,root,root) %{_libdir}/libartsdsp.so
267 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
268 %{_libdir}/libartsc.la
269 %{_includedir}/artsc
270 %{_mandir}/man1/artsc-config.1*
271
272 %files X11
273 %defattr(644,root,root,755)
274 # lt_dlopened module (.la needed)
275 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
276 %{_libdir}/libx11globalcomm.la
277
278 %files qt
279 %defattr(644,root,root,755)
280 # shared library
281 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
282
283 %files qt-devel
284 %defattr(644,root,root,755)
285 %attr(755,root,root) %{_libdir}/libqtmcop.so
286 %{_libdir}/libqtmcop.la
287 %{_includedir}/arts/qiomanager.h
This page took 0.045455 seconds and 2 git commands to generate.