]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
772da9fe5a15fd8c291ccd299eee9c2909c13a0c
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5
6 %define         _state          stable
7 %define         _kdever         3.1
8
9 Summary:        aRts sound server
10 Summary(pl):    Serwer d¼wiêku
11 Summary(pt_BR): Servidor de sons usado pelo KDE
12 Name:           arts
13 Version:        1.1
14 Release:        5
15 Epoch:          12
16 License:        LGPL
17 Vendor:         The KDE Team
18 Group:          Libraries
19 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
20 %ifnarch sparc sparcv9 sparc64
21 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
22 %endif
23 BuildRequires:  audiofile-devel
24 BuildRequires:  glib2-devel >= 2.0.0
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 # not needed, only ./configure check for this
28 #BuildRequires: libvorbis-devel
29 #BuildRequires: mad-devel
30 %{?_with_nas:BuildRequires:     nas-devel}
31 %{!?_with_nas:BuildConflicts:   nas-devel}
32 BuildRequires:  pkgconfig
33 BuildRequires:  qt-devel >= 3.1
34 URL:            http://www.kde.org/
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _htmldir        /usr/share/doc/kde/HTML
38
39 %define         no_install_post_chrpath         1
40
41 %description
42 aRts sound server.
43
44 %description -l pl
45 Serwer d¼wiêku aRts.
46
47 %description -l pt_BR
48 O aRts é um sintetizador analógico em tempo real que é completamente
49 modular. Você pode criar sons e músicas (síntese em tempo real de
50 midi) usando pequenos módulos como oscilador para criar waveforms,
51 vários filtros, mixers, faders, etc. Você pode configurar tudo através
52 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
53 design foi escolhido para permitir que outras aplicações usem o aRts
54 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
55 outros.
56
57 %package X11
58 Summary:        X11 dependent part of aRts
59 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
60 Group:          X11/Libraries
61
62 %description X11
63 X11 dependent part of aRts.
64
65 %description X11 -l pl
66 Czê¶æ aRts wymagaj±ca X11.
67
68 %package qt
69 Summary:        QT dependend part of aRts
70 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
71 Group:          X11/Libraries
72 Requires:       %{name} >= %{version}
73 Requires:       qt >= 3.1
74
75 %description qt
76 QT dependend part of aRts.
77
78 %description qt -l pl
79 Czê¶æ aRts wymagaj±ca QT.
80
81 %package devel
82 Summary:        Sound server - header files
83 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
84 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
85 Group:          Development/Libraries
86 Requires:       qt-devel >= 3.1
87 Requires:       %{name} >= %{version}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 %package glib
100 Summary:        GLib dependend part of aRts
101 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
102 Group:          X11/Libraries
103 Requires:       glib >= 1.2.6
104
105 %description glib
106 GLib dependend part of aRts.
107
108 %description glib -l pl
109 Czê¶æ aRts wymagaj±ca GLib.
110
111 %prep
112 %setup -q
113
114 %build
115 kde_htmldir="%{_htmldir}"; export kde_htmldir
116 kde_icondir="%{_pixmapsdir}"; export kde_icondir
117
118 %configure \
119         --%{?debug:en}%{!?debug:dis}able-debug \
120         --enable-final \
121         --with-xinerama \
122         --with%{?_without_alsa:out}-alsa
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install DESTDIR=$RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %post X11   -p /sbin/ldconfig
135 %postun X11 -p /sbin/ldconfig
136
137 %post qt   -p /sbin/ldconfig
138 %postun qt -p /sbin/ldconfig
139
140 %post glib   -p /sbin/ldconfig
141 %postun glib -p /sbin/ldconfig
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/artscat
149 %attr(755,root,root) %{_bindir}/artsd
150 %attr(755,root,root) %{_bindir}/artsdsp
151 %attr(755,root,root) %{_bindir}/artsplay
152 %attr(755,root,root) %{_bindir}/artsrec
153 %attr(755,root,root) %{_bindir}/artsshell
154 %attr(755,root,root) %{_bindir}/artswrapper
155 %attr(755,root,root) %{_bindir}/testdhandle
156 %{_libdir}/lib[!gqx]*.la
157 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
158 %{_libdir}/mcop
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/artsc-config
163 %attr(755,root,root) %{_bindir}/mcopidl
164 %{_libdir}/*.so
165 %{_includedir}/arts
166 %{_includedir}/artsc
167
168 %files X11
169 %defattr(644,root,root,755)
170 %{_libdir}/libx11globalcomm.la
171 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
172
173 %files glib
174 %defattr(644,root,root,755)
175 %{_libdir}/libgmcop.la
176 %attr(755,root,root) %{_libdir}/libgmcop.so.*
177
178 %files qt
179 %defattr(644,root,root,755)
180 %{_libdir}/libqtmcop.la
181 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.027256 seconds and 2 git commands to generate.