]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- reorders: *.la for regular shared libraries back to -devel,
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5 %ifarch sparc sparcv9 sparc64
6 %define         _without_alsa   1
7 %endif
8 Summary:        aRts sound server
9 Summary(pl):    Serwer d¼wiêku
10 Summary(pt_BR): Servidor de sons usado pelo KDE
11 Name:           arts
12 Version:        1.1.3
13 Release:        1.1
14 Epoch:          12
15 License:        LGPL
16 Vendor:         The KDE Team
17 Group:          Libraries
18 Source0:        ftp://ftp.kde.org/pub/kde/stable/3.1.3/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  f04eb6ef387d63741561ab6623696322
20 URL:            http://www.kde.org/
21 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
22 BuildRequires:  audiofile-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  glib2-devel >= 2.0.0
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool >= 2:1.5-2
30 # not needed, only ./configure check for this
31 #BuildRequires: libmad-devel
32 #BuildRequires: libvorbis-devel
33 %{?_with_nas:BuildRequires:     nas-devel}
34 BuildRequires:  pkgconfig
35 BuildRequires:  qt-devel >= 3.1
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _htmldir        /usr/share/doc/kde/HTML
39
40 %description
41 aRts sound server.
42
43 %description -l pl
44 Serwer d¼wiêku aRts.
45
46 %description -l pt_BR
47 O aRts é um sintetizador analógico em tempo real que é completamente
48 modular. Você pode criar sons e músicas (síntese em tempo real de
49 midi) usando pequenos módulos como oscilador para criar waveforms,
50 vários filtros, mixers, faders, etc. Você pode configurar tudo através
51 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
52 design foi escolhido para permitir que outras aplicações usem o aRts
53 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
54 outros.
55
56 %package X11
57 Summary:        X11 dependent part of aRts
58 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
59 Group:          X11/Libraries
60 Requires:       %{name} = %{epoch}:%{version}
61
62 %description X11
63 X11 dependent part of aRts.
64
65 %description X11 -l pl
66 Czê¶æ aRts wymagaj±ca X11.
67
68 %package qt
69 Summary:        QT dependend part of aRts
70 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
71 Group:          X11/Libraries
72 Requires:       %{name} = %{epoch}:%{version}
73 Requires:       qt >= 3.1
74
75 %description qt
76 QT dependend part of aRts.
77
78 %description qt -l pl
79 Czê¶æ aRts wymagaj±ca QT.
80
81 %package devel
82 Summary:        Sound server - header files
83 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
84 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
85 Group:          Development/Libraries
86 Requires:       qt-devel >= 3.1
87 Requires:       %{name} = %{epoch}:%{version}
88 %{?_with_nas:Requires:  nas-devel}
89
90 %description devel
91 Header files required to compile programs using arts.
92
93 %description devel -l pl
94 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
95 arts.
96
97 %description devel -l pt_BR
98 Arquivos para desenvolvimento com o o aRts.
99
100 %package glib
101 Summary:        GLib dependend part of aRts
102 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
103 Group:          Libraries
104 Requires:       %{name} = %{epoch}:%{version}
105 Requires:       glib >= 1.2.6
106
107 %description glib
108 GLib dependend part of aRts.
109
110 %description glib -l pl
111 Czê¶æ aRts wymagaj±ca GLib.
112
113 %prep
114 %setup -q
115
116 %build
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 %{__perl} admin/am_edit
123
124 kde_htmldir="%{_htmldir}"; export kde_htmldir
125 kde_icondir="%{_pixmapsdir}"; export kde_icondir
126 %configure \
127         --%{?debug:en}%{!?debug:dis}able-debug \
128         --disable-rpath \
129         --enable-final \
130         --with-xinerama \
131         --with%{?_without_alsa:out}-alsa
132
133 %if %{!?_with_nas:1}0
134 # Cannot patch configure.in because it does not rebuild correctly on ac25
135 sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
136         < config.h \
137         > config.h.tmp
138 mv -f config.h{.tmp,}
139 %endif
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %post   X11 -p /sbin/ldconfig
155 %postun X11 -p /sbin/ldconfig
156
157 %post   qt -p /sbin/ldconfig
158 %postun qt -p /sbin/ldconfig
159
160 %post   glib -p /sbin/ldconfig
161 %postun glib -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/artscat
166 %attr(755,root,root) %{_bindir}/artsd
167 %attr(755,root,root) %{_bindir}/artsdsp
168 %attr(755,root,root) %{_bindir}/artsplay
169 %attr(755,root,root) %{_bindir}/artsrec
170 %attr(755,root,root) %{_bindir}/artsshell
171 %attr(755,root,root) %{_bindir}/artswrapper
172 %attr(755,root,root) %{_bindir}/testdhandle
173 # shared libraries
174 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
175 %attr(755,root,root) %{_libdir}/libartsflow*.so.*.*.*
176 %attr(755,root,root) %{_libdir}/libkmedia2*.so.*.*.*
177 %attr(755,root,root) %{_libdir}/libmcop*.so.*.*.*
178 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
179 # lt_dlopened modules (*.la needed)
180 %attr(755,root,root) %{_libdir}/libarts*playobject.so.*.*.*
181 %{_libdir}/libarts*playobject.la
182 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
183 %{_libdir}/libartscbackend.la
184 %attr(755,root,root) %{_libdir}/libartsdsp*.so.*.*.*
185 %{_libdir}/libartsdsp*.la
186 %{_libdir}/mcop
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/artsc-config
191 %attr(755,root,root) %{_bindir}/mcopidl
192 %attr(755,root,root) %{_libdir}/libartsc.so
193 %attr(755,root,root) %{_libdir}/libartsflow*.so
194 %attr(755,root,root) %{_libdir}/libkmedia2*.so
195 %attr(755,root,root) %{_libdir}/libmcop*.so
196 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
197 %attr(755,root,root) %{_libdir}/libgmcop.so
198 %attr(755,root,root) %{_libdir}/libqtmcop.so
199 # some apps (incorrectly?) link with libarts*playobject (gg with -lartswavplayobject only?)
200 %attr(755,root,root) %{_libdir}/libarts*playobject.so
201 %{_libdir}/libartsc.la
202 %{_libdir}/libartsflow*.la
203 %{_libdir}/libkmedia2*.la
204 %{_libdir}/libmcop*.la
205 %{_libdir}/libsoundserver_idl.la
206 %{_libdir}/libgmcop.la
207 %{_libdir}/libqtmcop.la
208 %{_includedir}/arts
209 %{_includedir}/artsc
210
211 %files X11
212 %defattr(644,root,root,755)
213 # lt_dlopened module (.la needed)
214 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
215 %{_libdir}/libx11globalcomm.la
216
217 %files glib
218 %defattr(644,root,root,755)
219 # shared library
220 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
221
222 %files qt
223 %defattr(644,root,root,755)
224 # shared library
225 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.035901 seconds and 3 git commands to generate.