]> git.pld-linux.org Git - packages/arpd.git/blob - arpd.spec
- change uid of arpd-demon
[packages/arpd.git] / arpd.spec
1 Summary:        User-space arp daemon
2 Summary(pl):    Demon arpd
3 Name:           arpd
4 Version:        1.0.2
5 Release:        2
6 License:        GPL
7 Group:          Daemons
8 Group(de):      Server
9 Group(pl):      Serwery
10 Source0:        %{name}-%{version}.tar.gz
11 Source1:        %{name}-init
12 Patch0:         %{name}-%{version}.debian-patch
13 Patch1:         %{name}-%{version}.pld-patch
14 Patch2:         %{name}-makefile-patch
15 Patch3:         %{name}-more_tables.patch
16 Prereq:         /sbin/chkconfig
17 Prereq:         rc-scripts >= 0.2.0
18 Prereq:         fileutils
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The ARP daemon moves the management of the ARP (Address Resolution
23 Protocol) table from kernel to user space. It is useful for sites with
24 LARGE network segments (256+ systems per segment), because the kernel
25 hash tables are not optimized to handle this situation. To use the ARP
26 daemon your kernel needs to have ARPD and NETLINK support enabled. The
27 standard kernels of PLD lack this support. It shouldn't be run without
28 that!! This version can alocate 2048 entries.
29
30 %description -l pl
31 Demon ARP przekazuje zarz±dzanie tablic± ARP (Address Resolution
32 Protocol) z kernel'a do przestrzeni u¿ytkownika. Jest to bardzo
33 u¿yteczne dla miejsc o du¿ych segmentach sieci (256+ systemów na
34 segment), poniewa¿ tablice w j±drze nie s± zoptymalizowane na takie
35 sytuacje. Aby u¿ywaæ tego demona musisz mieæ ARPD support oraz NETLINK
36 support uaktywnione w j±drze. Uwaga! Stanadardowe j±dro PLD nie ma
37 supportu ARPD!!. Demon nie powinien byæ startowany bez tego!! Ta
38 wersja potrafi zaakceptowaæ 2048 pozycji.
39
40 %prep
41 %setup  -q -n %{name}-%{version}.orig
42 %patch0 -p1
43 %patch1 -p1
44 %patch2 -p1
45 %patch3
46
47 %build
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT/{usr/sbin,etc/rc.d/init.d}
53
54 install arpd $RPM_BUILD_ROOT%{_sbindir}/arpd
55 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/arpd
56
57 gzip -9nf CHANGES
58
59 %post
60 /sbin/chkconfig --add arpd
61 if [ ! -f /dev/arpd ]; then
62         mknod /dev/arpd c 36 8 
63 fi
64 echo "Warning!!"
65 echo "You need arpd kernel support. The standard kernels of PLD lack this support!!"
66 if [ -f /var/lock/subsys/arpd ]; then
67         /etc/rc.d/init.d/arpd restart 1>&2
68 else
69         echo "Run \"/etc/rc.d/init.d/arpd start\" to start arpd daemon."
70 fi
71
72
73 %preun
74 /sbin/chkconfig --del arpd
75 if [ "$1" = "0" ]; then
76         if [ -f /var/lock/subsys/arpd ]; then
77                 /etc/rc.d/init.d/arpd stop 1>&2
78         fi
79         /sbin/chkconfig --del arpd
80 fi
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc *.gz README.html
88 %attr(754,root,root) %{_sbindir}/arpd
89 %attr(754,root,root) /etc/rc.d/init.d/arpd
This page took 0.036505 seconds and 3 git commands to generate.