]> git.pld-linux.org Git - packages/arpack.git/blob - arpack.spec
- added support for conditional building with ACML (freely available proprietary...
[packages/arpack.git] / arpack.spec
1 #
2 # Conditional build:
3 %bcond_with     acml    # With ACML version of BLAS instead of NETLIB implementation
4 Summary:        Subroutines for solving large scale eigenvalue problems
5 Summary(pl):    Rozwi±zywanie zagadnienia w³asnego dla du¿ych macierzy
6 Name:           arpack
7 Version:        2.1
8 Release:        3%{?with_acml:ACML}
9 License:        Freely distributable
10 Group:          Libraries
11 Source0:        http://www.caam.rice.edu/software/ARPACK/SRC/%{name}96.tar.gz
12 # Source0-md5:  fffaa970198b285676f4156cebc8626e
13 Source1:        http://www.caam.rice.edu/software/ARPACK/SRC/patch.tar.gz
14 # Source1-md5:  14830d758f195f272b8594a493501fa2
15 Source2:        http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
16 # Source2-md5:  79cc51e4812c75873adafcad2185842e
17 Source3:        http://www.caam.rice.edu/software/ARPACK/SRC/P57_58.ps.gz
18 # Source3-md5:  b86d77199f989fc438acaf7ac0433e76
19 Source4:        http://www.caam.rice.edu/software/ARPACK/SRC/P61_62.ps.gz
20 # Source4-md5:  d116887acb3d61fecf645c2d37d4d517
21 Patch0:         %{name}-automake_support.patch
22 URL:            http://www.caam.rice.edu/software/ARPACK/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  gcc-g77
26 %{!?with_acml:BuildRequires:    blas-devel}
27 BuildRequires:  libtool >= 2:1.5
28 %{?with_acml:ExclusiveArch:     amd64}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 ARPACK software is capable of solving large scale symmetric,
33 nonsymmetric, and generalized eigenproblems from significant
34 application areas. The software is designed to compute a few (k)
35 eigenvalues with user specified features such as those of largest real
36 part or largest magnitude. Storage requirements are on the order of
37 n*k locations. No auxiliary storage is required. A set of Schur basis
38 vectors for the desired k-dimensional eigen-space is computed which is
39 numerically orthogonal to working precision. Numerically accurate
40 eigenvectors are available on request.
41
42 %description -l pl
43 Rozwi±zywanie zagadnienia w³asnego (symetrycznego, niesymetrycznego,
44 ogólnego) dla du¿ych macierzy. Macierz mo¿e byæ dowolna, przy czym
45 procedury dzia³aj± szczególnie dobrze w przypadku du¿ych macierzy
46 rzadkich b±d¼ macierzy ze znan± struktur±. Biblioteka s³u¿y do
47 obliczenia kilku (k) warto¶ci w³asnych o zadanych z góry w³asno¶ciach,
48 takich jak najwiêksza (najmniejsza) czê¶æ rzeczywista albo najwiêkszy
49 (najmniejszy) modu³. Wymagania pamiêciowe s± rzedu n*k, ¿adna
50 dodatkowa pamiêæ (np. dyskowa) nie jest wymagana.
51
52 %package devel
53 Summary:        ARPACK development files
54 Summary(pl):    Pliki programistyczne ARPACK
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 %{!?with_acml:Requires: blas-devel}
58
59 %description devel
60 ARPACK development files.
61
62 %description devel -l pl
63 Pliki programistyczne ARPACK.
64
65 %package static
66 Summary:        Static ARPACK library
67 Summary(pl):    Statyczna biblioteka ARPACK
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70 %{!?with_acml:Requires: blas-static}
71
72 %description static
73 Static ARPACK library.
74
75 %description static -l pl
76 Statyczna biblioteka ARPACK.
77
78 %prep
79 %setup -q -n ARPACK -b1
80 %patch -p1
81 cp %{SOURCE2} .
82 cp %{SOURCE3} .
83 cp %{SOURCE4} .
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoheader}
89 %{__autoconf}
90 %{__automake}
91 %configure \
92         LDFLAGS=%{?with_acml:-lacml}%{!?with_acml:-lblas}
93
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -fr $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc README
112 %attr(755,root,root) %{_libdir}/libarpack.so.*.*.*
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libarpack.so
117 %doc DOCUMENTS/*.doc *.ps.gz
118 %{_libdir}/libarpack.la
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libarpack.a
This page took 0.071367 seconds and 3 git commands to generate.