]> git.pld-linux.org Git - packages/arpack.git/blob - arpack.spec
- rediffed arscnd-3 patch
[packages/arpack.git] / arpack.spec
1 #
2 # Conditional build:
3 %bcond_with     acml    # With ACML version of BLAS instead of NETLIB implementation
4 #
5 %define         rel     13
6 Summary:        Subroutines for solving large scale eigenvalue problems
7 Summary(pl.UTF-8):      Rozwiązywanie zagadnienia własnego dla dużych macierzy
8 Name:           arpack
9 Version:        2.1
10 Release:        %{rel}%{?with_acml:ACML}
11 License:        Freely distributable
12 Group:          Libraries
13 Source0:        http://www.caam.rice.edu/software/ARPACK/SRC/%{name}96.tar.gz
14 # Source0-md5:  fffaa970198b285676f4156cebc8626e
15 Source1:        http://www.caam.rice.edu/software/ARPACK/SRC/patch.tar.gz
16 # Source1-md5:  14830d758f195f272b8594a493501fa2
17 Source2:        http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
18 # Source2-md5:  79cc51e4812c75873adafcad2185842e
19 Source3:        http://www.caam.rice.edu/software/ARPACK/SRC/P57_58.ps.gz
20 # Source3-md5:  b86d77199f989fc438acaf7ac0433e76
21 Source4:        http://www.caam.rice.edu/software/ARPACK/SRC/P61_62.ps.gz
22 # Source4-md5:  d116887acb3d61fecf645c2d37d4d517
23 Patch0:         http://mathema.tician.de/news.tiker.net/files/arpack-arscnd-3.patch.gz
24 # Patch0-md5:   a9b8224dbd9a033a73034753afb125d4
25 Patch1:         %{name}-automake_support.patch
26 Patch2:         %{name}-no_etime.patch
27 URL:            http://www.caam.rice.edu/software/ARPACK/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  gcc-g77
31 BuildRequires:  libtool >= 2:1.5
32 %{!?with_acml:BuildRequires:    lapack-devel}
33 %{?with_acml:ExclusiveArch:     %{x8664}}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 ARPACK software is capable of solving large scale symmetric,
38 nonsymmetric, and generalized eigenproblems from significant
39 application areas. The software is designed to compute a few (k)
40 eigenvalues with user specified features such as those of largest real
41 part or largest magnitude. Storage requirements are on the order of
42 n*k locations. No auxiliary storage is required. A set of Schur basis
43 vectors for the desired k-dimensional eigen-space is computed which is
44 numerically orthogonal to working precision. Numerically accurate
45 eigenvectors are available on request.
46
47 %description -l pl.UTF-8
48 Rozwiązywanie zagadnienia własnego (symetrycznego, niesymetrycznego,
49 ogólnego) dla dużych macierzy. Macierz może być dowolna, przy czym
50 procedury działają szczególnie dobrze w przypadku dużych macierzy
51 rzadkich bądź macierzy ze znaną strukturą. Biblioteka służy do
52 obliczenia kilku (k) wartości własnych o zadanych z góry własnościach,
53 takich jak największa (najmniejsza) część rzeczywista albo największy
54 (najmniejszy) moduł. Wymagania pamięciowe są rzędu n*k, żadna
55 dodatkowa pamięć (np. dyskowa) nie jest wymagana.
56
57 %package devel
58 Summary:        ARPACK development files
59 Summary(pl.UTF-8):      Pliki programistyczne ARPACK
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 %{!?with_acml:Requires: blas-devel}
63
64 %description devel
65 ARPACK development files.
66
67 %description devel -l pl.UTF-8
68 Pliki programistyczne ARPACK.
69
70 %package static
71 Summary:        Static ARPACK library
72 Summary(pl.UTF-8):      Statyczna biblioteka ARPACK
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static ARPACK library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka ARPACK.
81
82 %prep
83 %setup -q -n ARPACK -b1
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 cp %{SOURCE2} .
88 cp %{SOURCE3} .
89 cp %{SOURCE4} .
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoheader}
95 %{__autoconf}
96 %{__automake}
97 %configure
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README
116 %attr(755,root,root) %{_libdir}/libarpack.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libarpack.so.2
118
119 %files devel
120 %defattr(644,root,root,755)
121 %doc DOCUMENTS/*.doc *.ps.gz
122 %attr(755,root,root) %{_libdir}/libarpack.so
123 %{_libdir}/libarpack.la
124
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libarpack.a
This page took 0.09153 seconds and 3 git commands to generate.