]> git.pld-linux.org Git - packages/armst.git/commitdiff
- by Lord Blick lordblick at gmail.com
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 13 Jun 2012 16:07:31 +0000 (16:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  cleaned up and added to cvs

Changed files:
    armst.spec -> 1.1
    stmbl.patch -> 1.1

armst.spec [new file with mode: 0644]
stmbl.patch [new file with mode: 0644]

diff --git a/armst.spec b/armst.spec
new file mode 100644 (file)
index 0000000..085a12e
--- /dev/null
@@ -0,0 +1,40 @@
+Summary:       ST ARM-CortexM3 Linux RS-232 Loader
+Name:          armst
+Version:       1.20
+Release:       1
+License:       GPL v3
+Group:         Development/Tools
+Source0:       http://isotel.eu/ARMst/%{name}-%{version}-src.tgz
+# Source0-md5: aeaf4fa71c5b2cf7a4678409f82ec13e
+Patch0:                stmbl.patch
+URL:           http://isotel.eu/ARMst/
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The ARMst utility is a command line tool for flashing the ST
+ARM-CortexM3 family via the standard RS-232 port.
+
+%description -l pl.UTF-8
+Narzędzie ARMst jest uruchamialnym z konsoli narzędziem do zapisywania
+w pamięci mikrokontrolerów ST ARM Cortex-M3 przez standartowy port
+szeregowy RS-232.
+
+%prep
+%setup -n ARMst -q
+%patch0 -p0
+
+%build
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{_bindir}/armst
diff --git a/stmbl.patch b/stmbl.patch
new file mode 100644 (file)
index 0000000..ab01041
--- /dev/null
@@ -0,0 +1,71 @@
+--- stmbl.c.oryg       2012-06-13 15:01:49.000000000 +0200
++++ stmbl.c    2012-06-13 15:12:51.000000000 +0200
+@@ -127,7 +127,7 @@
+ int stmblRecv(uint8_t* buf, unsigned int size)
+ {
+       int rsize = 0;
+-      int rval, i;
++      int rval;
+       
+       while( rsize < size ) {
+               // Look whether there are still pending bytes in the buffer
+@@ -210,6 +210,7 @@
+ int stmblGetVersionNprotection()
+ {
++      return 0;
+ }
+@@ -236,7 +237,6 @@
+               address & 0xFF
+       };
+       int rval;
+-      int i;
+       if (size > 256) return STMBL_ERR_SIZE;
+       if (!stmblCmdAvail(0x11)) return STMBL_ERR_INVALIDCMD;
+@@ -308,19 +308,23 @@
+ int stmblWriteProtect()
+ {
++      return 0;
+ }
+ int stmblWriteUnprotect()
+ {
++      return 0;
+ }
+ int stmblReadoutProtect()
+ {
++      return 0;
+ }
+ int stmblReadoutUnprotect()
+ {
++      return 0;
+ }
+--- Makefile~  2012-06-13 15:17:22.000000000 +0200
++++ Makefile   2012-06-13 15:17:22.000000000 +0200
+@@ -10,7 +10,7 @@
+       LIBS    =
+       CFLAGS  = -Wall -g
+-
++DESTDIR=/usr/local/bin
+ # Do the stuff as specified above.
+ all:  armst
+@@ -19,7 +19,7 @@
+       $(CC) -o $@ $(CFLAGS) $(OBJ) $(LIBS)
+ install: armst
+-      install armst /usr/local/bin
++      install -p armst $(DESTDIR)
+ clean:
+       rm *~ *.o
This page took 0.096571 seconds and 4 git commands to generate.