]> git.pld-linux.org Git - packages/armagetronad.git/blob - armagetronad.spec
- comment out many things to fine the good way for build workaround
[packages/armagetronad.git] / armagetronad.spec
1 #
2 # TODO: start scripts for server
3 Summary:        A Tron lightcycle game with focus on multiplayer mode
4 Summary(pl.UTF-8):      Gra Tron ze światłocyklem skupiająca się na trybie dla wielu graczy
5 Name:           armagetronad
6 Version:        0.2.8.3.1
7 Release:        0.1
8 License:        GPL v3+
9 Group:          X11/Applications/Games
10 Source0:        http://downloads.sourceforge.net/armagetronad/%{name}-%{version}.src.tar.bz2
11 # Source0-md5:  d4957ee0c2d3ae9d630d1362a6dcee70
12 #Source1:       %{name}.desktop
13 #Source2:       %{name}.png
14 Source3:        http://armagetron.sourceforge.net/addons/moviepack.zip
15 # Source3-md5:  e2d40309dde7e1339ca6aff7599cdfa3
16 URL:            http://armagetronad.net/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  SDL_image-devel
19 BuildRequires:  SDL_mixer-devel
20 BuildRequires:  libjpeg-devel
21 BuildRequires:  libxml2-devel
22 BuildRequires:  libpng-devel >= 2:1.4.0
23 BuildRequires:  sed >= 4.0
24 BuildRequires:  unzip
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 In Armagetron, you ride a lightcycle around the game grid. You can
29 only make sharp turns of 90 degrees and a wall constantly builds up
30 after you. Make your enemies crash into your wall, but be aware that
31 they are trying to do the same to you. If you are fast enough, you may
32 be able to trap them, but the only way to speed up your lightcycle is
33 to drive close to the dangerous walls. Prepare for exciting strategic
34 preparations followed by action-packed close combat!
35
36 %description -l pl.UTF-8
37 W grze Armagetron jedzie się światłocyklem dookoła planszy. Można
38 wykonywać tylko ostre zakręty o 90 stopni, a za graczem ciągle buduje
39 się ściana. Trzeba spowodować, by wrogowie roztrzaskali się na tej
40 ścianie, ale także uważać, bo oni próbują zrobić to samo. Jeśli gracz
41 jest szybki, może złapać ich wszystkich, ale jedynym sposobem na
42 przyspieszenie światłocyklu jest jazda blisko niebezpiecznych ścian.
43 Trzeba się przygotować na ekscytujące strategiczne przygotowania i
44 następującą po nich walkę w zbliżeniu!
45
46 %package moviepack
47 Summary:        Moviepack addon
48 Summary(pl.UTF-8):      Dodatek Moviepack
49 Group:          X11/Applications/Games
50 Requires:       %{name} = %{version}-%{release}
51
52 %description moviepack
53 Moviepack addon.
54
55 %description moviepack -l pl.UTF-8
56 Dodatek Moviepack.
57
58 %package server
59 Summary:        Armagetron server
60 Summary(pl.UTF-8):      Serwer Armagetrona
61 Group:          Applications/Games
62
63 %description server
64 Armagetron server.
65
66 %description server -l pl.UTF-8
67 Serwer Armagetrona.
68
69 %prep
70 %setup -q -a3
71
72 # fix build with libpng >= 2:1.4.0
73 %{__sed} -i 's/png_check_sig/png_sig_cmp/' configure.ac
74 #sed -i -e 's@/usr/lib@/usr/%{_lib}@;s@X11R6/lib@%{_lib}@' configure.in
75
76 %build
77 %{__aclocal}
78 %{__autoconf}
79 %{__autoheader}
80 %{__automake}
81 %configure \
82         --disable-sysinstall \
83         --disable-uninstall
84 #       --disable-glout \
85 #       --enable-games \
86 #       --enable-main \
87 #       --enable-master \
88 #       --enable-music \
89 #       --disable-initscripts \
90 #       --disable-useradd
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 #install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
97 #       $RPM_BUILD_ROOT%{_prefix}/games/%{name}/moviepack \
98 #       $RPM_BUILD_ROOT%{_sysconfdir_server}
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 #mv -f $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_bindir}
104
105 #install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
106 #install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
107 #
108 #cp $RPM_BUILD_ROOT%{_sysconfdir}/* $RPM_BUILD_ROOT%{_sysconfdir_server}
109 #cp -R moviepack $RPM_BUILD_ROOT%{_prefix}/games/%{name}
110 #rm -f $RPM_BUILD_ROOT%{_prefix}/games/%{name}/moviepack/art_read_me.txt
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog NEWS src/doc/{*.html,net}
118 %dir %{_sysconfdir}/games
119 %dir %{_sysconfdir}/games/%{name}
120 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/games/%{name}/*.cfg
121 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.cfg
122 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.srv
123 %attr(755,root,root) %{_bindir}/%{name}
124 %dir %{_prefix}/share
125 %dir %{_prefix}/share/games
126 %dir %{_prefix}/share/games/armagetronad
127 %dir %{_prefix}/share/games/armagetronad/language
128 %{_prefix}/share/games/armagetronad/language/*.txt
129 %dir %{_prefix}/share/games/armagetronad/models
130 %{_prefix}/share/games/armagetronad/models/*.mod
131 %dir %{_prefix}/share/games/armagetronad/resource
132 %dir %{_prefix}/share/games/armagetronad/resource/included
133 %{_prefix}/share/games/armagetronad/resource/included/*.dtd
134 %dir %{_prefix}/share/games/armagetronad/resource/included/AATeam
135 %{_prefix}/share/games/armagetronad/resource/included/AATeam/*.dtd
136 %dir %{_prefix}/share/games/armagetronad/resource/included/Anonymous
137 %dir %{_prefix}/share/games/armagetronad/resource/included/Anonymous/polygon
138 %dir %{_prefix}/share/games/armagetronad/resource/included/Anonymous/polygon/regular
139 %{_prefix}/share/games/armagetronad/resource/included/Anonymous/polygon/regular/*.xml
140 %dir %{_prefix}/share/games/armagetronad/resource/included/Your_mom
141 %dir %{_prefix}/share/games/armagetronad/resource/included/Your_mom/clever
142 %{_prefix}/share/games/armagetronad/resource/included/Your_mom/clever/*.xml
143 %dir %{_prefix}/share/games/armagetronad/resource/included/Z-Man
144 %dir %{_prefix}/share/games/armagetronad/resource/included/Z-Man/fortress
145 %{_prefix}/share/games/armagetronad/resource/included/Z-Man/fortress/*.xml
146 %dir %{_prefix}/share/games/armagetronad/sound
147 %{_prefix}/share/games/armagetronad/sound/*.wav
148 %dir %{_prefix}/share/games/armagetronad/textures
149 %{_prefix}/share/games/armagetronad/textures/*.jpg
150 %{_prefix}/share/games/armagetronad/textures/*.png
151 %if 0
152 #%attr(755,root,root) %{_bindir}/%{name}-stat
153 #%dir %{_prefix}/games/%{name}
154 #%{_prefix}/games/%{name}/arenas
155 #%dir %{_prefix}/games/%{name}/bin
156 #%attr(755,root,root) %{_prefix}/games/%{name}/bin/[ap]*
157 #%dir %{_prefix}/games/%{name}/language
158 #%{_prefix}/games/%{name}/language/languages.txt
159 #%{_prefix}/games/%{name}/language/english.txt
160 #%lang(de) %{_prefix}/games/%{name}/language/deutsch.txt
161 #%{_prefix}/games/%{name}/models
162 #%{_prefix}/games/%{name}/sound
163 #%{_prefix}/games/%{name}/textures
164 #%{_desktopdir}/*.desktop
165 #%{_pixmapsdir}/*
166 %endif
167
168 %files moviepack
169 %defattr(644,root,root,755)
170 #%%doc moviepack/art_read_me.txt
171 #%%{_prefix}/games/%{name}/moviepack
172
173 %files server
174 %defattr(644,root,root,755)
175 %if 0
176 %attr(755,root,root) %{_bindir}/armagetronad-dedicated
177 %dir %{_prefix}/games/armagetronad-dedicated
178 %{_datadir}/games/armagetronad-dedicated/bin
179 %attr(755,root,root) %{_prefix}/games/armagetronad-dedicated/bin/*
180 %exclude %{_prefix}/games/armagetronad-dedicated/bin/uninstall
181 %{_prefix}/games/armagetronad-dedicated/language
182 %dir %{_sysconfdir_server}
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir_server}/*.cfg
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir_server}/*.srv
185 %endif
This page took 0.072582 seconds and 3 git commands to generate.