]> git.pld-linux.org Git - packages/armagetron.git/blob - armagetron.spec
- typo
[packages/armagetron.git] / armagetron.spec
1 #
2 # TODO: start scripts for server
3 Summary:        A Tron lightcycle game with focus on multiplayer mode
4 Summary(pl):    Gra Tron ze ¶wiat³ocyklem skupiaj±ca siê na trybie dla wielu graczy
5 Name:           armagetron
6 Version:        0.2.6.0
7 Release:        4.1
8 License:        GPL
9 Group:          X11/Applications/Games
10 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
11 # Source0-md5:  602d3f3c942e3ed06bcc2e9c7e39abf7
12 Source1:        %{name}.desktop
13 Source2:        %{name}.png
14 Source3:        http://armagetron.sourceforge.net/addons/moviepack.zip
15 # Source3-md5:  e2d40309dde7e1339ca6aff7599cdfa3
16 Patch0:         %{name}-types.patch
17 URL:            http://armagetron.sourceforge.net/
18 Requires:       %{name}-common = %{version}-%{release}
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  unzip
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # it installs data in %{_prefix}/games, so...
28 %define         _bindir         /usr/bin
29 %define         _prefix         /usr/%{_lib}
30 %define         _sysconfdir     /etc/%{name}
31
32 %description
33 In Armagetron, you ride a lightcycle around the game grid. You can
34 only make sharp turns of 90 degrees and a wall constantly builds up
35 after you. Make your enemies crash into your wall, but be aware that
36 they are trying to do the same to you. If you are fast enough, you may
37 be able to trap them, but the only way to speed up your lightcycle is
38 to drive close to the dangerous walls. Prepare for exciting strategic
39 preparations followed by action-packed close combat!
40
41 %description -l pl
42 W grze Armagetron jedzie siê ¶wiat³ocyklem dooko³a planszy. Mo¿na
43 wykonywaæ tylko ostre zakrêty o 90 stopni, a za graczem ci±gle buduje
44 siê ¶ciana. Trzeba spowodowaæ, by wrogowie roztrzaskali siê na tej
45 ¶cianie, ale tak¿e uwa¿aæ, bo oni próbuj± zrobiæ to samo. Je¶li gracz
46 jest szybki, mo¿e z³apaæ ich wszystkich, ale jedynym sposobem na
47 przyspieszenie ¶wiat³ocyklu jest jazda blisko niebezpiecznych ¶cian.
48 Trzeba siê przygotowaæ na ekscytuj±ce strategiczne przygotowania i
49 nastêpuj±c± po nich walkê w zbli¿eniu!
50
51 %package moviepack
52 Summary:        Moviepack addon
53 Summary(pl):    Dodatek Moviepack
54 Group:          X11/Applications/Games
55 Requires:       %{name} = %{version}-%{release}
56
57 %description moviepack
58 Moviepack addon.
59
60 %description moviepack -l pl
61 Dodatek Moviepack.
62
63 %package common
64 Summary:        Common files for armagetron
65 Summary(pl):    Pliki wspólne dla armagetron
66 Group:          Applications/Games
67
68 %description common
69 Common files for armagetron server and player game.
70
71 %description common -l pl
72 Pliki wspólne armagetron-a dla serwera i trybu gracza.
73
74 %package server
75 Summary:        Armagetron server.
76 Summary(pl):    Armagetron serwer
77 Group:          Applications/Games
78 Requires:       %{name}-common = %{version}-%{release}
79
80 %description server
81 Armagetron server.
82
83 %description server -l pl 
84 Armagetron serwer.
85
86 %prep
87 %setup -q -a3
88 %patch0 -p1
89
90 %{__perl} -pi -e 's@/usr/lib@/usr/%{_lib}@;s@X11R6/lib@X11R6/%{_lib}@' configure.in
91
92 %build
93 cp -f /usr/share/automake/config.sub .
94 %{__aclocal}
95 %{__autoconf}
96
97 %configure   --disable-glout
98 %{__make} bindist
99 mv bindist bindist-dedicated
100
101 %configure
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
107         $RPM_BUILD_ROOT%{_prefix}/games/%{name}/moviepack
108
109 %{__make} install
110
111 cd bindist-dedicated
112 ./install
113 cd ..
114
115 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT%{_bindir}
116
117 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
118 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
119
120 cp -R moviepack $RPM_BUILD_ROOT%{_prefix}/games/%{name}
121 rm -f $RPM_BUILD_ROOT%{_prefix}/games/%{name}/moviepack/art_read_me.txt
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc CHANGELOG doc/*.html doc/net
129 %attr(755,root,root) %{_bindir}/%{name}
130 %attr(755,root,root) %{_bindir}/%{name}-stat
131 %dir %{_prefix}/games/%{name}
132 %{_prefix}/games/%{name}/arenas
133 %dir %{_prefix}/games/%{name}/bin
134 %attr(755,root,root) %{_prefix}/games/%{name}/bin/[ap]*
135 %dir %{_prefix}/games/%{name}/language
136 %{_prefix}/games/%{name}/language/languages.txt
137 %{_prefix}/games/%{name}/language/english.txt
138 %lang(de) %{_prefix}/games/%{name}/language/deutsch.txt
139 %{_prefix}/games/%{name}/models
140 %{_prefix}/games/%{name}/sound
141 %{_prefix}/games/%{name}/textures
142 %{_desktopdir}/*
143 %{_pixmapsdir}/*
144
145 %files moviepack
146 %defattr(644,root,root,755)
147 %doc moviepack/art_read_me.txt
148 %{_prefix}/games/%{name}/moviepack
149
150 %files server 
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/armagetron-dedicated
153 %dir %{_prefix}/games/armagetron-dedicated
154 %{_prefix}/games/armagetron-dedicated/bin
155 %attr(755,root,root) %{_prefix}/games/armagetron-dedicated/bin/*
156 %exclude %{_prefix}/games/armagetron-dedicated/bin/uninstall
157 %{_prefix}/games/armagetron-dedicated/language
158 #%%dir %{_prefix}/games/armagetron-dedicated/rc.d
159 #%%attr(755,root,root) %{_prefix}/games/armagetron-dedicated/rc.d/*
160
161 %files common
162 %defattr(644,root,root,755)
163 %dir %{_sysconfdir}
164 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.cfg
165 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.srv
This page took 1.337378 seconds and 3 git commands to generate.