]> git.pld-linux.org Git - packages/armadillo.git/blob - armadillo.spec
efdfb101469457397fb90968bffdff65f4da5f03
[packages/armadillo.git] / armadillo.spec
1 Summary:        C++ linear algebra library
2 Summary(pl.UTF-8):      Biblioteka C++ do algebry liniowej
3 Name:           armadillo
4 Version:        10.1.2
5 Release:        1
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/arma/%{name}-%{version}.tar.xz
9 # Source0-md5:  1419e8ef00a8e08a34a5e2e1164ef042
10 URL:            http://arma.sourceforge.net/
11 BuildRequires:  SuperLU-devel >= 5
12 BuildRequires:  arpack-devel
13 BuildRequires:  blas-devel
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  hdf5-devel
16 BuildRequires:  lapack-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  rpmbuild(macros) >= 1.752
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Armadillo is a C++ linear algebra library (matrix maths) aiming
26 towards a good balance between speed and ease of use. The syntax is
27 deliberately similar to Matlab.
28
29 %description -l pl.UTF-8
30 Armadillo to biblioteka C++ do algebry liniowej (obliczeń na
31 macierzach), której celem jest dobry kompromis między szybkością a
32 łatwością użycia. Składnia jest celowo podobna do Matlaba.
33
34 %package devel
35 Summary:        Header files for Armadillo library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Armadillo
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       SuperLU-devel >= 5
40 Requires:       arpack-devel
41 Requires:       blas-devel
42 Requires:       hdf5-devel
43 Requires:       lapack-devel
44 Requires:       libstdc++-devel
45 Obsoletes:      armadillo-static
46
47 %description devel
48 Header files for Armadillo library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki Armadillo.
52
53 %package apidocs
54 Summary:        Armadillo API documentation
55 Summary(pl.UTF-8):      Dokumentacja API biblioteki Armadillo
56 Group:          Documentation
57 BuildArch:      noarch
58
59 %description apidocs
60 API and internal documentation for Armadillo library.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API biblioteki Armadillo.
64
65 %prep
66 %setup -q
67
68 %build
69 %cmake . \
70         -DDETECT_HDF5=ON \
71         -DINSTALL_LIB_DIR=%{_libdir}
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc LICENSE.txt README.md docs.html
90 %attr(755,root,root) %{_libdir}/libarmadillo.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libarmadillo.so.10
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libarmadillo.so
96 %{_includedir}/armadillo
97 %{_includedir}/armadillo_bits
98 %{_pkgconfigdir}/armadillo.pc
99 %dir %{_datadir}/Armadillo
100 %{_datadir}/Armadillo/CMake
101
102 %files apidocs
103 %defattr(644,root,root,755)
104 %doc docs.html armadillo_icon.png armadillo_nicta_2010.pdf rcpp_armadillo_csda_2014.pdf
This page took 0.057802 seconds and 2 git commands to generate.