]> git.pld-linux.org Git - packages/armadillo.git/blob - armadillo.spec
80fc0490fb0408888440f33959dd466ffe440960
[packages/armadillo.git] / armadillo.spec
1 Summary:        C++ linear algebra library
2 Summary(pl.UTF-8):      Biblioteka C++ do algebry liniowej
3 Name:           armadillo
4 Version:        5.200.2
5 Release:        1
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/arma/%{name}-%{version}.tar.gz
9 # Source0-md5:  ef57ba4c473a3b67c672441a7face09e
10 URL:            http://arma.sourceforge.net/
11 BuildRequires:  SuperLU-devel >= 4
12 BuildRequires:  arpack-devel
13 BuildRequires:  blas-devel
14 BuildRequires:  boost-devel >= 1.34
15 BuildRequires:  cmake >= 2.8
16 BuildRequires:  hdf5-devel
17 BuildRequires:  lapack-devel
18 BuildRequires:  libstdc++-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Armadillo is a C++ linear algebra library (matrix maths) aiming
23 towards a good balance between speed and ease of use. The syntax is
24 deliberately similar to Matlab.
25
26 %description -l pl.UTF-8
27 Armadillo to biblioteka C++ do algebry liniowej (obliczeń na
28 macierzach), której celem jest dobry kompromis między szybkością a
29 łatwością użycia. Składnia jest celowo podobna do Matlaba.
30
31 %package devel
32 Summary:        Header files for Armadillo library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Armadillo
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       SuperLU >= 4
37 Requires:       arpack-devel
38 Requires:       blas-devel
39 Requires:       boost-devel >= 1.34
40 Requires:       hdf5-devel
41 Requires:       lapack-devel
42 Requires:       libstdc++-devel
43
44 %description devel
45 Header files for Armadillo library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki Armadillo.
49
50 %package static
51 Summary:        Static Armadillo library
52 Summary(pl.UTF-8):      Statyczna biblioteka Armadillo
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static Armadillo library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka Armadillo.
61
62 %package apidocs
63 Summary:        Armadillo API documentation
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki Armadillo
65 Group:          Documentation
66
67 %description apidocs
68 API and internal documentation for Armadillo library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki Armadillo.
72
73 %prep
74 %setup -q
75
76 %build
77 %cmake . \
78         -DINSTALL_LIB_DIR=%{_libdir}
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc LICENSE.txt README.txt
97 %attr(755,root,root) %{_libdir}/libarmadillo.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libarmadillo.so.5
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libarmadillo.so
103 %{_includedir}/armadillo
104 %{_includedir}/armadillo_bits
105 %dir %{_datadir}/Armadillo
106 %{_datadir}/Armadillo/CMake
This page took 0.04442 seconds and 2 git commands to generate.