]> git.pld-linux.org Git - packages/argus.git/blob - argus.spec
- adapter
[packages/argus.git] / argus.spec
1 # TODO
2 # - configure without options not working
3 #
4 # Conditional build:
5 %bcond_without  tcp_wrappers    # build with tcp_wrappers support
6 %bcond_without  sasl            # build with sasl support
7 #
8 %define         _ver_major      3.0
9 %define         _ver_minor      0
10 %define         _rc             rc.40
11 %define         _rel    0.2
12 Summary:        Real time network flow monitor
13 Summary(pl.UTF-8):      Monitor obciążenia sieci czasu rzeczywistego
14 Name:           argus
15 Version:        %{_ver_major}.%{_ver_minor}
16 Release:        0.%{_rc}.%{_rel}
17 License:        GPL v2
18 Group:          Applications/Networking
19 Source0:        ftp://qosient.com/dev/argus-%{_ver_major}/%{name}-%{version}.%{_rc}.tar.gz
20 # Source0-md5:  49047be6450c6255cceb3fb9bfe3caed
21 Source1:        %{name}.conf
22 Source2:        %{name}.init
23 Source3:        %{name}.sysconfig
24 Source4:        %{name}.logrotate
25 URL:            http://www.qosient.com/argus/
26 BuildRequires:  bison
27 %{?with_tcp_wrappers:BuildRequires:     cyrus-sasl-devel}
28 BuildRequires:  libpcap-devel
29 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
30 BuildRequires:  rpmbuild(macros) >= 1.268
31 Requires(post,preun):   /sbin/chkconfig
32 Requires:       rc-scripts
33 Provides:       group(argus)
34 Provides:       user(argus)
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Argus is a Real Time Flow Monitor designed to track and report on the
39 status and performance of all network transactions seen in a data
40 network traffic stream. It is similiar to Cisco NetFlow, however more
41 powerful and with different data format.
42
43 %description -l pl.UTF-8
44 Argus jest monitorem sieci czasu rzeczywistego zaprojektowanym do
45 śledzenia i raportowania stanu sieci oraz wszelkiego typu transakcji
46 strumieni danych. Jest bardzo podobny do NetFlow z Cisco, jednak
47 bardziej rozbudowany i posiada inny format danych.
48
49 %prep
50 %setup -q -n %{name}-%{version}.%{_rc}
51
52 %build
53 %configure \
54         --with%{!?with_tcp_wrappers:out}-libwrap \
55         --with%{!?with_sasl:out}-sasl
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
62 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig}
63 install -d $RPM_BUILD_ROOT%{_var}/log/%{name}
64
65 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
66 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
67 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
68 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
69
70 touch $RPM_BUILD_ROOT%{_var}/log/%{name}/%{name}.log
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %pre
79 %groupadd -g 214 -r argus
80 %useradd -M -o -r -u 214 -d /usr/share/empty -s /bin/sh -g argus -c "argus daemon" argus
81
82 %post
83 /sbin/chkconfig --add %{name}
84 %service %{name} restart
85
86 %preun
87 if [ "$1" = "0" ]; then
88         %service -q %{name} stop
89         /sbin/chkconfig --del %{name}
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc CREDITS ChangeLog README doc/{CHANGES,FAQ,HOW-TO}
95 %attr(755,root,root) %{_bindir}/argusbug
96 %attr(755,root,root) %{_sbindir}/argus
97 %attr(754,root,root) /etc/rc.d/init.d/%{name}
98 %dir %{_sysconfdir}/%{name}
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
100 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
101 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
102 %dir %{_var}/log/%{name}
103 %attr(640,argus,root,) %ghost %{_var}/log/%{name}/%{name}.log
104 %{_mandir}/man5/argus.conf.5*
105 %{_mandir}/man8/argus.8*
This page took 0.076886 seconds and 3 git commands to generate.