]> git.pld-linux.org Git - packages/arena.git/blob - arena.spec
- forgotten md5 for source
[packages/arena.git] / arena.spec
1 Summary:        Arena Scripting Language with syntax and library similar to ANSI C
2 Summary(pl):    Jêzyk skryptowy Arena ze sk³adni± i bibliotek± podobn± do ANSI C
3 Name:           arena
4 Version:        0.9.8
5 Release:        0.1
6 License:        distributable   
7 Group:          Development/Languages
8 Source0:        http://www.minimalinux.org/arena/%{name}-%{version}.tar.gz
9 # Source0-md5:  a1feb6df9014c4a1e89bf3f96b50f94e
10 URL:            http://www.minimalinux.org/arena/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  pcre-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Arena, a light-weight scripting language. The language uses a syntax
18 and library similar to that of ANSI C, but adds automatic memory
19 management and runtime polymorphism on top of that.
20 The Arena language was designed with the following main features
21 in mind, most of which were added on top of a very C-like core to
22 support:
23 - better ad-hoc scripting: 
24 - syntax similar to ANSI C
25 - standard library similar to ANSI C
26 - automatic memory management
27 - runtime polymorphism
28 - support for exceptions
29 - support for anonymous functions
30
31 Additionally, an interpreter for the Arena language can be
32 implemented to be very compact in terms of both source code size
33 and memory consumption.
34
35 #%%description -l pl
36
37 %package examples
38 Summary:        Examples for Arena Scripting Language
39 Summary(pl):    Przyk³ady dla jêzyka skryptowego arena
40 Group:          Development/Languages
41
42 %description examples
43 Examples for Arena Scripting Language.
44
45 #%%description examples -l pl
46
47 %prep
48 %setup -q
49
50 %build
51 %{__autoconf}
52 cp -f /usr/share/automake/config.sub .
53 %configure
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 cp -f doc/manual/transform $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc doc/CHANGES doc/CREDITS doc/HACKING doc/LICENSE doc/NEWS doc/TODO doc/manual/manual.asc
71 %attr(755,root,root) %{_bindir}/*
72 %{_mandir}/man1/arena.1*
73
74 %files examples
75 %defattr(644,root,root,755)
76 %{_examplesdir}/%{name}-%{version}
This page took 0.072496 seconds and 3 git commands to generate.