]> git.pld-linux.org Git - packages/arena.git/blob - arena.spec
- added
[packages/arena.git] / arena.spec
1 Summary:        Arena Scripting Language with syntax and library similar to ANSI C
2 Summary(pl):    Jêzyk skryptowy Arena ze sk³adni± i bibliotek± podobn± do ANSI C
3 Name:           arena
4 Version:        0.9.8
5 Release:        0.1
6 License:        distributable   
7 Group:          Development/Languages
8 Source0:        http://www.minimalinux.org/arena/%{name}-%{version}.tar.gz
9 URL:            http://www.minimalinux.org/arena/
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  pcre-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Arena, a light-weight scripting language. The language uses a syntax
17 and library similar to that of ANSI C, but adds automatic memory
18 management and runtime polymorphism on top of that.
19 The Arena language was designed with the following main features
20 in mind, most of which were added on top of a very C-like core to
21 support:
22 - better ad-hoc scripting: 
23 - syntax similar to ANSI C
24 - standard library similar to ANSI C
25 - automatic memory management
26 - runtime polymorphism
27 - support for exceptions
28 - support for anonymous functions
29
30 Additionally, an interpreter for the Arena language can be
31 implemented to be very compact in terms of both source code size
32 and memory consumption.
33
34 #%%description -l pl
35
36 %package examples
37 Summary:        Examples for Arena Scripting Language
38 Summary(pl):    Przyk³ady dla jêzyka skryptowego arena
39 Group:          Development/Languages
40
41 %description examples
42 Examples for Arena Scripting Language.
43
44 #%%description examples -l pl
45
46 %prep
47 %setup -q
48
49 %build
50 %{__autoconf}
51 cp -f /usr/share/automake/config.sub .
52 %configure
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 cp -f doc/manual/transform $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc doc/CHANGES doc/CREDITS doc/HACKING doc/LICENSE doc/NEWS doc/TODO doc/manual/manual.asc
70 %attr(755,root,root) %{_bindir}/*
71 %{_mandir}/man1/arena.1*
72
73 %files examples
74 %defattr(644,root,root,755)
75 %{_examplesdir}/%{name}-%{version}
This page took 0.164322 seconds and 3 git commands to generate.