]> git.pld-linux.org Git - packages/arena.git/blob - arena.spec
7b3a6cc823137d38fe23c4ce96e8f7c00f7dfeec
[packages/arena.git] / arena.spec
1 Summary:        Arena Scripting Language with syntax and library similar to ANSI C
2 Summary(pl.UTF-8):      Język skryptowy Arena ze składnią i biblioteką podobną do ANSI C
3 Name:           arena
4 Version:        0.9.9
5 Release:        2
6 License:        distributable   
7 Group:          Development/Languages
8 Source0:        http://www.minimalinux.org/arena/%{name}-%{version}.tar.gz
9 # Source0-md5:  16005f68f784d9062feccfaa83c1ad03
10 URL:            http://www.minimalinux.org/arena/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  pcre-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Arena, a light-weight scripting language. The language uses a syntax
18 and library similar to that of ANSI C, but adds automatic memory
19 management and runtime polymorphism on top of that.
20 The Arena language was designed with the following main features
21 in mind, most of which were added on top of a very C-like core to
22 support:
23 - better ad-hoc scripting: 
24 - syntax similar to ANSI C
25 - standard library similar to ANSI C
26 - automatic memory management
27 - runtime polymorphism
28 - support for exceptions
29 - support for anonymous functions
30
31 Additionally, an interpreter for the Arena language can be
32 implemented to be very compact in terms of both source code size
33 and memory consumption.
34
35 %description -l pl.UTF-8
36 Arena to lekki język skryptowy. Język wykorzystuje składnię i
37 bibliotekę podobne do ANSI C, ale dodaje do tego automatyczne
38 zarządzanie pamięcią i polimorfizm. Język Arena został zaprojektowany
39 z myślą o następujących cechach, z których większość została dodana
40 do rdzenia bardzo podobnego do C:
41 - lepsze tworzenie skryptów ad-hoc
42 - składnia podobna do ANSI C
43 - biblioteka standardowa podobna do ANSI C
44 - automatyczne zarządzanie pamięcią
45 - polimorfizm
46 - obsługa wyjątków
47 - obsługa anonimowych funkcji
48
49 Ponadto interpreter języka Arena może być zaimplementowany jako bardzo
50 zwarty w sensie zarówno rozmiaru kodu źródłowego, jak i wykorzystania
51 pamięci.
52
53 %package examples
54 Summary:        Examples for Arena Scripting Language
55 Summary(pl.UTF-8):      Przykłady dla języka skryptowego Arena
56 Group:          Development/Languages
57
58 %description examples
59 Examples for Arena Scripting Language.
60
61 %description examples -l pl.UTF-8
62 Przykłady dla języka skryptowego Arena.
63
64 %prep
65 %setup -q
66
67 %build
68 %{__autoconf}
69 cp -f /usr/share/automake/config.sub .
70 %configure
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 cp -f doc/manual/transform $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81 cp -Rf examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README doc/CHANGES doc/CREDITS doc/HACKING doc/LICENSE doc/NEWS doc/TODO doc/manual/manual.asc
89 %attr(755,root,root) %{_bindir}/*
90 %{_mandir}/man1/arena.1*
91
92 %files examples
93 %defattr(644,root,root,755)
94 %{_examplesdir}/%{name}-%{version}
This page took 0.050429 seconds and 2 git commands to generate.