]> git.pld-linux.org Git - packages/ardour.git/commitdiff
- added system-libs patch, regenerate ac/am (for system libsigc++1 and gtkmm1)
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 14 Jul 2003 23:18:47 +0000 (23:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  (includes workaround for LOCK define - it's an example why pure kernel
   headers shouldn't be used in user space, only the sanitized ones)
- finished pl

Changed files:
    ardour-system-libs.patch -> 1.1
    ardour.spec -> 1.3

ardour-system-libs.patch [new file with mode: 0644]
ardour.spec

diff --git a/ardour-system-libs.patch b/ardour-system-libs.patch
new file mode 100644 (file)
index 0000000..a5dde3a
--- /dev/null
@@ -0,0 +1,84 @@
+--- ardour-0.9beta2/aclocal.m4.orig    2003-06-29 02:45:29.000000000 +0200
++++ ardour-0.9beta2/aclocal.m4 2003-07-15 00:02:13.000000000 +0200
+@@ -806,19 +806,19 @@
+ ARDOUR_TOP=`cd $ARDOUR_TOP; pwd`
+-export LIBDIRS="sigc++ pbd soundtouch midi++ ardour gtkmm gtkmmext gtk-canvas"
++export LIBDIRS="pbd soundtouch midi++ ardour gtkmmext gtk-canvas"
+ ACLOCAL_FLAGS="-I $ARDOUR_TOP/aclocal"
+ ACLOCAL_AMFLAGS="-I $ARDOUR_TOP/aclocal `if test -d m4 ; then echo -I m4; fi`"
+ AC_SUBST(ACLOCAL_FLAGS)
+ AC_SUBST(ACLOCAL_AMFLAGS)
+-BASE_LIBS="$ARDOUR_TOP/libs/midi++/libmidipp.a $ARDOUR_TOP/libs/pbd/libpbd.a $ARDOUR_TOP/libs/sigc++/sigc++/libsigc.a"
+-BASE_INCLUDES="-I$ARDOUR_TOP/libs/sigc++ -I$ARDOUR_TOP/libs/sigc++/sigc++/config -I$ARDOUR_TOP/libs/pbd -I$ARDOUR_TOP/libs/midi++ -I$ARDOUR_TOP/libs/ardour -I$ARDOUR_TIP/libs/soundtouch"
+-GUI_LIBS="$ARDOUR_TOP/libs/gtkmmext/libgtkmmext.a $ARDOUR_TOP/libs/midi++/libmidipp.a $ARDOUR_TOP/libs/gtk-canvas/libgtk-canvas.a $ARDOUR_TOP/libs/gtkmm/src/gtk--/libgtkmm.a $ARDOUR_TOP/libs/gtkmm/gdk--/gdk--/libgdkmm.a"
+-GUI_INCLUDES="-I$ARDOUR_TOP/libs/ -I$ARDOUR_TOP/libs/gtk-canvas -I$ARDOUR_TOP/libs/gtk-canvas/gtk-canvas -I$ARDOUR_TOP/libs/gtkmmext -I$ARDOUR_TOP/libs/gtkmm/gdk-- -I$ARDOUR_TOP/libs/gtkmm/src -I$ARDOUR_TOP/libs/gtkmm"
+-CFLAGS="$CFLAGS -I$ARDOUR_TOP/libs/sigc++ -I$ARDOUR_TOP/libs/sigc++/sigc++/config -I$ARDOUR_TOP/libs/pbd -I$ARDOUR_TOP/libs/midi++ -I$ARDOUR_TOP/libs/ardour -I$ARDOUR_TOP/libs/soundtouch"
+-CXXFLAGS="$CXXFLAGS -I$ARDOUR_TOP/libs/sigc++ -I$ARDOUR_TOP/libs/sigc++/sigc++/config -I$ARDOUR_TOP/libs/pbd -I$ARDOUR_TOP/libs/midi++ -I$ARDOUR_TOP/libs/ardour -I$ARDOUR_TOP/libs/soundtouch"
+-LIBS="$LIBS $ARDOUR_TOP/libs/soundtouch/libsoundtouch.a $ARDOUR_TOP/libs/midi++/libmidipp.a $ARDOUR_TOP/libs/pbd/libpbd.a $ARDOUR_TOP/libs/sigc++/sigc++/libsigc.a"
++BASE_LIBS="$ARDOUR_TOP/libs/midi++/libmidipp.a $ARDOUR_TOP/libs/pbd/libpbd.a `sigc-config --libs`"
++BASE_INCLUDES="`sigc-config --cflags` -I$ARDOUR_TOP/libs/pbd -I$ARDOUR_TOP/libs/midi++ -I$ARDOUR_TOP/libs/ardour -I$ARDOUR_TIP/libs/soundtouch"
++GUI_LIBS="$ARDOUR_TOP/libs/gtkmmext/libgtkmmext.a $ARDOUR_TOP/libs/midi++/libmidipp.a $ARDOUR_TOP/libs/gtk-canvas/libgtk-canvas.a `gtkmm-config --libs`"
++GUI_INCLUDES="-I$ARDOUR_TOP/libs/ -I$ARDOUR_TOP/libs/gtk-canvas -I$ARDOUR_TOP/libs/gtk-canvas/gtk-canvas -I$ARDOUR_TOP/libs/gtkmmext `gtkmm-config --cflags`"
++CFLAGS="$CFLAGS `sigc-config --cflags` -I$ARDOUR_TOP/libs/pbd -I$ARDOUR_TOP/libs/midi++ -I$ARDOUR_TOP/libs/ardour -I$ARDOUR_TOP/libs/soundtouch"
++CXXFLAGS="$CXXFLAGS `sigc-config --cflags` -I$ARDOUR_TOP/libs/pbd -I$ARDOUR_TOP/libs/midi++ -I$ARDOUR_TOP/libs/ardour -I$ARDOUR_TOP/libs/soundtouch"
++LIBS="$LIBS $ARDOUR_TOP/libs/soundtouch/libsoundtouch.a $ARDOUR_TOP/libs/midi++/libmidipp.a $ARDOUR_TOP/libs/pbd/libpbd.a `sigc-config --libs`"
+ ])
+--- ardour-0.9beta2/libs/configure.ac.orig     2003-06-24 05:11:36.000000000 +0200
++++ ardour-0.9beta2/libs/configure.ac  2003-07-15 00:03:21.000000000 +0200
+@@ -5,10 +5,10 @@
+ AM_BUILD_ENVIRONMENT
+-AC_CONFIG_SUBDIRS(sigc++ pbd soundtouch midi++ ardour)
++AC_CONFIG_SUBDIRS(pbd soundtouch midi++ ardour)
+ if test x$WITH_GTK_GUI != x ; then
+-   AC_CONFIG_SUBDIRS(gtkmm gtkmmext gtk-canvas)
++   AC_CONFIG_SUBDIRS(gtkmmext gtk-canvas)
+ fi
+ if test x$WITH_VST_WIN != x ; then
+--- ardour-0.9beta2/gtk_ardour/editor_audiotrack.cc.orig       2003-06-24 05:11:35.000000000 +0200
++++ ardour-0.9beta2/gtk_ardour/editor_audiotrack.cc    2003-07-15 00:57:21.000000000 +0200
+@@ -1,11 +1,12 @@
+-#include <ardour/location.h>
+-#include <ardour/diskstream.h>
+-
+ #include "editor.h"
+ #include "audio_time_axis.h"
+ #include "regionview.h"
+ #include "selection.h"
++/* must be after Gtk-- includes - LOCK define conflict */
++#include <ardour/location.h>
++#include <ardour/diskstream.h>
++
+ using namespace ARDOUR;
+ void
+--- ardour-0.9beta2/gtk_ardour/selection.cc.orig       2003-06-24 05:11:35.000000000 +0200
++++ ardour-0.9beta2/gtk_ardour/selection.cc    2003-07-15 01:12:34.000000000 +0200
+@@ -22,8 +22,6 @@
+ #include <sigc++/bind.h>
+ #include <pbd/error.h>
+-#include <ardour/route.h>
+-
+ #include "regionview.h"
+ #include "selection.h"
+ #include "selection_templates.h"
+@@ -31,6 +29,9 @@
+ #include "i18n.h"
++/* must be after Gtk-- includes - LOCK define conflict */
++#include <ardour/route.h>
++
+ using namespace ARDOUR;
+ using namespace SigC;
index be183e0c432bc1f39d38d079a1ac95732d7aee07..0230896be4b44fa0a5582831ed2d4175fdf40ba3 100644 (file)
@@ -1,31 +1,38 @@
 # TODO:
 # - use external libraries if possible (sigc++1 and gtkmm1)
-# - pl descs
 # - .desktop
 # - check BR (ladspa - is it really needed at compile time?)
+# - optflags (in gtk_ardour, libs/{ardour,gtkmmext,midi++,pbd,soundtouch}
 #
 %define                _beta beta2
 Summary:       Multitrack hard disk recorder
-Summary(pl):   Wieloscie¿kowy ...
+Summary(pl):   Wieloscie¿kowy magnetofon nagrywaj±cy na twardym dysku
 Name:          ardour
 Version:       0.9
 Release:       0.%{_beta}.1
 License:       GPL
 Group:         X11/Applications/Sound
-Source0:       http://dl.sourceforge.net/sourceforge/ardour/%{name}-%{version}%{_beta}.tar.bz2
+Source0:       http://dl.sourceforge.net/ardour/%{name}-%{version}%{_beta}.tar.bz2
 # Source0-md5: 91db0b724e5183e7c92408a986aa17ea
+Patch0:                %{name}-system-libs.patch
 URL:           http://ardour.sourceforge.net/
 BuildRequires: XFree86-devel
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
 BuildRequires: alsa-lib-devel >= 0.9.0
-BuildRequires: gtk+-devel
+BuildRequires: gtk+-devel >= 1.0.0
+BuildRequires: gtkmm1-devel >= 1.2.6
 BuildRequires: jack-audio-connection-kit-devel >= 0.66.0
 BuildRequires: ladspa-devel
 BuildRequires: libart_lgpl >= 2.3
 BuildRequires: liblrdf-devel >= 0.3.0
 BuildRequires: libsamplerate-devel >= 0.0.13
+BuildRequires: libsigc++1-devel >= 0.8.8
 BuildRequires: libsndfile-devel >= 1.0.0
 BuildRequires: libstdc++-devel
-BuildRequires: libxml2 >= 2.5.0
+BuildRequires: libtool
+BuildRequires: libxml2-devel >= 2.5.0
+BuildRequires: pkgconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -35,11 +42,62 @@ samples, 24+ channels at up to 96kHz, full MMC control,
 non-destructive, non-linear editor, LADSPA plugins.
 
 %description -l pl
+"Profesjonalny" wielo¶cie¿kowy, wielokana³owy magnetofon oraz DAW dla
+Linuksa, wykorzystuj±cy interfejsu d¼wiêkowe obs³ugiwane przez ALSA.
+Obs³uguje próbki do 32 bitów, 24+ kana³ów do 96kHz, pe³n± kontrolê
+MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
 
 %prep
 %setup -q -n %{name}-%{version}%{_beta}
+%patch -p1
+
+install -d m4
+# extract AM_BUILD_ENVIRONMENT (patched!)
+tail +787 aclocal.m4 > m4/buildenv.m4
+# AC_UNIQUIFY_{LAST,FIRST}
+tail +6685 libs/ardour/aclocal.m4 >> m4/buildenv.m4
+# AC_POSIX_RTSCHED
+tail +870 libs/pbd/aclocal.m4 | head -118 >> m4/buildenv.m4
 
 %build
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
+cd gtk_ardour
+%{__aclocal} -I ../m4
+%{__autoconf}
+%{__automake}
+cd ../libs
+%{__libtoolize}
+%{__aclocal} -I ../m4
+%{__autoconf}
+%{__automake}
+cd ardour
+%{__libtoolize}
+%{__aclocal} -I ../../m4
+%{__autoconf}
+%{__automake}
+cd ../gtk-canvas
+%{__aclocal} -I ../../m4
+%{__autoconf}
+%{__automake}
+cd ../gtkmmext
+%{__aclocal} -I ../../m4
+%{__autoconf}
+%{__automake}
+cd ../midi++
+%{__aclocal} -I ../../m4
+%{__autoconf}
+%{__automake}
+cd ../pbd
+%{__aclocal} -I ../../m4
+%{__autoconf}
+%{__automake}
+cd ../soundtouch
+%{__aclocal} -I ../../m4
+%{__autoconf}
+%{__automake}
+cd ../..
 # ksi doesn't build for a moment
 %configure \
        --disable-ksi
@@ -49,7 +107,8 @@ non-destructive, non-linear editor, LADSPA plugins.
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %find_lang %{name} --all-name
 
@@ -60,7 +119,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc ChangeLog README ReleaseNotes* TODO
 %attr(755,root,root) %{_bindir}/*
+%dir %{_datadir}/%{name}
 %{_datadir}/%{name}/pixmaps
 %{_datadir}/%{name}/splash.ppm
 %{_mandir}/man1/*
+%dir %{_sysconfdir}/ardour
 %{_sysconfdir}/ardour/*.rc
This page took 0.078737 seconds and 4 git commands to generate.