]> git.pld-linux.org Git - packages/ardour.git/commitdiff
enable video support auto/th/ardour-5.12.0-2
authorJacek Konieczny <jajcus@jajcus.net>
Tue, 23 Oct 2018 18:50:14 +0000 (20:50 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Tue, 23 Oct 2018 18:51:23 +0000 (20:51 +0200)
- Suggest xjadeo and harvid
- change ffmpeg executable names to those from our ffmpeg package

Release: 2

ardour.spec
ffmpeg_paths.patch [new file with mode: 0644]

index 6dedb7ca9ee126d69eaa405a5fb85278e16604cf..02b8c05be08fd075568ef7811f9c4cb580d429bf 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Multitrack hard disk recorder
 Summary(pl.UTF-8):     Wielościeżkowy magnetofon nagrywający na twardym dysku
 Name:          ardour
 Version:       5.12.0
-Release:       1
+Release:       2
 License:       GPL
 Group:         X11/Applications/Sound
 Source0:       https://community.ardour.org/srctar/Ardour-%{version}.tar.bz2
@@ -10,6 +10,7 @@ Source0:      https://community.ardour.org/srctar/Ardour-%{version}.tar.bz2
 Source1:       %{name}.desktop
 Patch0:                localedir.patch
 Patch1:                no_proc_build.patch
+Patch2:                ffmpeg_paths.patch
 URL:           http://ardour.org/
 BuildRequires: alsa-lib-devel >= 0.9.0
 BuildRequires: aubio-devel >= 0.4.0
@@ -48,6 +49,8 @@ BuildRequires:        udev-devel
 BuildRequires: vamp-devel >= 2.1
 BuildRequires: xorg-lib-libX11-devel >= 1.1
 Requires:      jack-audio-connection-kit-libs >= 0.121
+Suggests:      harvid
+Suggests:      xjadeo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoprovfiles        %{_libdir}/(ardour5|lv2)
@@ -77,6 +80,7 @@ MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 export CC="%{__cc}"
diff --git a/ffmpeg_paths.patch b/ffmpeg_paths.patch
new file mode 100644 (file)
index 0000000..edc6fde
--- /dev/null
@@ -0,0 +1,64 @@
+diff -dur -x '*~' Ardour-5.12.0.orig/gtk2_ardour/po/de.po Ardour-5.12.0/gtk2_ardour/po/de.po
+--- Ardour-5.12.0.orig/gtk2_ardour/po/de.po    2017-09-15 22:56:22.000000000 +0200
++++ Ardour-5.12.0/gtk2_ardour/po/de.po 2018-10-23 19:27:38.331895133 +0200
+@@ -16185,12 +16185,6 @@
+ "The tools are included with the %1 releases from ardour.org and also "
+ "available with the video-server at http://x42.github.com/harvid/\n"
+ "\n"
+-"Important: the files need to be installed in $PATH and named ffmpeg_harvid "
+-"and ffprobe_harvid.\n"
+-"If you already have a suitable ffmpeg installation on your system, we "
+-"recommend creating symbolic links from ffmpeg to ffmpeg_harvid and from "
+-"ffprobe to ffprobe_harvid.\n"
+-"\n"
+ "see also http://manual.ardour.org/video-timeline/setup/"
+ msgstr ""
+ "Auf diesem System konnte keine ffmpeg-Installation gefunden werden.\n"
+@@ -16200,12 +16194,6 @@
+ "Die Werkzeuge sind in den %1-Veröffentlichungen von ardour.org enthalten und "
+ "ebenfalls mit dem Videoserver auf http://x42.github.com/harvid/ erhältlich.\n"
+ "\n"
+-"Wichtig: Die Dateien müssen in $PATH installiert werden und nach "
+-"ffmpeg_harvid und ffprobe_harvid umbenannt werden.\n"
+-"Falls Sie eine geeignete ffmpeg-Installation auf Ihrem System haben, "
+-"empfehlen wir, symbolische Verknüpfungen von ffmpeg auf ffmpeg_harvid und "
+-"von ffprobe auf ffprobe_harvid zu erzeugen.\n"
+-"\n"
+ "Sehen Sie auch  http://manual.ardour.org/video-timeline/setup/"
+ #: transcode_video_dialog.cc:56
+diff -dur -x '*~' Ardour-5.12.0.orig/gtk2_ardour/transcode_ffmpeg.cc Ardour-5.12.0/gtk2_ardour/transcode_ffmpeg.cc
+--- Ardour-5.12.0.orig/gtk2_ardour/transcode_ffmpeg.cc 2017-09-15 22:56:22.000000000 +0200
++++ Ardour-5.12.0/gtk2_ardour/transcode_ffmpeg.cc      2018-10-23 19:27:09.621396487 +0200
+@@ -60,10 +60,6 @@
+                                       "The tools are included with the %1 releases from ardour.org "
+                                       "and also available with the video-server at http://x42.github.com/harvid/\n"
+                                       "\n"
+-                                      "Important: the files need to be installed in $PATH and named ffmpeg_harvid and ffprobe_harvid.\n"
+-                                      "If you already have a suitable ffmpeg installation on your system, we recommend creating "
+-                                      "symbolic links from ffmpeg to ffmpeg_harvid and from ffprobe to ffprobe_harvid.\n"
+-                                      "\n"
+                                       "see also http://manual.ardour.org/video-timeline/setup/"
+                                ), PROGRAM_NAME) << endmsg;
+               return;
+diff -dur -x '*~' Ardour-5.12.0.orig/gtk2_ardour/video_tool_paths.cc Ardour-5.12.0/gtk2_ardour/video_tool_paths.cc
+--- Ardour-5.12.0.orig/gtk2_ardour/video_tool_paths.cc 2017-09-15 22:56:22.000000000 +0200
++++ Ardour-5.12.0/gtk2_ardour/video_tool_paths.cc      2018-10-23 19:26:43.792949900 +0200
+@@ -166,7 +166,7 @@
+       ffprobe_exe = X_("");
+       std::string ff_file_path;
+-      if (find_file (Searchpath(Glib::getenv("PATH")), X_("ffmpeg_harvid"), ff_file_path)) {
++      if (find_file (Searchpath(Glib::getenv("PATH")), X_("ffmpeg"), ff_file_path)) {
+               ffmpeg_exe = ff_file_path;
+       }
+ #ifdef PLATFORM_WINDOWS
+@@ -194,7 +194,7 @@
+       }
+ #endif
+-      if (find_file (Searchpath(Glib::getenv("PATH")), X_("ffprobe_harvid"), ff_file_path)) {
++      if (find_file (Searchpath(Glib::getenv("PATH")), X_("ffprobe"), ff_file_path)) {
+               ffprobe_exe = ff_file_path;
+       }
+ #ifdef PLATFORM_WINDOWS
This page took 0.137552 seconds and 4 git commands to generate.