]> git.pld-linux.org Git - packages/ardour.git/blob - ardour.spec
c8cee920496a4afad96516437190a460263dfd71
[packages/ardour.git] / ardour.spec
1 # TODO
2 # - make it not to parse /proc/cpuinfo
3 Summary:        Multitrack hard disk recorder
4 Summary(pl.UTF-8):      Wielościeżkowy magnetofon nagrywający na twardym dysku
5 Name:           ardour
6 Version:        2.1
7 Release:        0.1
8 License:        GPL
9 Group:          X11/Applications/Sound
10 Source0:        http://ardour.org/files/releases/%{name}-%{version}.tar.bz2
11 # Source0-md5:  18be414a37b832aae23c068ba9fcf8ab
12 Source1:        %{name}.desktop
13 Patch0:         %{name}-c++.patch
14 Patch1:         %{name}-opt.patch
15 Patch2:         %{name}-stdint.patch
16 URL:            http://ardour.org/
17 BuildRequires:  alsa-lib-devel >= 0.9.0
18 BuildRequires:  boost-devel
19 BuildRequires:  gettext-devel
20 # included libsndfile needs patch (wants FLAC__seekable_stream_decoder_set_read_callback)
21 # (in ardour itself only one UI option depends on HAVE_FLAC)
22 BuildRequires:  cairomm-devel
23 BuildRequires:  fftw3-single-devel >= 3
24 BuildRequires:  flac-devel
25 BuildRequires:  glib2-devel >= 1:2.10.1
26 BuildRequires:  gtk+2-devel >= 2:2.8.1
27 BuildRequires:  gtkmm-devel >= 2.8.0
28 BuildRequires:  jack-audio-connection-kit-devel >= 0.101.1
29 BuildRequires:  libart_lgpl >= 2.3.16
30 BuildRequires:  libgnomecanvas-devel >= 2.0
31 BuildRequires:  libgnomecanvasmm-devel >= 2.12.0
32 BuildRequires:  liblo-devel
33 BuildRequires:  liblrdf-devel >= 0.4.0
34 BuildRequires:  libraptor-devel >= 1.4.2
35 BuildRequires:  libsamplerate-devel >= 0.1.2
36 BuildRequires:  libsigc++-devel >= 2.0
37 # internal one used
38 #BuildRequires: libsndfile-devel >= 1.0.0
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool
41 BuildRequires:  libusb-devel
42 BuildRequires:  libxml2-devel >= 1:2.6.0
43 BuildRequires:  libxslt-devel
44 BuildRequires:  pkgconfig >= 1:0.20
45 BuildRequires:  python >= 2.3.4
46 BuildRequires:  scons >= 0.96
47 BuildRequires:  soundtouch-devel >= 1.3.1
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 A "professional" multitrack, multichannel audio recorder and DAW for
52 Linux, using ALSA-supported audio interfaces. Supports up to 32 bit
53 samples, 24+ channels at up to 96kHz, full MMC control,
54 non-destructive, non-linear editor, LADSPA plugins.
55
56 %description -l pl.UTF-8
57 "Profesjonalny" wielościeżkowy, wielokanałowy magnetofon oraz DAW dla
58 Linuksa, wykorzystujący interfejsy dźwiękowe obsługiwane przez ALSA.
59 Obsługuje próbki do 32 bitów, 24+ kanałów do 96kHz, pełną kontrolę
60 MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 # NEEDS UPDATE for scons
66 #%patch1 -p1
67 %patch2 -p1
68
69 %build
70 # Make sure we have /proc mounted - it searches for flags from there
71 if [ ! -f /proc/cpuinfo ]; then
72         echo "You need to have /proc mounted in order to build this package!"
73         exit 1
74 fi
75 %scons \
76         PREFIX=%{_prefix} \
77         SYSLIBS=1 \
78 %ifarch %{x8664}
79         DIST_TARGET=x86_64
80 %else
81 %ifarch %{ix86}
82         DIST_TARGET=i386
83 %else
84         DIST_TARGET=none
85 %endif
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_desktopdir}
91
92 %scons install \
93         DESTDIR=$RPM_BUILD_ROOT \
94         PREFIX=%{_prefix} \
95         GTK=yes
96 #       KSI=yes
97
98 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
99
100 # it shouldn't be there
101 rm -f $RPM_BUILD_ROOT%{_datadir}/ardour/libardour.{la,a}
102
103 %find_lang %{name} --all-name
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc DOCUMENTATION/{AUTHORS,CONTRIBUTORS,FAQ,README,TODO,TRANSLATORS}
111 %lang(es) %doc DOCUMENTATION/{AUTHORS.es,CONTRIBUTORS.es,README.es}
112 %lang(fr) %doc DOCUMENTATION/README.fr
113 %lang(it) %doc DOCUMENTATION/README.it
114 %lang(ru) %doc DOCUMENTATION/README.ru
115 %attr(755,root,root) %{_bindir}/*
116 %{_datadir}/%{name}
117 %{_mandir}/man1/ardour.1*
118 %lang(es) %{_mandir}/es/man1/ardour.1*
119 %lang(fr) %{_mandir}/fr/man1/ardour.1*
120 %lang(ru) %{_mandir}/ru/man1/ardour.1*
121 %dir %{_sysconfdir}/ardour
122 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour/*.rc
123 %{_desktopdir}/ardour.desktop
This page took 0.051814 seconds and 2 git commands to generate.