]> git.pld-linux.org Git - packages/ardour.git/blob - ardour.spec
bc44bdd451dfa3b3a54c37f27cfc4538ccd40cee
[packages/ardour.git] / ardour.spec
1 # TODO
2 # - make it not to parse /proc/cpuinfo
3 Summary:        Multitrack hard disk recorder
4 Summary(pl.UTF-8):      Wielościeżkowy magnetofon nagrywający na twardym dysku
5 Name:           ardour
6 Version:        2.1
7 Release:        0.2
8 License:        GPL
9 Group:          X11/Applications/Sound
10 Source0:        http://ardour.org/files/releases/%{name}-%{version}.tar.bz2
11 # Source0-md5:  18be414a37b832aae23c068ba9fcf8ab
12 Source1:        %{name}.desktop
13 Patch0:         %{name}-c++.patch
14 Patch1:         %{name}-opt.patch
15 Patch2:         %{name}-stdint.patch
16 URL:            http://ardour.org/
17 BuildRequires:  alsa-lib-devel >= 0.9.0
18 BuildRequires:  boost-devel
19 BuildRequires:  cairomm-devel
20 BuildRequires:  fftw3-single-devel >= 3
21 BuildRequires:  flac-devel
22 BuildRequires:  gettext-devel
23 BuildRequires:  glib2-devel >= 1:2.10.1
24 BuildRequires:  gtk+2-devel >= 2:2.8.1
25 BuildRequires:  gtkmm-devel >= 2.8.0
26 BuildRequires:  jack-audio-connection-kit-devel >= 0.103
27 BuildRequires:  libart_lgpl >= 2.3.16
28 BuildRequires:  libgnomecanvas-devel >= 2.0
29 BuildRequires:  libgnomecanvasmm-devel >= 2.12.0
30 BuildRequires:  liblo-devel
31 BuildRequires:  liblrdf-devel >= 0.4.0
32 BuildRequires:  libraptor-devel >= 1.4.2
33 BuildRequires:  libsamplerate-devel >= 0.1.2
34 BuildRequires:  libsigc++-devel >= 2.0
35 # included libsndfile needs patch (wants FLAC__seekable_stream_decoder_set_read_callback)
36 # (in ardour itself only one UI option depends on HAVE_FLAC)
37 # internal one used
38 #BuildRequires: libsndfile-devel >= 1.0.0
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool
41 BuildRequires:  libusb-devel
42 BuildRequires:  libxml2-devel >= 1:2.6.0
43 BuildRequires:  libxslt-devel
44 BuildRequires:  pkgconfig >= 1:0.20
45 BuildRequires:  python >= 2.3.4
46 BuildRequires:  scons >= 0.96
47 BuildRequires:  soundtouch-devel >= 1.3.1
48 Requires:       jack-audio-connection-kit-libs >= 0.103
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 A "professional" multitrack, multichannel audio recorder and DAW for
53 Linux, using ALSA-supported audio interfaces. Supports up to 32 bit
54 samples, 24+ channels at up to 96kHz, full MMC control,
55 non-destructive, non-linear editor, LADSPA plugins.
56
57 %description -l pl.UTF-8
58 "Profesjonalny" wielościeżkowy, wielokanałowy magnetofon oraz DAW dla
59 Linuksa, wykorzystujący interfejsy dźwiękowe obsługiwane przez ALSA.
60 Obsługuje próbki do 32 bitów, 24+ kanałów do 96kHz, pełną kontrolę
61 MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 # NEEDS UPDATE for scons
67 #%patch1 -p1
68 %patch2 -p1
69
70 %build
71 # Make sure we have /proc mounted - it searches for flags from there
72 if [ ! -f /proc/cpuinfo ]; then
73         echo "You need to have /proc mounted in order to build this package!"
74         exit 1
75 fi
76
77 CXX="%{__cxx}" \
78 CC="%{__cc}" \
79 %scons \
80         PREFIX=%{_prefix} \
81         SYSLIBS=1 \
82 %ifarch %{x8664}
83         DIST_TARGET=x86_64
84 %else
85 %ifarch %{ix86}
86         DIST_TARGET=i386
87 %else
88         DIST_TARGET=none
89 %endif
90 %endif
91
92 %install
93 # Make sure we have /proc mounted - it searches for flags from there
94 if [ ! -f /proc/cpuinfo ]; then
95         echo "You need to have /proc mounted in order to build this package!"
96         exit 1
97 fi
98
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
101
102 %scons install \
103         DESTDIR=$RPM_BUILD_ROOT \
104         PREFIX=%{_prefix} \
105         GTK=yes
106 #       KSI=yes
107
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
109 cp -a gtk2_ardour/icons/ardour_icon_48px.png $RPM_BUILD_ROOT%{_pixmapsdir}/ardour.png
110
111 # it shouldn't be there
112 rm -f $RPM_BUILD_ROOT%{_datadir}/ardour/libardour.{la,a}
113
114 %find_lang %{name} --all-name
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc DOCUMENTATION/{AUTHORS,CONTRIBUTORS,FAQ,TRANSLATORS}
122 %lang(es) %doc DOCUMENTATION/{AUTHORS.es,CONTRIBUTORS.es,README.es}
123 %lang(fr) %doc DOCUMENTATION/README.fr
124 %lang(it) %doc DOCUMENTATION/README.it
125 %lang(ru) %doc DOCUMENTATION/README.ru
126 %dir %{_sysconfdir}/ardour2
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/*.conf
128 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/*.rc
129 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/ardour.bindings
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/ardour.menus
131 %attr(755,root,root) %{_bindir}/ardour2
132 %{_datadir}/ardour2
133 %{_desktopdir}/ardour.desktop
134 %{_pixmapsdir}/ardour.png
135
136 %dir %{_libdir}/ardour2
137 %attr(755,root,root) %{_libdir}/ardour2/ardour-2.1
138 %attr(755,root,root) %{_libdir}/ardour2/libardour.so
139 %attr(755,root,root) %{_libdir}/ardour2/libardour_cp.so
140 %attr(755,root,root) %{_libdir}/ardour2/libgtkmm2ext.so
141 %attr(755,root,root) %{_libdir}/ardour2/libmidi++.so
142 %attr(755,root,root) %{_libdir}/ardour2/libpbd.so
143 %attr(755,root,root) %{_libdir}/ardour2/libsndfile-ardour.so
144 %dir %{_libdir}/ardour2/engines
145 %attr(755,root,root) %{_libdir}/ardour2/engines/libclearlooks.so
146 %dir %{_libdir}/ardour2/surfaces
147 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_genericmidi.so
148 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_mackie.so
149 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_powermate.so
150 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_tranzport.so
This page took 0.0739 seconds and 3 git commands to generate.