]> git.pld-linux.org Git - packages/ardour.git/blob - ardour.spec
25e8538e19279f7cdc2c41a83e231a3af111c224
[packages/ardour.git] / ardour.spec
1 Summary:        Multitrack hard disk recorder
2 Summary(pl.UTF-8):   Wielościeżkowy magnetofon nagrywający na twardym dysku
3 Name:           ardour
4 Version:        0.9
5 %define _beta   beta18
6 Release:        0.%{_beta}.3
7 License:        GPL
8 Group:          X11/Applications/Sound
9 Source0:        http://ardour.org/releases/%{name}-%{version}%{_beta}.tar.bz2
10 # Source0-md5:  f0ab7b6fccb67b209b1f11edea49fbf1
11 Source1:        %{name}.desktop
12 Patch0:         %{name}-system-libs.patch
13 Patch1:         %{name}-opt.patch
14 Patch2:         %{name}-ac_cleanup.patch
15 Patch3:         %{name}-nptl_fix.patch
16 URL:            http://ardour.org/
17 #BuildRequires: gtk-canvas-devel >= 0.1
18 BuildRequires:  XFree86-devel
19 BuildRequires:  alsa-lib-devel >= 0.9.0
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  gettext-devel
23 BuildRequires:  gtk+-devel >= 1.0.0
24 BuildRequires:  gtkmm1-devel >= 1.2.6
25 BuildRequires:  jack-audio-connection-kit-devel >= 0.98.0
26 BuildRequires:  libart_lgpl >= 2.3.16
27 BuildRequires:  liblrdf-devel >= 0.3.0
28 BuildRequires:  libpng-devel
29 BuildRequires:  libsamplerate-devel >= 0.0.13
30 BuildRequires:  libsigc++1-devel >= 0.8.8
31 BuildRequires:  libsndfile-devel >= 1.0.0
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool
34 BuildRequires:  libxml2-devel >= 2.5.0
35 BuildRequires:  pkgconfig
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A "professional" multitrack, multichannel audio recorder and DAW for
40 Linux, using ALSA-supported audio interfaces. Supports up to 32 bit
41 samples, 24+ channels at up to 96kHz, full MMC control,
42 non-destructive, non-linear editor, LADSPA plugins.
43
44 %description -l pl.UTF-8
45 "Profesjonalny" wielościeżkowy, wielokanałowy magnetofon oraz DAW dla
46 Linuksa, wykorzystujący interfejsy dźwiękowe obsługiwane przez ALSA.
47 Obsługuje próbki do 32 bitów, 24+ kanałów do 96kHz, pełną kontrolę
48 MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
49
50 %prep
51 %setup -q -n %{name}-%{version}%{_beta}
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55 %patch3 -p1
56
57 install -d m4
58 # extract AM_BUILD_ENVIRONMENT (patched!)
59 tail -n +837 aclocal.m4 > m4/buildenv.m4
60 # AM_OPT_FLAGS (patched!)
61 tail -n +862 libs/pbd/aclocal.m4 | head -n 33 >> m4/buildenv.m4
62
63 %{__perl} -pi -e 's/pt_PT/pt/' gtk_ardour/po/LINGUAS
64 mv -f gtk_ardour/po/{pt_PT,pt}.po
65
66 %build
67 %{__aclocal} -I m4
68 %{__autoconf}
69 %{__automake}
70 cd gtk_ardour
71 %{__aclocal} -I ../m4
72 %{__autoconf}
73 %{__automake}
74 cd ../libs
75 %{__libtoolize}
76 %{__aclocal} -I ../m4
77 %{__autoconf}
78 %{__automake}
79 cd ardour
80 %{__libtoolize}
81 %{__aclocal} -I ../../m4
82 %{__autoconf}
83 %{__automake}
84 cd ../gtk-canvas
85 %{__aclocal} -I ../../m4
86 %{__autoconf}
87 %{__automake}
88 cd ../gtkmmext
89 %{__aclocal} -I ../../m4
90 %{__autoconf}
91 %{__automake}
92 cd ../midi++
93 %{__aclocal} -I ../../m4
94 %{__autoconf}
95 %{__automake}
96 cd ../pbd
97 %{__aclocal} -I ../../m4
98 %{__autoconf}
99 %{__automake}
100 cd ../soundtouch
101 %{__aclocal} -I ../../m4
102 %{__autoconf}
103 %{__automake}
104 cd ../..
105 # ksi doesn't build for a moment
106 %configure \
107         --disable-ksi \
108         %{!?debug:--enable-optimize}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_desktopdir}
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
120
121 # it shouldn't be there
122 rm -f $RPM_BUILD_ROOT%{_datadir}/ardour/libardour.{la,a}
123
124 %find_lang %{name} --all-name
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc ChangeLog DOCUMENTATION/{AUTHORS,CONTRIBUTORS,FAQ,README,TODO,TRANSLATORS}
132 %lang(es) %doc DOCUMENTATION/{AUTHORS.es,CONTRIBUTORS.es,README.es}
133 %lang(fr) %doc DOCUMENTATION/README.fr
134 %lang(it) %doc DOCUMENTATION/README.it
135 %lang(ru) %doc DOCUMENTATION/README.ru
136 %attr(755,root,root) %{_bindir}/*
137 %{_datadir}/%{name}
138 %{_mandir}/man1/ardour.1*
139 %lang(es) %{_mandir}/es/man1/ardour.1*
140 %lang(fr) %{_mandir}/fr/man1/ardour.1*
141 %lang(ru) %{_mandir}/ru/man1/ardour.1*
142 %dir %{_sysconfdir}/ardour
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour/*.rc
144 %{_desktopdir}/ardour.desktop
This page took 0.062801 seconds and 2 git commands to generate.