]> git.pld-linux.org Git - packages/arabica.git/blob - arabica.spec
- up to 2016-January version
[packages/arabica.git] / arabica.spec
1 #
2 # TODO:
3 # - unify Arabica <-> arabica
4 # - more parsers
5 #
6 Summary:        Arabica - an XML parser toolkit written in C++
7 Summary(pl.UTF-8):      Arabica - narzędzia do parsowania XML napisane w C++
8 Name:           arabica
9 Version:        2016_January
10 %define _ver    %(echo %{version} | tr _ -)
11 Release:        1
12 License:        BSD-like
13 Group:          Development/Libraries
14 Source0:        https://github.com/jezhiggins/arabica/archive/%{_ver}.tar.gz
15 # Source0-md5:  2ab97777049ac703e7ff03710ea9c1a2
16 URL:            http://www.jezuk.co.uk/cgi-bin/view/arabica
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libxml2-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Arabica is an XML parser toolkit, providing SAX2 and DOM
23 implementations, written in Standard C++.
24
25 Arabica is a full SAX2 implementation, including the optional
26 interfaces and helper classes. It delivers UTF-8 encoded std::strings
27 or UCS-2 std::wstrings, but is templated on string type and so can
28 accommodate custom string types. It provides uniform SAX2 wrappers
29 for the expat parser, Xerces, libxml and, on Windows only, for the
30 Microsoft XML parser COM component.
31
32 %description -l pl.UTF-8
33 Arabica to pakiet narzędzi do parsowania XML zawierający implementacje
34 SAX2 i DOM napisane w standardowym C++.
35
36 Arabica to pełna implementacja SAX2 wraz z opcjonalnymi interfejsami i
37 klasami pomocniczymi. Dostarcza kodowane UTF-8 std::strings albo
38 kodowane UCS-2 std::wstrings, ale ma szablony oparte na typie string,
39 więc może obsługiwać własne typy string. Udostępnia jednolite wrappery
40 SAX2 dla parserów expat, Xerces, libxml oraz - tylko pod Windows -
41 komponentu COM parsera XML Microsoftu.
42
43 %package devel
44 Summary:        Header files for Arabica
45 Summary(pl.UTF-8):      Pliki nagłówkowe Arabica
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libstdc++-devel
49 Requires:       libxml2-devel
50
51 %description devel
52 Header files for Arabica.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe Arabica.
56
57 %package static
58 Summary:        Static Arabica library
59 Summary(pl.UTF-8):      Statyczna biblioteka Arabica
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static Arabica library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka Arabica.
68
69 %prep
70 %setup -q -n %{name}-%{_ver}
71
72 %build
73 %{__libtoolize}
74 %{__aclocal}
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86      DESTDIR=$RPM_BUILD_ROOT
87
88 %{__mv} $RPM_BUILD_ROOT%{_bindir}/mangle $RPM_BUILD_ROOT%{_bindir}/arabica-mangle
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README NEWS AUTHORS ChangeLog
96 %attr(755,root,root) %{_bindir}/arabica-mangle
97 %attr(755,root,root) %{_libdir}/libarabica.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libarabica.so.0
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libarabica.so
103 %{_libdir}/libarabica.la
104 %{_includedir}/arabica
105 %{_pkgconfigdir}/arabica.pc
106
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libarabica.a
This page took 0.083673 seconds and 3 git commands to generate.