]> git.pld-linux.org Git - packages/aqbanking.git/blob - aqbanking.spec
- release 2 (rebuild with libofx 0.8.0)
[packages/aqbanking.git] / aqbanking.spec
1 Summary:        A library for online banking functions and financial data import/export
2 Summary(pl):    Biblioteka do funkcji bankowych online oraz importu/eksportu danych finansowych
3 Name:           aqbanking
4 Version:        1.2.0
5 Release:        2
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/aqbanking/%{name}-%{version}.tar.gz
9 # Source0-md5:  b6afa0facd32be6f57b3b8f802a2eb6c
10 Patch0:         %{name}-link.patch
11 URL:            http://www.aquamaniac.de/aqbanking/
12 BuildRequires:  autoconf >= 2.56
13 BuildRequires:  automake
14 BuildRequires:  gettext-devel
15 BuildRequires:  gwenhywfar-devel >= 1.14.0
16 BuildRequires:  ktoblzcheck-devel
17 BuildRequires:  libofx-devel >= 0.7.0
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  python-ctypes
21 BuildRequires:  python-devel >= 2.3
22 BuildRequires:  rpm-pythonprov
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The intention of AqBanking is to provide a middle layer between the
27 program and the various Online Banking libraries (e.g. AqHBCI). The
28 first backend which is already supported is AqHBCI, a library which
29 implements a client for the German HBCI (Home Banking Computer
30 Interface) protocol. Additionally, Aqbanking provides various plugins
31 to simplify import and export of financial data. Currently there are
32 import plugins for the following formats: DTAUS (German financial
33 format), SWIFT (MT940 and MT942).
34
35 %description -l pl
36 Celem projektu AqBanking jest dostarczenie warstwy po¶redniej miêdzy
37 programem a ró¿nymi bibliotekami us³ug bankowych online (np. AqHBCI).
38 Pierwszy ju¿ obs³ugiwany backend to AqHBCI - biblioteka implementuj±ca
39 klienta niemieckiego protoko³u HBCI (Home Baking Computer Interface).
40 Ponadto Aqbanking dostarcza ró¿ne wtyczki upraszczaj±ce importowanie i
41 eksportowanie danych finansowych. Aktualnie istniej± wtyczki do
42 importu nastêpuj±cych formatów: DTAUS (niemiecki format finansowy),
43 SWIFT (MT940 oraz MT942).
44
45 %package devel
46 Summary:        Header files for AqBanking library
47 Summary(pl):    Pliki nag³ówkowe biblioteki AqBanking
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       gwenhywfar-devel >= 1.14.0
51 # for libaqbankingpp only
52 #Requires:      libstdc++-devel
53
54 %description devel
55 Header files for AqBanking library.
56
57 %description devel -l pl
58 Pliki nag³ówkowe biblioteki AqBanking.
59
60 %package static
61 Summary:        Static AqBanking libraries
62 Summary(pl):    Statyczne biblioteki AqBanking
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static AqBanking libraries.
68
69 %description static -l pl
70 Statyczne biblioteki AqBanking.
71
72 %package -n python-%{name}
73 Summary:        Python binding for AqBanking library
74 Summary(pl):    Wi±zanie Pythona do biblioteki AqBanking
75 Group:          Development/Languages/Python
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       python-ctypes
78
79 %description -n python-%{name}
80 Python binding for AqBanking library.
81
82 %description -n python-%{name} -l pl
83 Wi±zanie Pythona do biblioteki AqBanking.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --enable-libofx \
97         --enable-python \
98         --enable-static
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 rm -f $RPM_BUILD_ROOT%{_libdir}/*/plugins/*/*/*.{la,a}
109 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/aqbanking/*.py
110
111 %find_lang %{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc ChangeLog ChangeLog README TODO
122 %attr(755,root,root) %{_bindir}/aqbanking-tool
123 %attr(755,root,root) %{_libdir}/libaqbanking.so.*.*.*
124 %attr(755,root,root) %{_libdir}/libaqbankingpp.so.*.*.*
125 %dir %{_libdir}/aqbanking
126 %dir %{_libdir}/aqbanking/plugins
127 %dir %{_libdir}/aqbanking/plugins/*
128 %dir %{_libdir}/aqbanking/plugins/*/bankinfo
129 %dir %{_libdir}/aqbanking/plugins/*/imexporters
130 %attr(755,root,root) %{_libdir}/aqbanking/plugins/*/*/*.so*
131 %{_libdir}/aqbanking/plugins/*/*/*.xml
132 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/dbio/*.so*
133 %{_libdir}/gwenhywfar/plugins/*/dbio/*.xml
134 %{_datadir}/aqbanking
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/aqbanking-config
139 %attr(755,root,root) %{_libdir}/libaqbanking.so
140 %attr(755,root,root) %{_libdir}/libaqbankingpp.so
141 %{_libdir}/libaqbanking.la
142 %{_libdir}/libaqbankingpp.la
143 %{_includedir}/aqbanking
144 %{_includedir}/aqbanking++
145 %{_aclocaldir}/aqbanking.m4
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libaqbanking.a
150 %{_libdir}/libaqbankingpp.a
151
152 %files -n python-%{name}
153 %defattr(644,root,root,755)
154 %dir %{py_sitescriptdir}/aqbanking
155 %{py_sitescriptdir}/aqbanking/*.py[co]
This page took 0.12623 seconds and 3 git commands to generate.