]> git.pld-linux.org Git - packages/apt.git/commitdiff
- updated pld_man,man_fixes patches
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 8 Feb 2015 18:16:34 +0000 (19:16 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 8 Feb 2015 18:16:34 +0000 (19:16 +0100)
- added rpm5 patch (adjust for rpm5 API)
- added includes patch (missing includes required by recent gcc/glibc)
- added format patch (fixes build with -Werror=format-security)

apt-format.patch [new file with mode: 0644]
apt-includes.patch [new file with mode: 0644]
apt-man_fixes.patch
apt-pld_man.patch
apt-rpm5.patch [new file with mode: 0644]
apt.spec

diff --git a/apt-format.patch b/apt-format.patch
new file mode 100644 (file)
index 0000000..3746193
--- /dev/null
@@ -0,0 +1,20 @@
+--- apt-0.5.15lorg3.94a/methods/gpg.cc.orig    2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/methods/gpg.cc 2015-02-08 16:39:02.051118648 +0100
+@@ -369,7 +369,7 @@
+       if (msg != NULL) 
+       {
+        removeTmpDir(TempDir, SigCount);
+-       return _error->Error(msg);
++       return _error->Error("%s", msg);
+       }
+    }
+    else 
+@@ -393,7 +393,7 @@
+        if (msg != NULL)
+        {
+           removeTmpDir(TempDir, SigCount);           
+-          return _error->Error(msg);
++          return _error->Error("%s", msg);
+        }
+        if (KeyList.empty())
+           KeyList = KeyID;
diff --git a/apt-includes.patch b/apt-includes.patch
new file mode 100644 (file)
index 0000000..fe6c429
--- /dev/null
@@ -0,0 +1,40 @@
+--- apt-0.5.15lorg3.94a/apt-pkg/pkgcache.h.orig        2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/pkgcache.h     2015-02-05 21:12:53.014640035 +0100
+@@ -25,6 +25,7 @@
+ #include <string>
+ #include <time.h>
++#include <sys/types.h>
+ #include <apt-pkg/mmap.h>
+ using std::string;
+--- apt-0.5.15lorg3.94a/apt-pkg/contrib/progress.h.orig        2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/contrib/progress.h     2015-02-05 21:18:21.347959589 +0100
+@@ -28,6 +28,7 @@
+ #include <map>
+ #include <string>
+ #include <sys/time.h>
++#include <sys/types.h>
+ using std::string;
+ using std::map;
+--- apt-0.5.15lorg3.94a/apt-pkg/srcrecords.h.orig      2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/srcrecords.h   2015-02-08 16:17:47.344505476 +0100
+@@ -19,6 +19,7 @@
+ #include <string>
+ #include <vector>    
++#include <sys/types.h>
+ using std::string;
+ using std::vector;
+--- apt-0.5.15lorg3.94a/methods/http.cc.orig   2015-02-08 17:06:09.701050343 +0100
++++ apt-0.5.15lorg3.94a/methods/http.cc        2015-02-08 17:06:11.574383597 +0100
+@@ -38,6 +38,7 @@
+ #include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
++#include <algorithm>
+ #include <iostream>
+ #include <map>
index 42d743781a5d17ae1037bd5cae70e09eae395ff3..e89699ef7dda3dbbe61581ea7b013eebdcd6b935 100644 (file)
@@ -1,120 +1,3 @@
-diff -Nur apt-0.5.4cnc7.orig/doc/apt-cdrom.8.sgml apt-0.5.4cnc7/doc/apt-cdrom.8.sgml
---- apt-0.5.4cnc7.orig/doc/apt-cdrom.8.sgml    Tue Jul 23 19:54:52 2002
-+++ apt-0.5.4cnc7/doc/apt-cdrom.8.sgml Tue Dec 10 16:43:13 2002
-@@ -54,7 +54,7 @@
-      <VarListEntry><Term>add</Term>
-      <ListItem><Para>
-      <literal/add/ is used to add a new disc to the source list. It will unmount the
--     CDROM device, prompt for a disk to be inserted and then procceed to 
-+     CDROM device, prompt for a disk to be inserted and then proceed to 
-      scan it and copy the index files. If the disc does not have a proper
-      <filename>.disk/</> directory you will be prompted for a descriptive 
-      title.
-@@ -101,7 +101,7 @@
-      
-      <VarListEntry><term><option/-f/</><term><option/--fast/</>
-      <ListItem><Para>
--     Fast Copy; Assume the package files are valid and do not check 
-+     Fast Copy; assume the package files are valid and do not check 
-      every package. This option should be used only if
-      <command/apt-cdrom/ has been run on this disc before and did not detect 
-      any errors.
-@@ -110,7 +110,7 @@
-      
-      <VarListEntry><term><option/-a/</><term><option/--thorough/</>
-      <ListItem><Para>
--     Thorough Package Scan; This option may be needed with some old 
-+     Thorough Package Scan; this option may be needed with some old 
-      Debian 1.1/1.2 discs that have Package files in strange places. It 
-      takes much longer to scan the CD but will pick them all up.
-      </VarListEntry>
-@@ -120,7 +120,7 @@
-                    <term><option/--recon/</>
-                    <term><option/--no-act/</>
-      <ListItem><Para>
--     No Changes; Do not change the &sources-list; file and do not 
-+     No Changes; do not change the &sources-list; file and do not 
-      write index files. Everything is still checked however.
-      Configuration Item: <literal/APT::CDROM::NoAct/.
-      </VarListEntry> 
-diff -Nur apt-0.5.4cnc7.orig/doc/apt-get.8.sgml apt-0.5.4cnc7/doc/apt-get.8.sgml
---- apt-0.5.4cnc7.orig/doc/apt-get.8.sgml      Thu Jul 25 20:07:18 2002
-+++ apt-0.5.4cnc7/doc/apt-get.8.sgml   Tue Dec 10 16:45:51 2002
-@@ -270,7 +270,7 @@
-      Simulate prints out
-      a series of lines each one representing a dpkg operation, Configure (Conf),
-      Remove (Remv), Unpack (Inst). Square brackets indicate broken packages with
--     and empty set of square brackets meaning breaks that are of no consequence
-+     an empty set of square brackets meaning breaks that are of no consequence
-      (rare).
-      </VarListEntry>
-@@ -286,7 +286,7 @@
-      <VarListEntry><term><option/-u/</><term><option/--show-upgraded/</>
-      <ListItem><Para>
--     Show upgraded packages; Print out a list of all packages that are to be
-+     Show upgraded packages; print out a list of all packages that are to be
-      upgraded. 
-      Configuration Item: <literal/APT::Get::Show-Upgraded/.
-      </VarListEntry>
-@@ -300,7 +300,7 @@
-      <VarListEntry><term><option/--ignore-hold/</>
-      <ListItem><Para>
--     Ignore package Holds; This causes <command/apt-get/ to ignore a hold 
-+     Ignore package Holds; this causes <command/apt-get/ to ignore a hold 
-      placed on a package. This may be useful in conjunction with 
-      <literal/dist-upgrade/ to override a large number of undesired holds. 
-      Configuration Item: <literal/APT::Ignore-Hold/.
-@@ -308,7 +308,7 @@
-      <VarListEntry><term><option/--no-upgrade/</>
-      <ListItem><Para>
--     Do not upgrade packages; When used in conjunction with <literal/install/
-+     Do not upgrade packages; when used in conjunction with <literal/install/
-      <literal/no-upgrade/ will prevent packages listed from being upgraded
-      if they are already installed. 
-      Configuration Item: <literal/APT::Get::Upgrade/.
-@@ -316,7 +316,7 @@
-      <VarListEntry><term><option/--force-yes/</>
-      <ListItem><Para>
--     Force yes; This is a dangerous option that will cause apt to continue 
-+     Force yes; this is a dangerous option that will cause apt to continue 
-      without prompting if it is doing something potentially harmful. It 
-      should not be used except in very special situations. Using 
-      <literal/force-yes/ can potentially destroy your system! 
-diff -Nur apt-0.5.4cnc7.orig/doc/apt.conf.5.sgml apt-0.5.4cnc7/doc/apt.conf.5.sgml
---- apt-0.5.4cnc7.orig/doc/apt.conf.5.sgml     Tue Dec 10 16:22:06 2002
-+++ apt-0.5.4cnc7/doc/apt.conf.5.sgml  Tue Dec 10 16:47:05 2002
-@@ -76,7 +76,7 @@
-  <RefSect1><Title>The APT Group</>
-    <para>   
--   This group of options controls general APT behavior as well as holding the
-+   This group of options controls general APT behaviour as well as holding the
-    options for all of the tools.
-    <VariableList>
-@@ -89,7 +89,7 @@
-      
-      <VarListEntry><Term>Ignore-Hold</Term>
-      <ListItem><Para>
--     Ignore Held packages; This global option causes the problem resolver to
-+     Ignore Held packages; this global option causes the problem resolver to
-      ignore held packages in its decision making. 
-      </VarListEntry>
-@@ -103,7 +103,7 @@
-      <VarListEntry><Term>Immediate-Configure</Term>
-      <ListItem><Para>
--     Disable Immediate Configuration; This dangerous option disables some
-+     Disable Immediate Configuration; this dangerous option disables some
-      of APT's ordering code to cause it to make fewer dpkg calls. Doing
-      so may be necessary on some extremely slow single user systems but 
-      is very dangerous and may cause package install scripts to fail or worse.
 diff -Nur apt-0.5.4cnc7.orig/doc/apt.ent apt-0.5.4cnc7/doc/apt.ent
 --- apt-0.5.4cnc7.orig/doc/apt.ent     Tue Dec 10 16:22:06 2002
 +++ apt-0.5.4cnc7/doc/apt.ent  Tue Dec 10 16:44:47 2002
index 1c4ecdbbf7d3d1b77443585863962575ddedd2ed..6f783b69333928a01fa46d2840ca0701bd4e9e85 100644 (file)
@@ -10,16 +10,3 @@ diff -Nur apt-0.5.4cnc7.orig/doc/apt.ent apt-0.5.4cnc7/doc/apt.ent
  <!ENTITY configureindex "<filename>&docdir;examples/configure-index.gz</>">
  <!ENTITY aptconfdir "<filename>/etc/apt.conf</>">
  <!ENTITY statedir "/var/lib/apt">
-diff -Nur apt-0.5.4cnc7.orig/doc/fr/apt.ent.fr apt-0.5.4cnc7/doc/fr/apt.ent.fr
---- apt-0.5.4cnc7.orig/doc/fr/apt.ent.fr       Tue Jul 23 19:54:52 2002
-+++ apt-0.5.4cnc7/doc/fr/apt.ent.fr    Tue Dec 10 16:21:02 2002
-@@ -1,7 +1,7 @@
- <!-- -*- mode: sgml; mode: fold -*- -->
- <!-- translation of version 1.9 -->
- <!-- Some common paths.. -->
--<!ENTITY docdir "/usr/share/doc/apt/">
-+<!ENTITY docdir "/usr/share/doc/apt*/">
- <!ENTITY configureindex "<filename>&docdir;examples/configure-index.gz</>">
- <!ENTITY aptconfdir "<filename>/etc/apt.conf</>">
- <!ENTITY statedir "/var/lib/apt">
diff --git a/apt-rpm5.patch b/apt-rpm5.patch
new file mode 100644 (file)
index 0000000..2c40083
--- /dev/null
@@ -0,0 +1,137 @@
+--- apt-0.5.15lorg3.94a/configure.ac.orig      2015-02-05 18:11:36.748429800 +0100
++++ apt-0.5.15lorg3.94a/configure.ac   2015-02-05 20:40:37.388054598 +0100
+@@ -99,8 +99,8 @@
+ fi
+ dnl Various rpm header checks..
+-AC_CHECK_HEADER(rpm/rpmlib.h, [],
+-         [AC_MSG_ERROR([Can't find rpmlib.h])])
++AC_CHECK_HEADER(rpm/rpmio.h, [],
++         [AC_MSG_ERROR([Can't find rpmio.h])])
+ AC_CHECK_HEADERS([rpm/rpmsx.h rpm/rpmcallback.h rpm/rpmcb.h \
+            rpm/rpmmessages.h rpm/rpmevr.h])
+@@ -116,7 +116,7 @@
+       [AC_MSG_RESULT(no) ])
+       
+ AC_MSG_CHECKING(for fdigests)
+-AC_EGREP_HEADER(RPMTRANS_FLAG_NOFDIGESTS, rpm/rpmlib.h,
++AC_EGREP_HEADER(RPMTRANS_FLAG_NOFDIGESTS, rpm/rpmts.h,
+       [AC_MSG_RESULT(yes) AC_DEFINE(RPM_HAVE_FDIGESTS, 1, [fdigests]) ],
+       [AC_MSG_RESULT(no) ])
+--- apt-0.5.15lorg3.94a/apt-pkg/rpm/aptcallback.cc.orig        2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/rpm/aptcallback.cc     2015-02-05 21:20:41.861287026 +0100
+@@ -1,6 +1,6 @@
+ #include <map>
+ #include <stdio.h>
+-#include <rpm/rpmlib.h>
++#include <rpm/rpmio.h>
+ #include <apti18n.h>
+ #include <apt-pkg/progress.h>
+--- apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmhandler.h.orig  2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmhandler.h       2015-02-05 21:21:37.227951369 +0100
+@@ -21,7 +21,7 @@
+ #include "sqlite.h"
+ #endif
+-#include <rpm/rpmlib.h>
++#include <rpm/rpm4compat.h>
+ #include <rpm/rpmmacro.h>
+ #include <sys/types.h>
+--- apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmpackagedata.cc.orig     2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmpackagedata.cc  2015-02-05 21:41:50.177900464 +0100
+@@ -12,7 +12,7 @@
+ #include <apti18n.h>
+-#include <rpm/rpmlib.h>
++#include <rpm/rpm4compat.h>
+ RPMPackageData::RPMPackageData()
+    :
+--- apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmpm.h.orig       2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmpm.h    2015-02-05 21:47:51.287885311 +0100
+@@ -11,7 +11,7 @@
+ #ifndef PKGLIB_rpmPM_H
+ #define PKGLIB_rpmPM_H
+-#include <rpm/rpmlib.h>
++#include <rpm/rpm4compat.h>
+ #if RPM_VERSION >= 0x040100
+ #include <rpm/rpmts.h>
+ #endif
+--- apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmpm.cc.orig      2015-02-05 21:47:55.474551799 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmpm.cc   2015-02-08 16:16:03.291176510 +0100
+@@ -709,6 +709,7 @@
+           if (rc)
+              _error->Error(_("Failed adding %s to transaction %s"),
+                            *I, "(install)");
++          using ::Header;
+           headerFree(hdr);
+           Fclose(fd);
+           break;
+--- apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmsystem.cc.orig  2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmsystem.cc       2015-02-08 16:23:09.601158619 +0100
+@@ -38,7 +38,6 @@
+ #include <stdlib.h>
+ #include <dirent.h>
+ #include <fcntl.h>
+-#include <rpm/rpmlib.h>
+ #include <assert.h>
+ #include <time.h>
+                                                                       /*}}}*/
+--- apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmversion.cc.orig 2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/apt-pkg/rpm/rpmversion.cc      2015-02-08 16:31:54.937803242 +0100
+@@ -27,7 +27,7 @@
+ #include "rpmversion.h"
+ #include <apt-pkg/pkgcache.h>
+-#include <rpm/rpmlib.h>
++#include <rpm/rpm4compat.h>
+ #include <stdlib.h>
+ #include <assert.h>
+--- apt-0.5.15lorg3.94a/tools/genpkglist.cc.orig       2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/tools/genpkglist.cc    2015-02-08 17:08:43.291043897 +0100
+@@ -6,7 +6,6 @@
+ #include <dirent.h>
+ #include <errno.h>
+ #include <fcntl.h>
+-#include <rpm/rpmlib.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/stat.h>
+--- apt-0.5.15lorg3.94a/tools/cached_md5.cc.orig       2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/tools/cached_md5.cc    2015-02-08 17:09:19.007709065 +0100
+@@ -6,7 +6,6 @@
+ #include <dirent.h>
+ #include <errno.h>
+ #include <fcntl.h>
+-#include <rpm/rpmlib.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/stat.h>
+--- apt-0.5.15lorg3.94a/tools/gensrclist.cc.orig       2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/tools/gensrclist.cc    2015-02-08 17:11:07.871037829 +0100
+@@ -6,7 +6,6 @@
+ #include <dirent.h>
+ #include <errno.h>
+ #include <fcntl.h>
+-#include <rpm/rpmlib.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/stat.h>
+--- apt-0.5.15lorg3.94a/tools/countpkglist.cc.orig     2008-01-12 10:45:07.000000000 +0100
++++ apt-0.5.15lorg3.94a/tools/countpkglist.cc  2015-02-08 17:12:58.104366537 +0100
+@@ -2,7 +2,7 @@
+ #include <errno.h>
+ #include <string.h>
+-#include <rpm/rpmlib.h>
++#include <rpm/rpm4compat.h>
+ int main(int argc, char *argv[])
+ {
index 5707d73d290df9307d90cea62f1a8639506b23fd..65c8b24cee00451e6165e149635cae08c3ec9048 100644 (file)
--- a/apt.spec
+++ b/apt.spec
@@ -7,7 +7,7 @@ Summary(pt.UTF-8):      Frontend avançado para pacotes rpm e deb
 Name:          apt
 Version:       0.5.15lorg3.94a
 Release:       0.1
-License:       GPL
+License:       GPL v2+
 Group:         Applications/Archiving
 Source0:       http://apt-rpm.org/testing/%{name}-%{version}.tar.bz2
 # Source0-md5: c1f3702c0a91a31132c1019d559e2ae3
@@ -17,23 +17,30 @@ Source3:    vendors.list
 Source4:       rpmpriorities
 Source5:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
 # Source5-md5: a3e9b7fd3dbf243d63cbfcc78cb20c1c
-#Patch0:               %{name}-ac_fixes.patch
+Patch0:                %{name}-rpm5.patch
 Patch1:                %{name}-pld_man.patch
 Patch2:                %{name}-man_fixes.patch
-#Patch3:               %{name}-es_it.patch
+Patch3:                %{name}-includes.patch
 Patch4:                %{name}-filed.patch
 Patch5:                %{name}-pld_user_in_ftp_pass.patch
+Patch6:                %{name}-format.patch
 URL:           http://apt-rpm.org/
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake >= 1:1.9.5
+BuildRequires: bzip2-devel
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
-BuildRequires: gettext-tools
-BuildRequires: gpm-devel
+BuildRequires: gettext-tools >= 0.14.5
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
-BuildRequires: rpm-devel >= 4.4.1
+BuildRequires: libxml2-devel >= 1:2.6
+BuildRequires: ncurses-devel
+BuildRequires: readline-devel
+BuildRequires: rpm-devel >= 5
+BuildRequires: sqlite3-devel
+BuildRequires: zlib-devel
 Requires:      gnupg
+Requires:      libxml2 >= 1:2.6
 Requires:      rpm
 Obsoletes:     libapt-pkg
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -61,9 +68,9 @@ Summary(pt.UTF-8):    Arquivos de desenvolvimento para a biblioteca libapt-pkg do A
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
-Requires:      rpm-devel
+Requires:      libxml2-devel >= 1:2.6
+Requires:      rpm-devel >= 5
 Obsoletes:     libapt-pkg-devel
-Obsoletes:     libapt-pkg-static
 
 %description devel
 This package contains the header files and static libraries for
@@ -77,32 +84,40 @@ korzystających z biblioteki libapt-pkg.
 %description devel -l pt_BR.UTF-8
 Arquivos de desenvolvimento para a biblioteca libapt-pkg do APT
 
+%package static
+Summary:       Static libapt-pkg library
+Summary(pl.UTF-8):     Statyczna biblioteka libapt-pkg
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Obsoletes:     libapt-pkg-static
+
+%description static
+Static libapt-pkg library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka libapt-pkg.
+
 %prep
 %setup -q -a5
-#%patch0 -p1
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
-#%patch3 -p1
+%patch3 -p1
 %patch4 -p1
 %patch5 -p1
-
-mv po/es{_ES,}.po
-mv po/it{_IT,}.po
-mv po/de{_DE,}.po
+%patch6 -p1
 
 %build
-%{__libtoolize}
 %{__gettextize}
-%{__aclocal} -I buildlib
-#need patching
-#autoheader
+%{__libtoolize}
+%{__aclocal} -I m4 -I buildlib
 %{__autoconf}
-CPPFLAGS="-Wno-deprecated"
-CXXFLAGS="%{rpmcflags} -fno-exceptions"
-bash %configure \
-       --enable-nls \
-       --with-gpm
-%{__make} CC="%{__cc}" CXX="%{__cxx}"
+%{__autoheader}
+%{__automake}
+CXXFLAGS="%{rpmcxxflags} -fpermissive"
+bash %configure
+
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -117,10 +132,10 @@ install -d $RPM_BUILD_ROOT/var/cache/apt/archives/partial \
 
 install doc/pl/*.8 $RPM_BUILD_ROOT%{_mandir}/pl/man8
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/apt/methods/bzip2
-rm -f $RPM_BUILD_ROOT%{_libdir}/apt/methods/ssh
-ln -sf ./gzip $RPM_BUILD_ROOT%{_libdir}/apt/methods/bzip2
-ln -sf ./rsh $RPM_BUILD_ROOT%{_libdir}/apt/methods/ssh
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/apt/methods/bzip2
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/apt/methods/ssh
+ln -sf gzip $RPM_BUILD_ROOT%{_libdir}/apt/methods/bzip2
+ln -sf rsh $RPM_BUILD_ROOT%{_libdir}/apt/methods/ssh
 
 install %{SOURCE1}     $RPM_BUILD_ROOT%{_sysconfdir}/apt/apt.conf
 install %{SOURCE3}     $RPM_BUILD_ROOT%{_sysconfdir}/apt/vendors.list
@@ -128,6 +143,10 @@ install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apt/rpmpriorities
 
 sed -e s/@ARCH@/%{_target_cpu}/ %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/apt/sources.list
 
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{es_ES,es}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{it_IT,it}
+
 %find_lang %{name}
 
 %clean
@@ -138,24 +157,52 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc doc/examples/* TODO
-%attr(755,root,root) %{_bindir}/*
+# COPYING contains general notes; GPL text is in COPYING.GPL
+%doc AUTHORS AUTHORS.RPM COPYING ChangeLog TODO doc/examples/*
+%attr(755,root,root) %{_bindir}/apt-cache
+%attr(755,root,root) %{_bindir}/apt-cdrom
+%attr(755,root,root) %{_bindir}/apt-config
+%attr(755,root,root) %{_bindir}/apt-get
+%attr(755,root,root) %{_bindir}/apt-shell
+%attr(755,root,root) %{_bindir}/countpkglist
+%attr(755,root,root) %{_bindir}/genbasedir
+%attr(755,root,root) %{_bindir}/genpkglist
+%attr(755,root,root) %{_bindir}/gensrclist
+%attr(755,root,root) %{_libdir}/libapt-pkg.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libapt-pkg.so.3
+%dir %{_libdir}/apt
+%dir %{_libdir}/apt/methods
+%attr(755,root,root) %{_libdir}/apt/methods/*
 %dir %{_sysconfdir}/apt
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/sources.list
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/vendors.list
 %config %{_sysconfdir}/apt/rpmpriorities
-%dir %{_libdir}/apt
-%attr(755,root,root) %{_libdir}/apt/*
-%{_mandir}/man[58]/*
-%lang(pl) %{_mandir}/pl/man8/*
+%dir %{_sysconfdir}/apt/apt.conf.d
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/multilib.conf
+%{_mandir}/man5/apt.conf.5*
+%{_mandir}/man5/apt_preferences.5*
+%{_mandir}/man5/sources.list.5*
+%{_mandir}/man5/vendors.list.5*
+%{_mandir}/man8/apt.8*
+%{_mandir}/man8/apt-cache.8*
+%{_mandir}/man8/apt-cdrom.8*
+%{_mandir}/man8/apt-config.8*
+%{_mandir}/man8/apt-get.8*
+%lang(pl) %{_mandir}/pl/man8/apt.8*
+%lang(pl) %{_mandir}/pl/man8/apt-cache.8*
+%lang(pl) %{_mandir}/pl/man8/apt-cdrom.8*
+%lang(pl) %{_mandir}/pl/man8/apt-get.8*
 /var/cache/apt
 /var/lib/apt
-%attr(755,root,root) %{_libdir}/libapt*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/libapt*.so
-%{_libdir}/libapt*.a
-%{_libdir}/libapt*.la
+%attr(755,root,root) %{_libdir}/libapt-pkg.so
+%{_libdir}/libapt-pkg.la
 %{_includedir}/apt-pkg
+%{_pkgconfigdir}/libapt-pkg.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libapt-pkg.a
This page took 0.118217 seconds and 4 git commands to generate.