]> git.pld-linux.org Git - packages/apr-compat.git/blame - apr-compat.spec
This commit was manufactured by cvs2git to create branch 'AC-branch'.
[packages/apr-compat.git] / apr-compat.spec
CommitLineData
99008380 1Summary: Apache Portable Runtime
2Summary(pl.UTF-8): Apache Portable Runtime - przenośna biblioteka uruchomieniowa
3Name: apr
4Version: 1.3.3
5Release: 3
6Epoch: 1
7License: Apache v2.0
8Group: Libraries
9Source0: http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
10# Source0-md5: 2090c21dee4f0eb1512604127dcd158f
11Patch0: %{name}-link.patch
12Patch1: %{name}-metuxmpm.patch
13Patch2: %{name}-libtool.patch
14URL: http://apr.apache.org/
15BuildRequires: autoconf >= 2.50
16BuildRequires: automake
17%if "%{pld_release}" != "ac"
18BuildRequires: libtool >= 2:2.2
19%else
20BuildRequires: libtool
21%endif
22BuildRequires: libuuid-devel
23BuildRequires: python
24BuildRequires: rpm >= 4.4.9-56
25BuildRequires: rpm-pythonprov
26BuildRequires: sed >= 4.0
27%if "%{pld_release}" != "ac"
28BuildRequires: uname(release) >= 2.6
29Requires: uname(release) >= 2.6
30%endif
31Conflicts: kernel24
32Conflicts: kernel24-smp
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%define _includedir /usr/include/apr
36%define _datadir /usr/share/apr
37
38%description
39The mission of the Apache Portable Runtime (APR) project is to create
40and maintain software libraries that provide a predictable and
41consistent interface to underlying platform-specific implementations.
42The primary goal is to provide an API to which software developers may
43code and be assured of predictable if not identical behaviour
44regardless of the platform on which their software is built, relieving
45them of the need to code special-case conditions to work around or
46take advantage of platform-specific deficiencies or features.
47
48%description -l pl.UTF-8
49Celem projektu APR (Apache Portable Runtime) jest stworzenie i
50utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
51interfejsu do leżących u podstaw implementacji zależnych od platformy.
52Głównym celem jest dostarczenie API, którego mogą używać programiści
53mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
54identyczny, niezależnie od platformy na jakiej oprogramowanie jest
55budowane oraz bez potrzeby kodowania specjalnych warunków do
56obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
57możliwości.
58
59%package devel
60Summary: Header files and development documentation for apr
61Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja programisty do apr
62Group: Development/Libraries
63Requires: %{name} = %{epoch}:%{version}-%{release}
64Requires: automake
65%if "%{pld_release}" != "ac"
66Requires: libtool >= 2:2.2
67%else
68Requires: libtool
69%endif
70Requires: libuuid-devel
71Requires: python-modules
72
73%description devel
74Header files and development documentation for apr.
75
76%description devel -l pl.UTF-8
77Pliki nagłówkowe i dokumentacja programisty do apr.
78
79%package static
80Summary: Static apr library
81Summary(pl.UTF-8): Statyczna biblioteka apr
82Group: Development/Libraries
83Requires: %{name}-devel = %{epoch}:%{version}-%{release}
84
85%description static
86Static apr library.
87
88%description static -l pl.UTF-8
89Statyczna biblioteka apr.
90
91%prep
92%setup -q
93%patch0 -p1
94%patch1 -p1
95%patch2 -p1
96
97cat >> config.layout <<'EOF'
98<Layout PLD>
99sbindir: %{_sbindir}
100libexecdir: %{_libdir}/apr
101installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
102localstatedir: /var/run
103runtimedir: /var/run
104libsuffix: -${APR_MAJOR_VERSION}
105</Layout>
106EOF
107
108%build
109install /usr/share/automake/config.* build
110%{__autoconf}
111
112%configure \
113 --enable-layout=PLD \
114%ifarch %{ix86} %{x8664}
115%ifnarch i386
116 --enable-nonportable-atomics \
117%endif
118%endif
119 --enable-threads \
120 --with-devrandom=/dev/urandom
121%{__make}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
129mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
130install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
131ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
132if [ -f /usr/share/libtool/config/ltmain.sh ]; then
133 ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
134else
135 ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
136fi
137ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
138ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
139
140sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
141 $RPM_BUILD_ROOT%{_bindir}/apr-1-config
142sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
143 $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
144sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post -p /sbin/ldconfig
150%postun -p /sbin/ldconfig
151
152%files
153%defattr(644,root,root,755)
154%doc CHANGES docs/*.html
155%attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
156%attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
157
158%files devel
159%defattr(644,root,root,755)
160%attr(755,root,root) %{_bindir}/apr-1-config
161%attr(755,root,root) %{_libdir}/libapr-1.so
162%{_libdir}/libapr-1.la
163%{_libdir}/apr.exp
164%{_includedir}
165%dir %{_datadir}
166%dir %{_datadir}/build
167%{_datadir}/build/*.mk
168%{_datadir}/build/*.m4
169%{_datadir}/build/*.awk
170%attr(755,root,root) %{_datadir}/build/config.*
171%attr(755,root,root) %{_datadir}/build/*.sh
172%attr(755,root,root) %{_datadir}/build/libtool
173%attr(755,root,root) %{_datadir}/build/gen-build.py
174%{_datadir}/build-1
175%{_pkgconfigdir}/apr-1.pc
176
177%files static
178%defattr(644,root,root,755)
179%{_libdir}/libapr-1.a
This page took 0.117606 seconds and 4 git commands to generate.