]> git.pld-linux.org Git - packages/appstream-glib.git/commitdiff
- updated to 0.2.6 auto/th/appstream-glib-0.2.6-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 4 Sep 2014 16:55:14 +0000 (18:55 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 4 Sep 2014 16:55:14 +0000 (18:55 +0200)
- updated rpm5 patch

appstream-glib-rpm5.patch
appstream-glib.spec

index 4642986c9c822722ea5a15e893043f86976fc231..109f58868d3ea26e9e195c22cf3d999974a514d9 100644 (file)
@@ -28,8 +28,8 @@
  AppStreamBuilder_1_0_gir_FILES = $(introspection_sources)
  INTROSPECTION_GIRS += AppStreamBuilder-1.0.gir
  
---- appstream-glib-0.2.0/libappstream-builder/asb-package-rpm.c.orig   2014-06-21 22:53:36.268565676 +0200
-+++ appstream-glib-0.2.0/libappstream-builder/asb-package-rpm.c        2014-06-21 22:56:36.995228569 +0200
+--- appstream-glib-0.2.6/libappstream-builder/asb-package-rpm.c.orig   2014-09-01 15:57:32.000000000 +0200
++++ appstream-glib-0.2.6/libappstream-builder/asb-package-rpm.c        2014-09-04 16:55:26.028784594 +0200
 @@ -33,7 +33,7 @@
  #include <archive.h>
  #include <archive_entry.h>
@@ -39,8 +39,8 @@
  #include <rpm/rpmts.h>
  
  #include "as-cleanup.h"
-@@ -229,6 +229,33 @@
-       asb_package_set_source (pkg, srcrpm);
+@@ -239,6 +239,36 @@ asb_package_rpm_set_source (AsbPackage *
+       asb_package_set_source_pkgname (pkg, srcrpm);
  }
  
 +static uint64_t rpmtdGetNumber(rpmtd td)
 +    }
 +    return val;
 +}
++
++#define _RPMVSF_NOSIGNATURES (RPMVSF_NODSAHEADER | RPMVSF_NORSAHEADER | RPMVSF_NODSA | RPMVSF_NORSA)
++#define       _RPMVSF_NODIGESTS (RPMVSF_NOSHA1HEADER | RPMVSF_NOMD5HEADER | RPMVSF_NOSHA1 | RPMVSF_NOMD5)
 +
  /**
   * asb_package_rpm_ensure_simple:
   **/
-@@ -241,7 +268,7 @@
+@@ -251,7 +281,7 @@ asb_package_rpm_ensure_simple (AsbPackag
        rpmtd td;
  
        /* get the simple stuff */
@@ -82,7 +85,7 @@
        headerGet (priv->h, RPMTAG_NAME, td, HEADERGET_MINMEM);
        asb_package_set_name (pkg, rpmtdGetString (td));
        headerGet (priv->h, RPMTAG_VERSION, td, HEADERGET_MINMEM);
-@@ -258,7 +285,7 @@
+@@ -268,7 +298,7 @@ asb_package_rpm_ensure_simple (AsbPackag
        asb_package_rpm_set_license (pkg, rpmtdGetString (td));
        headerGet (priv->h, RPMTAG_SOURCERPM, td, HEADERGET_MINMEM);
        asb_package_rpm_set_source (pkg, rpmtdGetString (td));
@@ -91,7 +94,7 @@
        return ret;
  }
  
-@@ -390,7 +417,7 @@
+@@ -341,7 +371,7 @@ asb_package_rpm_ensure_releases (AsbPack
  
        /* read out the file list */
        for (i = 0; i < 3; i++)
        /* get the ChangeLog info */
        headerGet (priv->h, RPMTAG_CHANGELOGTIME, td[0], HEADERGET_MINMEM);
        headerGet (priv->h, RPMTAG_CHANGELOGNAME, td[1], HEADERGET_MINMEM);
-@@ -405,7 +432,7 @@
+@@ -356,7 +386,7 @@ asb_package_rpm_ensure_releases (AsbPack
        }
        for (i = 0; i < 3; i++) {
                rpmtdFreeData (td[i]);
        }
        return TRUE;
  }
-@@ -427,7 +454,7 @@
+@@ -378,7 +408,7 @@ asb_package_rpm_ensure_deps (AsbPackage
        _cleanup_strv_free_ gchar **deps = NULL;
  
        /* read out the dep list */
        rc = headerGet (priv->h, RPMTAG_REQUIRENAME, td, HEADERGET_MINMEM);
        if (!rc) {
                ret = FALSE;
-@@ -455,7 +482,7 @@
+@@ -406,7 +436,7 @@ asb_package_rpm_ensure_deps (AsbPackage
        asb_package_set_deps (pkg, deps);
  out:
        rpmtdFreeData (td);
        return ret;
  }
  
-@@ -477,7 +504,7 @@
+@@ -428,7 +458,7 @@ asb_package_rpm_ensure_filelists (AsbPac
  
        /* read out the file list */
        for (i = 0; i < 3; i++)
        rc = headerGet (priv->h, RPMTAG_DIRNAMES, td[0], HEADERGET_MINMEM);
        if (rc)
                rc = headerGet (priv->h, RPMTAG_BASENAMES, td[1], HEADERGET_MINMEM);
-@@ -512,7 +539,7 @@
+@@ -463,7 +493,7 @@ asb_package_rpm_ensure_filelists (AsbPac
  out:
        for (i = 0; i < 3; i++) {
                rpmtdFreeData (td[i]);
index 0b679b0a1d769658bf1b0cf90825c5a78077c6eb..a93754f3bf9e6a83e1f2363feee1fb30a893e3e3 100644 (file)
@@ -1,12 +1,12 @@
 Summary:       GLib Objects and helper methods for reading and writing AppStream metadata
 Summary(pl.UTF-8):     Obiekty GLiba i metody pomocnicze do odczytu i zapisu metadanych AppStream
 Name:          appstream-glib
-Version:       0.2.3
+Version:       0.2.6
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://people.freedesktop.org/~hughsient/appstream-glib/releases/%{name}-%{version}.tar.xz
-# Source0-md5: b2121d03fd2e04f39cf999b4eee2643e
+# Source0-md5: 2a86155462ef49747ca6f27f857aa1a9
 Patch0:                %{name}-rpm5.patch
 Patch1:                %{name}-pc.patch
 URL:           http://people.freedesktop.org/~hughsient/appstream-glib/
@@ -229,10 +229,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_absorb.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_appdata.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_blacklist.so
+%attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_dbus.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_desktop.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_font.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_gettext.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_gir.so
+%attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_gresource.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_gstreamer.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_hardcoded.so
 %attr(755,root,root) %{_libdir}/asb-plugins/libasb_plugin_ibus_sql.so
This page took 0.099578 seconds and 4 git commands to generate.