]> git.pld-linux.org Git - packages/apport.git/blob - apport.spec
- 0.106
[packages/apport.git] / apport.spec
1 Summary:        Read, write, and modify problem reports
2 Name:           apport
3 Version:        0.106
4 Release:        1
5 License:        GPL
6 Group:          Applications/System
7 Source0:        https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
8 # Source0-md5:  128c5b362708bc9e54e4bd167075d45d
9 Source1:        %{name}.init
10 URL:            https://wiki.ubuntu.com/Apport
11 BuildRequires:  gettext
12 BuildRequires:  intltool
13 BuildRequires:  python-devel >= 1:2.5
14 #BuildRequires: tetex-format-pdflatex
15 #BuildRequires: tetex-latex
16 # Need the ability to use pipes in /proc/sys/kernel/core_pattern
17 # seems only 2.6.24 allows command line params
18 Requires:       uname(release) >= 2.6.24
19 Requires(post,preun):   /sbin/chkconfig
20 Requires(post,preun):   /sbin/service
21 Requires(post,postun):  hicolor-icon-theme
22 Requires(post,postun):  shared-mime-info
23 Requires:       python-rpm
24 Requires:       yum
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 apport automatically collects data from crashed processes and compiles
30 a problem report in /var/crash/.
31
32 This package also provides apport's python libraries and a command
33 line frontend for browsing and handling the crash reports.
34
35 See https://wiki.ubuntu.com/AutomatedProblemReports for more
36 information.
37
38 %package gtk
39 Summary:        GTK frontend for the apport crash report system
40 Group:          Applications/System
41 Requires:       procps
42 Requires:       python-pygtk-gtk
43 Requires:       python-pygtk-glade
44 Requires:       python-pyxdg
45
46 %description gtk
47 apport automatically collects data from crashed processes and compiles
48 a problem report in /var/crash/.
49
50 This package provides a GTK frontend for browsing and handling the
51 crash reports.
52
53 %package qt
54 Summary:        Qt4 frontend for the apport crash report system
55 Group:          Applications/System
56 Requires:       procps
57 Requires:       python-PyQT
58 Requires:       python-pyxdg
59
60 %description qt
61 apport automatically collects data from crashed processes and compiles
62 a problem report in /var/crash/.
63
64 This package provides a Qt4 frontend for browsing and handling the
65 crash reports.
66
67 %package retrace
68 Summary:        Tools for reprocessing Apport crash reports
69 Group:          Applications/System
70
71 %description retrace
72 apport-retrace recombines an Apport crash report (either a file or a
73 Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
74 stack traces.
75
76 This package also ships apport-chroot. This tool can create and manage
77 chroots for usage with apport-retrace. If the fakeroot and fakechroot
78 libraries are available (either by installing the packages or by
79 merely putting their libraries somewhere and setting two environment
80 variables), the entire process of retracing crashes in chroots can
81 happen with normal user privileges.
82
83 %prep
84 %setup -q -n ubuntu
85
86 %build
87 python setup.py build
88 %{__make} -C po
89 %{__make} -C gtk
90 %{__make} -C qt4
91 #%{__make} -C doc
92 # set up the packaging backend
93 cp backends/packaging_rpm.py backends/packaging_fedora.py apport
94 ln -s packaging_fedora.py apport/packaging_impl.py
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 python setup.py install \
99         --optimize=2 \
100         --root=$RPM_BUILD_ROOT \
101         --install-scripts %{_datadir}/apport
102
103 %py_postclean
104
105 # Do the man pages
106 install -d $RPM_BUILD_ROOT%{_mandir}/man1
107 install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
108 # cron job
109 install -d $RPM_BUILD_ROOT/etc/cron.daily
110 install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
111 # create the dir for crash reports
112 install -d $RPM_BUILD_ROOT/var/crash
113 # install initscript
114 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
115 install %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 # Add proper symlinks in %{_sysconfdir}/rc*.d
122 /sbin/chkconfig --add apport
123 %update_mime_database
124 %update_icon_cache hicolor
125
126 %preun
127 if [ "$1" == "0" ]; then
128     %service apport stop > /dev/null
129     /sbin/chkconfig --del apport
130 fi
131
132 %postun
133 if [ "$1" -ge "1" ]; then
134     %service apport condrestart > /dev/null || :
135 fi
136 %update_mime_database
137 %update_icon_cache hicolor
138
139 %files
140 %defattr(644,root,root,755)
141 %dir /var/crash
142 %{_mandir}/man1/*
143 %{_iconsdir}/hicolor/*/apps/apport.svg
144 %{_datadir}/mime/packages/apport.xml
145 %{py_sitescriptdir}/apport-0.0.0-py*.egg-info
146 %dir %{_datadir}/apport
147 %attr(755,root,root) %{_datadir}/apport/apport
148 %attr(755,root,root) %{_datadir}/apport/apport-cli
149 %attr(755,root,root) %{_datadir}/apport/gcc_ice_hook
150 %attr(755,root,root) %{_datadir}/apport/apport-checkreports
151 %attr(755,root,root) %{_datadir}/apport/package_hook
152 %attr(755,root,root) %{_datadir}/apport/kernel_hook
153 %attr(755,root,root) %{_datadir}/apport/apport-unpack
154 %attr(755,root,root) %{_datadir}/apport/testsuite/
155 %dir %{_datadir}/apport/general-hooks/
156 %attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
157 %dir %{_datadir}/apport/package-hooks/
158 %attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
159 %{py_sitescriptdir}/apport_python_hook.py[co]
160 %{py_sitescriptdir}/problem_report*.py[co]
161 %dir %{py_sitescriptdir}/apport
162 %{py_sitescriptdir}/apport/*.py[co]
163 %dir %{py_sitescriptdir}/apport/crashdb_impl
164 %{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
165 %{_sysconfdir}/cron.daily/apport
166 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/apport
167 %dir %{_sysconfdir}/apport
168 %config %{_sysconfdir}/apport/crashdb.conf
169 %{_sysconfdir}/apport/blacklist.d
170
171 %files gtk
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_datadir}/apport/apport-gtk
174 %{_datadir}/apport/apport-gtk.glade
175
176 %files qt
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_datadir}/apport/apport-qt
179 %{_datadir}/apport/*.ui
180
181 %files retrace
182 %defattr(644,root,root,755)
183 %{_mandir}/man1/apport-retrace.1*
184 %attr(755,root,root) %{_datadir}/apport/apport-retrace
185 %attr(755,root,root) %{_datadir}/apport/apport-chroot
186 %attr(755,root,root) %{_datadir}/apport/dupdb-admin
This page took 0.175001 seconds and 4 git commands to generate.