]> git.pld-linux.org Git - packages/apport.git/blob - apport.spec
- update to 1.108
[packages/apport.git] / apport.spec
1 Summary:        Read, write, and modify problem reports
2 Name:           apport
3 Version:        0.108
4 Release:        0.1
5 License:        GPL
6 Group:          Applications/System
7 Source0:        https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
8 # Source0-md5:  fce254253ad9a5f3d1dab91b48a82e5e
9 Source1:        %{name}.init
10 Source2:        %{name}-backend-pld.py
11 URL:            https://wiki.ubuntu.com/Apport
12 BuildRequires:  gettext
13 BuildRequires:  intltool
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 #BuildRequires: tetex-format-pdflatex
17 #BuildRequires: tetex-latex
18 Requires(post,postun):  hicolor-icon-theme
19 Requires(post,postun):  shared-mime-info
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       lsb-release
22 Requires:       python-launchpad-bugs
23 Requires:       python-rpm
24 Requires:       rc-scripts
25 Requires:       yum
26 # Need the ability to use pipes in /proc/sys/kernel/core_pattern
27 # seems only 2.6.24 allows command line params
28 Requires:       uname(release) >= 2.6.24
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 apport automatically collects data from crashed processes and compiles
34 a problem report in /var/crash/.
35
36 This package also provides apport's python libraries and a command
37 line frontend for browsing and handling the crash reports.
38
39 See <https://wiki.ubuntu.com/AutomatedProblemReports> for more
40 information.
41
42 %package gtk
43 Summary:        GTK frontend for the apport crash report system
44 Group:          Applications/System
45 Requires:       procps
46 Requires:       python-pygtk-glade
47 Requires:       python-pygtk-gtk
48 Requires:       python-pyxdg
49
50 %description gtk
51 apport automatically collects data from crashed processes and compiles
52 a problem report in /var/crash/.
53
54 This package provides a GTK frontend for browsing and handling the
55 crash reports.
56
57 %package qt
58 Summary:        Qt4 frontend for the apport crash report system
59 Group:          Applications/System
60 Requires:       procps
61 Requires:       python-PyQt4
62 Requires:       python-pyxdg
63
64 %description qt
65 apport automatically collects data from crashed processes and compiles
66 a problem report in /var/crash/.
67
68 This package provides a Qt4 frontend for browsing and handling the
69 crash reports.
70
71 %package retrace
72 Summary:        Tools for reprocessing Apport crash reports
73 Group:          Applications/System
74
75 %description retrace
76 apport-retrace recombines an Apport crash report (either a file or a
77 Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
78 stack traces.
79
80 This package also ships apport-chroot. This tool can create and manage
81 chroots for usage with apport-retrace. If the fakeroot and fakechroot
82 libraries are available (either by installing the packages or by
83 merely putting their libraries somewhere and setting two environment
84 variables), the entire process of retracing crashes in chroots can
85 happen with normal user privileges.
86
87 %prep
88 %setup -qc
89 mv ubuntu/* .
90
91 # only used by debian
92 rm apport/packaging.py
93
94 # set up the packaging backend
95 cp backends/packaging_rpm.py apport
96 cp %{SOURCE2} apport/packaging_pld.py
97 ln -s packaging_pld.py apport/packaging_impl.py
98
99 %build
100 python setup.py build
101 %{__make} -C po
102 %{__make} -C gtk
103 %{__make} -C qt4
104
105 #%{__make} -C doc
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 python setup.py install \
110         --optimize=2 \
111         --root=$RPM_BUILD_ROOT \
112         --install-scripts %{_datadir}/apport
113
114 %py_postclean
115
116 # Do the man pages
117 install -d $RPM_BUILD_ROOT%{_mandir}/man1
118 install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
119 # cron job
120 install -d $RPM_BUILD_ROOT/etc/cron.daily
121 install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
122 # create the dir for crash reports
123 install -d $RPM_BUILD_ROOT/var/crash
124 # install initscript
125 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
126 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
127
128 rm -f $RPM_BUILD_ROOT%{_docdir}/apport/package-hooks.txt
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 /sbin/chkconfig --add apport
135 %service apport restart
136 %update_mime_database
137 %update_icon_cache hicolor
138
139 %preun
140 if [ "$1" == "0" ]; then
141         %service apport stop
142         /sbin/chkconfig --del apport
143 fi
144
145 %update_mime_database
146 %update_icon_cache hicolor
147
148 %files
149 %defattr(644,root,root,755)
150 %doc doc/package-hooks.txt
151 %dir /var/crash
152 %{_mandir}/man1/*
153 %{_iconsdir}/hicolor/*/apps/apport.svg
154 %{_datadir}/mime/packages/apport.xml
155 %{py_sitescriptdir}/apport-*.egg-info
156 %dir %{_datadir}/apport
157 %attr(755,root,root) %{_datadir}/apport/apport
158 %attr(755,root,root) %{_datadir}/apport/apport-cli
159 %attr(755,root,root) %{_datadir}/apport/gcc_ice_hook
160 %attr(755,root,root) %{_datadir}/apport/apport-checkreports
161 %attr(755,root,root) %{_datadir}/apport/package_hook
162 %attr(755,root,root) %{_datadir}/apport/kernel_hook
163 %attr(755,root,root) %{_datadir}/apport/apport-unpack
164 %attr(755,root,root) %{_datadir}/apport/testsuite/
165 %dir %{_datadir}/apport/general-hooks/
166 %attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
167 %dir %{_datadir}/apport/package-hooks/
168 %attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
169 %{py_sitescriptdir}/apport_python_hook.py[co]
170 %{py_sitescriptdir}/problem_report*.py[co]
171 %dir %{py_sitescriptdir}/apport
172 %{py_sitescriptdir}/apport/*.py[co]
173 %dir %{py_sitescriptdir}/apport/crashdb_impl
174 %{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
175 /etc/cron.daily/apport
176 %attr(754,root,root) /etc/rc.d/init.d/apport
177 %dir %{_sysconfdir}/apport
178 %config %{_sysconfdir}/apport/crashdb.conf
179 %{_sysconfdir}/apport/blacklist.d
180
181 %files gtk
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_datadir}/apport/apport-gtk
184 %{_datadir}/apport/apport-gtk.glade
185
186 %files qt
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_datadir}/apport/apport-qt
189 %{_datadir}/apport/*.ui
190
191 %files retrace
192 %defattr(644,root,root,755)
193 %{_mandir}/man1/apport-retrace.1*
194 %attr(755,root,root) %{_datadir}/apport/apport-retrace
195 %attr(755,root,root) %{_datadir}/apport/apport-chroot
196 %attr(755,root,root) %{_datadir}/apport/dupdb-admin
This page took 0.087873 seconds and 4 git commands to generate.