]> git.pld-linux.org Git - packages/apport.git/blob - apport.spec
- release 2
[packages/apport.git] / apport.spec
1 Summary:        Read, write, and modify problem reports
2 Name:           apport
3 Version:        0.108.2
4 Release:        2
5 License:        GPL
6 Group:          Applications/System
7 Source0:        https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
8 # Source0-md5:  b2eb9a3b1168329ae7cdeb2a988d3443
9 Source1:        %{name}.init
10 Source2:        %{name}-backend-pld.py
11 Patch0:         %{name}-pager.patch
12 Patch1:         %{name}-crashdb.patch
13 Patch2:         %{name}-gtk-glade.patch
14 URL:            https://wiki.ubuntu.com/Apport
15 BuildRequires:  gettext
16 BuildRequires:  intltool
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 #BuildRequires: tetex-format-pdflatex
20 #BuildRequires: tetex-latex
21 Requires(post,postun):  hicolor-icon-theme
22 Requires(post,postun):  shared-mime-info
23 Requires(post,preun):   /sbin/chkconfig
24 Requires:       lsb-release
25 Requires:       python-launchpad-bugs
26 Requires:       python-rpm
27 Requires:       rc-scripts
28 Requires:       yum
29 # Need the ability to use pipes in /proc/sys/kernel/core_pattern
30 # seems only 2.6.24 allows command line params
31 Requires:       uname(release) >= 2.6.24
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 apport automatically collects data from crashed processes and compiles
37 a problem report in /var/crash/.
38
39 This package also provides apport's python libraries and a command
40 line frontend for browsing and handling the crash reports.
41
42 See <https://wiki.ubuntu.com/AutomatedProblemReports> for more
43 information.
44
45 %package gtk
46 Summary:        GTK frontend for the apport crash report system
47 Group:          Applications/System
48 Requires:       procps
49 Requires:       python-pygtk-glade
50 Requires:       python-pygtk-gtk
51 Requires:       python-pyxdg
52
53 %description gtk
54 apport automatically collects data from crashed processes and compiles
55 a problem report in /var/crash/.
56
57 This package provides a GTK frontend for browsing and handling the
58 crash reports.
59
60 %package qt
61 Summary:        Qt4 frontend for the apport crash report system
62 Group:          Applications/System
63 Requires:       procps
64 Requires:       python-PyQt4
65 Requires:       python-pyxdg
66
67 %description qt
68 apport automatically collects data from crashed processes and compiles
69 a problem report in /var/crash/.
70
71 This package provides a Qt4 frontend for browsing and handling the
72 crash reports.
73
74 %package retrace
75 Summary:        Tools for reprocessing Apport crash reports
76 Group:          Applications/System
77
78 %description retrace
79 apport-retrace recombines an Apport crash report (either a file or a
80 Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
81 stack traces.
82
83 This package also ships apport-chroot. This tool can create and manage
84 chroots for usage with apport-retrace. If the fakeroot and fakechroot
85 libraries are available (either by installing the packages or by
86 merely putting their libraries somewhere and setting two environment
87 variables), the entire process of retracing crashes in chroots can
88 happen with normal user privileges.
89
90 %prep
91 %setup -q -n hardy
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95
96 # only used by debian
97 rm apport/packaging.py
98
99 # set up the packaging backend
100 cp backends/packaging_rpm.py apport
101 cp %{SOURCE2} apport/packaging_pld.py
102 ln -s packaging_pld.py apport/packaging_impl.py
103
104 %build
105 python setup.py build
106 %{__make} -C po
107 %{__make} -C gtk
108 %{__make} -C qt4
109
110 #%{__make} -C doc
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 python setup.py install \
115         --optimize=2 \
116         --root=$RPM_BUILD_ROOT
117
118 %py_postclean
119
120 # Do the man pages
121 install -d $RPM_BUILD_ROOT%{_mandir}/man1
122 install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
123 # cron job
124 install -d $RPM_BUILD_ROOT/etc/cron.daily
125 install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
126 # create the dir for crash reports
127 install -d $RPM_BUILD_ROOT/var/crash
128 # install initscript
129 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
130 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
131
132 # KDE integration
133 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/mimelnk/text}
134 # application
135 cp -a qt4/apport-qt.desktop $RPM_BUILD_ROOT%{_desktopdir}
136 # mimetype and associated action
137 cp -a qt4/apport-qt-mimelnk.desktop $RPM_BUILD_ROOT%{_datadir}/mimelnk/text/x-apport.desktop
138 cp -a qt4/apport-qt-mime.desktop $RPM_BUILD_ROOT%{_desktopdir}
139
140 rm -f $RPM_BUILD_ROOT%{_docdir}/apport/package-hooks.txt
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post
146 /sbin/chkconfig --add apport
147 %service apport restart
148 %update_mime_database
149 %update_icon_cache hicolor
150
151 %preun
152 if [ "$1" == "0" ]; then
153         %service apport stop
154         /sbin/chkconfig --del apport
155 fi
156
157 %update_mime_database
158 %update_icon_cache hicolor
159
160 %files
161 %defattr(644,root,root,755)
162 %doc doc/package-hooks.txt
163 %dir /var/crash
164 %{_mandir}/man1/*
165 %{_iconsdir}/hicolor/*/apps/apport.svg
166 %{_datadir}/mime/packages/apport.xml
167 %{py_sitescriptdir}/apport-*.egg-info
168 %dir %{_datadir}/apport
169 %attr(755,root,root) %{_bindir}/apport
170 %attr(755,root,root) %{_bindir}/apport-cli
171 %attr(755,root,root) %{_bindir}/gcc_ice_hook
172 %attr(755,root,root) %{_bindir}/apport-checkreports
173 %attr(755,root,root) %{_bindir}/package_hook
174 %attr(755,root,root) %{_bindir}/kernel_hook
175 %attr(755,root,root) %{_bindir}/apport-unpack
176 %attr(755,root,root) %{_datadir}/apport/testsuite/
177 %dir %{_datadir}/apport/general-hooks/
178 %attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
179 %dir %{_datadir}/apport/package-hooks/
180 %attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
181 %{py_sitescriptdir}/apport_python_hook.py[co]
182 %{py_sitescriptdir}/problem_report*.py[co]
183 %dir %{py_sitescriptdir}/apport
184 %{py_sitescriptdir}/apport/*.py[co]
185 %dir %{py_sitescriptdir}/apport/crashdb_impl
186 %{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
187 /etc/cron.daily/apport
188 %attr(754,root,root) /etc/rc.d/init.d/apport
189 %dir %{_sysconfdir}/apport
190 %config %{_sysconfdir}/apport/crashdb.conf
191 %{_sysconfdir}/apport/blacklist.d
192
193 %files gtk
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_bindir}/apport-gtk
196 %{_datadir}/apport/apport-gtk.glade
197
198 %files qt
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/apport-qt
201 %{_datadir}/apport/*.ui
202 %{_desktopdir}/apport-qt.desktop
203 %{_desktopdir}/apport-qt-mime.desktop
204 %{_datadir}/mimelnk/text/x-apport.desktop
205
206 %files retrace
207 %defattr(644,root,root,755)
208 %{_mandir}/man1/apport-retrace.1*
209 %attr(755,root,root) %{_bindir}/apport-retrace
210 %attr(755,root,root) %{_bindir}/apport-chroot
211 %attr(755,root,root) %{_bindir}/dupdb-admin
This page took 0.09773 seconds and 3 git commands to generate.