]> git.pld-linux.org Git - packages/apport.git/blob - apport.spec
- Requires(post,postun): gtk-update-icon-cache
[packages/apport.git] / apport.spec
1 Summary:        Read, write, and modify problem reports
2 Name:           apport
3 Version:        0.108.2
4 Release:        5
5 License:        GPL
6 Group:          Applications/System
7 Source0:        https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
8 # Source0-md5:  b2eb9a3b1168329ae7cdeb2a988d3443
9 Source1:        %{name}.init
10 Source2:        %{name}-backend-pld.py
11 Patch0:         %{name}-pager.patch
12 Patch1:         %{name}-crashdb.patch
13 Patch2:         %{name}-gtk-glade.patch
14 URL:            https://wiki.ubuntu.com/Apport
15 BuildRequires:  gettext-devel
16 BuildRequires:  intltool
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  python-modules
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 #BuildRequires: tetex-format-pdflatex
22 #BuildRequires: tetex-latex
23 Requires(post,postun):  gtk-update-icon-cache
24 Requires(post,postun):  hicolor-icon-theme
25 Requires(post,postun):  shared-mime-info
26 Requires(post,preun):   /sbin/chkconfig
27 Requires:       lsb-release
28 Requires:       python-launchpad-bugs
29 Requires:       python-rpm
30 Requires:       rc-scripts
31 Requires:       yum
32 # Need the ability to use pipes in /proc/sys/kernel/core_pattern
33 # seems only 2.6.24 allows command line params
34 Requires:       uname(release) >= 2.6.24
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 apport automatically collects data from crashed processes and compiles
40 a problem report in /var/crash/.
41
42 This package also provides apport's python libraries and a command
43 line frontend for browsing and handling the crash reports.
44
45 See <https://wiki.ubuntu.com/AutomatedProblemReports> for more
46 information.
47
48 %package gtk
49 Summary:        GTK frontend for the apport crash report system
50 Group:          Applications/System
51 Requires:       procps
52 Requires:       python-pygtk-glade
53 Requires:       python-pygtk-gtk
54 Requires:       python-pyxdg
55
56 %description gtk
57 apport automatically collects data from crashed processes and compiles
58 a problem report in /var/crash/.
59
60 This package provides a GTK frontend for browsing and handling the
61 crash reports.
62
63 %package qt
64 Summary:        Qt4 frontend for the apport crash report system
65 Group:          Applications/System
66 Requires:       procps
67 Requires:       python-PyQt4
68 Requires:       python-pyxdg
69
70 %description qt
71 apport automatically collects data from crashed processes and compiles
72 a problem report in /var/crash/.
73
74 This package provides a Qt4 frontend for browsing and handling the
75 crash reports.
76
77 %package retrace
78 Summary:        Tools for reprocessing Apport crash reports
79 Group:          Applications/System
80
81 %description retrace
82 apport-retrace recombines an Apport crash report (either a file or a
83 Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
84 stack traces.
85
86 This package also ships apport-chroot. This tool can create and manage
87 chroots for usage with apport-retrace. If the fakeroot and fakechroot
88 libraries are available (either by installing the packages or by
89 merely putting their libraries somewhere and setting two environment
90 variables), the entire process of retracing crashes in chroots can
91 happen with normal user privileges.
92
93 %prep
94 %setup -q -n hardy
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98
99 # only used by debian
100 rm apport/packaging.py
101
102 # set up the packaging backend
103 cp backends/packaging_rpm.py apport
104 cp %{SOURCE2} apport/packaging_pld.py
105 ln -s packaging_pld.py apport/packaging_impl.py
106
107 %build
108 python setup.py build
109 %{__make} -C po
110 %{__make} -C gtk
111 %{__make} -C qt4
112
113 #%{__make} -C doc
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 python setup.py install \
118         --optimize=2 \
119         --root=$RPM_BUILD_ROOT
120
121 %py_postclean
122
123 # Do the man pages
124 install -d $RPM_BUILD_ROOT%{_mandir}/man1
125 install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
126 # cron job
127 install -d $RPM_BUILD_ROOT/etc/cron.daily
128 install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
129 # create the dir for crash reports
130 install -d $RPM_BUILD_ROOT/var/crash
131 # install initscript
132 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
133 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
134
135 # KDE integration
136 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/mimelnk/text}
137 # application
138 cp -a qt4/apport-qt.desktop $RPM_BUILD_ROOT%{_desktopdir}
139 # mimetype and associated action
140 cp -a qt4/apport-qt-mimelnk.desktop $RPM_BUILD_ROOT%{_datadir}/mimelnk/text/x-apport.desktop
141 cp -a qt4/apport-qt-mime.desktop $RPM_BUILD_ROOT%{_desktopdir}
142
143 rm -f $RPM_BUILD_ROOT%{_docdir}/apport/package-hooks.txt
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/chkconfig --add apport
150 %service apport restart
151 %update_mime_database
152 %update_icon_cache hicolor
153
154 %preun
155 if [ "$1" == "0" ]; then
156         %service apport stop
157         /sbin/chkconfig --del apport
158 fi
159
160 %update_mime_database
161 %update_icon_cache hicolor
162
163 %files
164 %defattr(644,root,root,755)
165 %doc doc/package-hooks.txt
166 %dir /var/crash
167 %{_mandir}/man1/*
168 %{_iconsdir}/hicolor/*/apps/apport.svg
169 %{_datadir}/mime/packages/apport.xml
170 %{py_sitescriptdir}/apport-*.egg-info
171 %dir %{_datadir}/apport
172 %attr(755,root,root) %{_bindir}/apport
173 %attr(755,root,root) %{_bindir}/apport-cli
174 %attr(755,root,root) %{_bindir}/gcc_ice_hook
175 %attr(755,root,root) %{_bindir}/apport-checkreports
176 %attr(755,root,root) %{_bindir}/package_hook
177 %attr(755,root,root) %{_bindir}/kernel_hook
178 %attr(755,root,root) %{_bindir}/apport-unpack
179 %attr(755,root,root) %{_datadir}/apport/testsuite/
180 %dir %{_datadir}/apport/general-hooks/
181 %attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
182 %dir %{_datadir}/apport/package-hooks/
183 %attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
184 %{py_sitescriptdir}/apport_python_hook.py[co]
185 %{py_sitescriptdir}/problem_report*.py[co]
186 %dir %{py_sitescriptdir}/apport
187 %{py_sitescriptdir}/apport/*.py[co]
188 %dir %{py_sitescriptdir}/apport/crashdb_impl
189 %{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
190 /etc/cron.daily/apport
191 %attr(754,root,root) /etc/rc.d/init.d/apport
192 %dir %{_sysconfdir}/apport
193 %config %{_sysconfdir}/apport/crashdb.conf
194 %{_sysconfdir}/apport/blacklist.d
195
196 %files gtk
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/apport-gtk
199 %{_datadir}/apport/apport-gtk.glade
200
201 %files qt
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/apport-qt
204 %{_datadir}/apport/*.ui
205 %{_desktopdir}/apport-qt.desktop
206 %{_desktopdir}/apport-qt-mime.desktop
207 %{_datadir}/mimelnk/text/x-apport.desktop
208
209 %files retrace
210 %defattr(644,root,root,755)
211 %{_mandir}/man1/apport-retrace.1*
212 %attr(755,root,root) %{_bindir}/apport-retrace
213 %attr(755,root,root) %{_bindir}/apport-chroot
214 %attr(755,root,root) %{_bindir}/dupdb-admin
This page took 0.062413 seconds and 3 git commands to generate.