]> git.pld-linux.org Git - packages/apper.git/commitdiff
- initial master
authorJan Palus <jan.palus@gmail.com>
Sat, 11 Feb 2012 14:21:09 +0000 (14:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apper-crash_fix.patch -> 1.1
    apper.spec -> 1.1

apper-crash_fix.patch [new file with mode: 0644]
apper.spec [new file with mode: 0644]

diff --git a/apper-crash_fix.patch b/apper-crash_fix.patch
new file mode 100644 (file)
index 0000000..0e0e581
--- /dev/null
@@ -0,0 +1,20 @@
+diff -ur apper-0.7.0.orig/Apper/main.cpp apper-0.7.0/Apper/main.cpp
+--- apper-0.7.0.orig/Apper/main.cpp    2012-02-05 13:08:14.521574875 +0100
++++ apper-0.7.0/Apper/main.cpp 2012-02-05 16:24:35.096903422 +0100
+@@ -75,6 +75,8 @@
+     options.add("+[package]", ki18n("Package file to install"));
+     KCmdLineArgs::addCmdLineOptions(options);
++    Apper app;
++
+     KCmdLineArgs *args = KCmdLineArgs::parsedArgs();
+     if (args->count()) {
+@@ -131,7 +133,5 @@
+         return 0;
+     }
+-    Apper app;
+-
+     return app.exec();
+ }
diff --git a/apper.spec b/apper.spec
new file mode 100644 (file)
index 0000000..29a229a
--- /dev/null
@@ -0,0 +1,60 @@
+#
+Summary:       Application to get and manage software
+Name:          apper
+Version:       0.7.0
+Release:       0.1
+License:       GPL v2
+Group:         X11/Applications
+Source0:       http://dl.dropbox.com/u/37314029/%{name}-%{version}.tar.bz2
+# Source0-md5: 712b52dd9bd9eda7368d0820404d50f8
+Patch0:                %{name}-crash_fix.patch
+URL:           http://dantti.wordpress.com/
+BuildRequires: PackageKit-qt2-devel >= 0.6.17
+BuildRequires: automoc4 >= 0.9.88
+BuildRequires: cmake >= 2.8.0
+BuildRequires: kde4-kdelibs-devel
+BuildRequires: qt4-build
+BuildRequires: qt4-qmake
+BuildRequires: rpmbuild(macros) >= 1.600
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Application to get and manage software.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+install -d build
+cd build
+%cmake \
+       ../
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} -C build install/fast \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%find_lang %{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files -f %{name}.lang
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/apper
+%dir %{_libdir}/apper
+%attr(755,root,root) %{_libdir}/apper/libapper.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_apper.so
+%attr(755,root,root) %{_libdir}/kde4/kded_apperd.so
+%attr(755,root,root) %{_libdir}/kde4/libexec/apper-sentinel
+%{_desktopdir}/kde4/apper.desktop
+%{_datadir}/apps/apper
+%dir %{_datadir}/apps/ApperSentinel
+%{_datadir}/apps/ApperSentinel/ApperSentinel.notifyrc
+%{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
+%{_datadir}/dbus-1/services/org.kde.ApperSentinel.service
+%{_datadir}/kde4/services/kded/apperd.desktop
+%{_datadir}/kde4/services/kcm_apper.desktop
This page took 0.108951 seconds and 4 git commands to generate.