]> git.pld-linux.org Git - packages/apinger.git/blob - apinger.spec
- massive attack: adding Source-md5
[packages/apinger.git] / apinger.spec
1 Summary:        Alarm Pinger - network monitor with mail notification
2 Summary(pl):    Alarm Pinger - monitor sieci z powiadamianiem poczt±
3 Name:           apinger
4 Version:        0.6.1
5 Release:        2
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.bnet.pl/~jajcus/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  3505e6503ec06363613f16713501bb33
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconf
12 Patch0:         %{name}-user.patch
13 URL:            http://www.bnet.pl/~jajcus/
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Alarm Pinger is a little tool which monitors various IP devices by
18 simple ICMP echo requests. There are various other tools, that can do
19 this, but most of them are shell or perl scripts, spawning many
20 processes, thus much CPU-expensive, especially when one wants
21 continuous monitoring and fast response on target failure. Alarm
22 Pinger is a single process written in C, so it doesn't need much CPU
23 power even when monitoring many targets with frequent probes. Alarm
24 Pinger supports both IPv4 and IPv6.
25
26 %description -l pl
27 Alarm Pinger to ma³e narzêdzie monitoruj±ce ró¿ne urz±dzenia IP
28 wykorzystuj±c pakiety ICMP echo request/reply (tzw. ping). S± ró¿ne
29 inne narzêdzia, które to potrafi±, ale wiêkszo¶æ z nich to skrypty
30 shella lub perla uruchamiaj±ce wiele procesów, przez co mocno
31 obci±¿aj±ce maszynê, szczególnie gdy kto¶ chce ci±g³ego monitorowania
32 i szybkiej informacji o awarii. Alarm Pinger to pojedynczy proces
33 napisany w C, wiêc nie wymaga wielkiej mocy obliczeniowej, nawet gdy
34 bada wiele urz±dzeñ czêstymi pingami. Alarm Pinger obs³uguje zarówno
35 IPv4 jak i IPv6.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %build
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
48
49 %{__make} install DESTDIR=$RPM_BUILD_ROOT
50 install src/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
51 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
52 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 /sbin/chkconfig --add apinger
59
60 if [ -f /var/lock/subsys/apinger ]; then
61         /etc/rc.d/init.d/apinger restart 1>&2
62 else
63         echo "Type \"/etc/rc.d/init.d/apinger start\" to start apinger" 1>&2
64 fi
65
66 %preun
67 if [ "$1" = "0" ]; then
68         if [ -f /var/lock/subsys/apinger ]; then
69                 /etc/rc.d/init.d/apinger stop 1>&2
70         fi
71         /sbin/chkconfig --del apinger
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc AUTHORS NEWS TODO README doc/FAQ.html
77 %attr(755,root,root) %{_sbindir}/*
78 %attr(754,root,root) %config(noreplace) /etc/rc.d/init.d/apinger
79 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/apinger
80 %attr(640,root,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
This page took 0.733043 seconds and 3 git commands to generate.