]> git.pld-linux.org Git - packages/apinger.git/blob - apinger.spec
- nasty cut&paste bug fixed (s/named/apinger/)
[packages/apinger.git] / apinger.spec
1 Summary:        Alarm Pinger - network monitor with mail notification
2 Summary(pl):    Alarm Pinger - monitor sieci z powiadamianiem poczt±
3 Name:           apinger
4 Version:        0.3
5 Release:        1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.bnet.pl/~jajcus/%{name}/%{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconf
11 Patch0:         %{name}-user.patch
12 URL:            http://www.bnet.pl/~jajcus/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Alarm Pinger is a little tool which monitors various IP devices by
17 simple ICMP echo requests. There are various other tools, that can do
18 this, but most of them are shell or perl scripts, spawning many
19 processes, thus much CPU-expensive, especially when one wants
20 continuous monitoring and fast response on target failure. Alarm
21 Pinger is a single process written in C, so it doesn't need much CPU
22 power even when monitoring many targets with frequent probes. Alarm
23 Pinger supports both IPv4 and IPv6.
24
25 %description -l pl
26 Alarm Pinger to ma³e narzêdzie monitoruj±ce ró¿ne urz±dzenia IP
27 wykorzystuj±c pakiety ICMP echo request/reply (tzw. ping). S± ró¿ne
28 inne narzêdzia, które to potrafi±, ale wiêkszo¶æ z nich to skrypty
29 shella lub perla uruchamiaj±ce wiele procesów, przez co mocno
30 obci±¿aj±ce maszynê, szczególnie gdy kto¶ chce ci±g³ego monitorowania
31 i szybkiej informacji o awarii. Alarm Pinger to pojedynczy proces
32 napisany w C, wiêc nie wymaga wielkiej mocy obliczeniowej, nawet gdy
33 bada wiele urz±dzeñ czêstymi pingami. Alarm Pinger obs³uguje zarówno
34 IPv4 jak i IPv6.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 %build
41 %configure 
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
47
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49 install src/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
50 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
51 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /sbin/chkconfig --add apinger
58
59 if [ -f /var/lock/subsys/apinger ]; then
60         /etc/rc.d/init.d/apinger restart 1>&2
61 else
62         echo "Type \"/etc/rc.d/init.d/apinger start\" to start apinger" 1>&2
63 fi
64
65 %preun
66 if [ "$1" = "0" ]; then
67         if [ -f /var/lock/subsys/apinger ]; then
68                 /etc/rc.d/init.d/apinger stop 1>&2
69         fi
70         /sbin/chkconfig --del apinger
71 fi    
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS NEWS TODO README
76 %attr(755,root,root) %{_sbindir}/*
77 %attr(754,root,root) %config(noreplace) /etc/rc.d/init.d/apinger
78 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/apinger
79 %attr(640,root,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
This page took 0.056936 seconds and 3 git commands to generate.