]> git.pld-linux.org Git - packages/apertium-dict-mk-en.git/commitdiff
- new package
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Dec 2010 15:00:34 +0000 (15:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- DESTDIR patch self-explaining
- missing patch adds missing file taken from svn

Changed files:
    apertium-dict-mk-en-DESTDIR.patch -> 1.1
    apertium-dict-mk-en-missing.patch -> 1.1
    apertium-dict-mk-en.spec -> 1.1

apertium-dict-mk-en-DESTDIR.patch [new file with mode: 0644]
apertium-dict-mk-en-missing.patch [new file with mode: 0644]
apertium-dict-mk-en.spec [new file with mode: 0644]

diff --git a/apertium-dict-mk-en-DESTDIR.patch b/apertium-dict-mk-en-DESTDIR.patch
new file mode 100644 (file)
index 0000000..28dbb8f
--- /dev/null
@@ -0,0 +1,16 @@
+--- apertium-mk-en-0.1.0/Makefile.am.orig      2010-09-19 15:54:43.000000000 +0200
++++ apertium-mk-en-0.1.0/Makefile.am   2010-12-04 15:41:10.434118583 +0100
+@@ -100,9 +100,9 @@
+                 
+ install-data-local:
+       apertium-gen-modes modes.xml apertium-$(PREFIX1)
+-      $(INSTALL_DATA) $(PREFIX1).mode $(apertium_mk_enmodesdir)
+-      $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(apertium_mk_endir)
+-      $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t2x $(apertium_mk_endir)
+-      $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t3x $(apertium_mk_endir)
++      $(INSTALL_DATA) $(PREFIX1).mode $(DESTDIR)$(apertium_mk_enmodesdir)
++      $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(DESTDIR)$(apertium_mk_endir)
++      $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t2x $(DESTDIR)$(apertium_mk_endir)
++      $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t3x $(DESTDIR)$(apertium_mk_endir)
+ CLEANFILES = -r $(TARGETS_COMMON) 
diff --git a/apertium-dict-mk-en-missing.patch b/apertium-dict-mk-en-missing.patch
new file mode 100644 (file)
index 0000000..f17b7d8
--- /dev/null
@@ -0,0 +1,141 @@
+--- apertium-mk-en-0.1.0/lexchoicebil.xsl.orig 1970-01-01 01:00:00.000000000 +0100
++++ apertium-mk-en-0.1.0/lexchoicebil.xsl      2010-12-04 15:36:26.938122774 +0100
+@@ -0,0 +1,138 @@
++<?xml version="1.0" encoding="UTF-8"?> <!-- -*- nxml -*- -->
++<!--
++ Copyright (C) 2005 Universitat d'Alacant / Universidad de Alicante
++
++ This program is free software; you can redistribute it and/or
++ modify it under the terms of the GNU General Public License as
++ published by the Free Software Foundation; either version 2 of the
++ License, or (at your option) any later version.
++
++ This program is distributed in the hope that it will be useful, but
++ WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
++ General Public License for more details.
++
++ You should have received a copy of the GNU General Public License
++ along with this program; if not, write to the Free Software
++ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
++ 02111-1307, USA.
++-->
++<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
++  <xsl:output method="xml" encoding="UTF-8"/>
++<xsl:param name="r2l"/>
++
++<xsl:template match="s">
++  <s n="{./@n}"/>
++</xsl:template>
++
++<xsl:template match="b">
++  <b/>
++</xsl:template>
++
++<xsl:template match="g">
++  <g><xsl:apply-templates/></g>
++</xsl:template>
++
++<xsl:template match="a">
++  <a/>
++</xsl:template>
++
++<xsl:template match="j">
++  <j/>
++</xsl:template>
++
++<xsl:template match="l">
++  <xsl:apply-templates select="./*|text()"/>
++</xsl:template>
++
++<xsl:template match="r">
++  <xsl:apply-templates select="./*|text()"/>
++</xsl:template>
++
++<xsl:template match="par">
++  <par n="{./@n}"/>
++</xsl:template>
++
++<xsl:template match="re">
++  <re><xsl:apply-templates/></re>
++</xsl:template>
++
++<xsl:template match="p">
++  <p>
++      <xsl:choose>
++        <xsl:when test="not(count(../@slr)=0)">
++          <l><xsl:apply-templates select="./l/text()|./l/*[not(name(.)=string('s'))]"/>:<xsl:apply-templates select="../@slr"/><xsl:apply-templates select="./l/*[name(.)=string('s')]"/></l>
++        </xsl:when>
++        <xsl:otherwise>
++        <l><xsl:apply-templates select="./l/*|./l/text()"/></l>
++        </xsl:otherwise>
++      </xsl:choose>
++      <r><xsl:apply-templates select="./r/*|./r/text()"/></r>
++  </p>
++</xsl:template>
++
++
++<xsl:template match="i">
++  <p>
++      <xsl:choose>
++        <xsl:when test="not(count(../@slr)=0)">
++          <l><xsl:apply-templates select="text()|*[not(name(.)=string('s'))]"/>:<xsl:apply-templates select="../@slr"/><xsl:apply-templates select="*[name(.)=string('s')]"/></l>
++        </xsl:when>
++        <xsl:otherwise>
++        <l><xsl:apply-templates select="*|text()"/></l>
++        </xsl:otherwise>
++      </xsl:choose>
++      <r><xsl:apply-templates select="*|text()"/></r>
++  </p>
++</xsl:template>
++
++
++<xsl:template match="e">
++      <xsl:choose>
++        <xsl:when test="not(count(./@r)=0)">
++          <e r="{./@r}"><xsl:apply-templates select="./*"/></e>
++        </xsl:when>
++        <xsl:otherwise>
++          <e><xsl:apply-templates select="./*"/></e>
++        </xsl:otherwise>
++      </xsl:choose>
++</xsl:template>
++
++
++<xsl:template match="dictionary">
++<dictionary>
++  <xsl:value-of select="string('&#xA;')"/>
++  <xsl:copy-of select="./alphabet"/>
++  <xsl:value-of select="string('&#xA;')"/>
++  <xsl:copy-of select="./sdefs"/>
++  <xsl:value-of select="string('&#xA;')"/>
++  <xsl:if test="not(count(./pardefs/pardef)=0)">
++    <pardefs>
++  <xsl:value-of select="string('&#xA;')"/>
++
++      <xsl:for-each select="./pardefs/pardef">
++  <xsl:value-of select="string('&#xA;')"/>
++
++      <pardef n="{./@n}">
++        <xsl:apply-templates/>
++      </pardef>
++      </xsl:for-each>
++  <xsl:value-of select="string('&#xA;')"/>
++
++    </pardefs>
++  </xsl:if>
++  <xsl:value-of select="string('&#xA;')"/>
++
++  <xsl:for-each select="./section">
++    <section id="{./@id}" type="{./@type}">
++      <xsl:apply-templates/>
++    </section>
++
++  </xsl:for-each>
++
++</dictionary>
++
++</xsl:template>
++
++
++</xsl:stylesheet>
diff --git a/apertium-dict-mk-en.spec b/apertium-dict-mk-en.spec
new file mode 100644 (file)
index 0000000..472e5ae
--- /dev/null
@@ -0,0 +1,64 @@
+Summary:       Macedonian-English language pair for Apertium
+Summary(pl.UTF-8):     Para języków macedoński-angielski dla Apertium
+%define        lpair   mk-en
+Name:          apertium-dict-%{lpair}
+Version:       0.1.0
+Release:       1
+License:       GPL v3
+Group:         Applications/Text
+Source0:       http://downloads.sourceforge.net/apertium/apertium-%{lpair}-%{version}.tar.gz
+# Source0-md5: 622842068b69a91b946f7581c849b06c
+Patch0:                %{name}-DESTDIR.patch
+Patch1:                %{name}-missing.patch
+URL:           http://www.apertium.org/
+BuildRequires: apertium-devel >= 3.2.0
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake
+BuildRequires: libxslt-progs
+BuildRequires: lttoolbox >= 3.2.0
+BuildRequires: vislcg3 >= 0.9.7.5129
+BuildRequires: pkgconfig
+Requires:      apertium >= 3.2.0
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This is an Apertium language pair, which can be used for translating
+between Macedonian and English, morphological analysis or
+part-of-speech tagging of both languages.
+
+%description -l pl.UTF-8
+Ten pakiet zawiera parę języków dla Apertium służącą do tłumaczenia
+między macedońskim a angielskim, a także analizy morfologicznej lub
+oznaczania części mowy w obu językach.
+
+%prep
+%setup -q -n apertium-%{lpair}-%{version}
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__aclocal}
+%{__autoconf}
+%{__automake}
+%configure
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_datadir}/apertium/modes
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# not needed here (see modes subdir) and contain wrong (builddir) paths
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/apertium/apertium-%{lpair}/*.mode
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS ChangeLog NEWS README
+%{_datadir}/apertium/apertium-%{lpair}
+%{_datadir}/apertium/modes/mk-en.mode
This page took 0.082027 seconds and 4 git commands to generate.