]> git.pld-linux.org Git - packages/apcupsd.git/blobdiff - cxxld.patch
up to 3.14.13
[packages/apcupsd.git] / cxxld.patch
index d9a25449d63f69a2340bcecc6eb1bde32167ae40..1c49c2897097d184c5cdf990805af1974e88c01d 100644 (file)
@@ -1,19 +1,18 @@
 fix FTBFS, c++ linking needs -lstdc++ explicitly
 https://bugzilla.redhat.com/show_bug.cgi?id=631288
 
-diff -up apcupsd-3.14.8/src/Makefile.cxxld apcupsd-3.14.8/src/Makefile
---- apcupsd-3.14.8/src/Makefile.cxxld  2009-09-30 01:20:45.000000000 +0200
-+++ apcupsd-3.14.8/src/Makefile        2010-09-22 11:18:03.550601657 +0200
-@@ -26,10 +26,10 @@ SRCS = $(common_srcs) $(apcupsd_srcs) $(
- all-targets: apcupsd apcaccess apctest smtp 
+--- apcupsd-3.14.13/src/Makefile~      2014-11-04 21:17:43.000000000 +0200
++++ apcupsd-3.14.13/src/Makefile       2015-09-16 16:42:11.150220917 +0300
+@@ -30,10 +30,10 @@
+ all-targets: apcupsd$(EXE) apcaccess$(EXE) apctest$(EXE) smtp$(EXE) 
  
- apcupsd: $(common_obj) $(apcupsd_obj) $(APCDRVLIBS) $(APCLIBS)
--      $(LINK) $(DRVLIBS)
-+      $(LINK) -lstdc++ $(DRVLIBS)
+ apcupsd$(EXE): $(common_obj) $(apcupsd_obj) $(APCDRVLIBS) $(APCLIBS)
+-      $(LINK) $(DRVLIBS) $(BG)
++      $(LINK) -lstdc++ $(DRVLIBS) $(BG)
  
- apctest: $(common_obj) $(apctest_obj) $(APCDRVLIBS) $(APCLIBS)
+ apctest$(EXE): $(common_obj) $(apctest_obj) $(APCDRVLIBS) $(APCLIBS)
 -      $(LINK) $(DRVLIBS)
 +      $(LINK) -lstdc++ $(DRVLIBS)
  
- apcaccess: $(apcaccess_obj) $(APCLIBS)
+ apcaccess$(EXE): $(apcaccess_obj) $(APCLIBS)
        $(LINK)
This page took 0.035221 seconds and 4 git commands to generate.