]> git.pld-linux.org Git - packages/apcupsd.git/commitdiff
up to 3.14.13
authorElan Ruusamäe <glen@delfi.ee>
Wed, 16 Sep 2015 13:47:07 +0000 (16:47 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 16 Sep 2015 13:47:07 +0000 (16:47 +0300)
apcupsd-configure.patch
apcupsd.spec
cxxld.patch
nodbg.patch

index 3bf764bbf2098b79d9266bbdd8dfe33a93b39a55..aaf88c93835f3c24ffba2a7e50a125220665ed3f 100644 (file)
@@ -1,19 +1,17 @@
-diff -urN apcupsd-3.10.13.orig/autoconf/acconfig.h apcupsd-3.10.13.new/autoconf/acconfig.h
---- apcupsd-3.10.13.orig/autoconf/acconfig.h   2004-04-16 15:18:42.000000000 +0200
-+++ apcupsd-3.10.13.new/autoconf/acconfig.h    2004-05-22 15:54:12.854409808 +0200
-@@ -97,6 +97,10 @@
- /* Define the default "log" files directory. */
+--- apcupsd-3.14.13/./autoconf/config.h.in~    2015-01-02 19:12:47.000000000 +0200
++++ apcupsd-3.14.13/./autoconf/config.h.in     2015-09-16 16:40:33.785163382 +0300
+@@ -295,6 +295,9 @@
+ /* Default directory in which log is written */
  #undef LOGDIR
  
 +/* Define the default "status" files directory. */
 +#undef STATDIR
 +
-+
- /* Define the default serial port lock directory */
- #undef LOCKDIR
+ /* Default port number for NIS server */
+ #undef NISPORT
  
---- apcupsd-3.10.13.orig/autoconf/configure.in 2004-04-16 20:14:57.000000000 +0200
-+++ apcupsd-3.10.13.new/autoconf/configure.in  2004-05-22 19:09:30.116115272 +0200
+--- apcupsd-3.14.13/autoconf/configure.in~     2015-09-16 16:36:41.000000000 +0300
++++ apcupsd-3.14.13/autoconf/configure.in      2015-09-16 16:37:57.190362425 +0300
 @@ -1261,16 +1261,25 @@
  # Find the default directory to put the root-mode PID file in
  for PIDDIR in "/var/run" "/etc/apcupsd"
@@ -59,15 +57,15 @@ diff -urN apcupsd-3.10.13.orig/autoconf/acconfig.h apcupsd-3.10.13.new/autoconf/
  # now allow user to specify LOCKDIR
  AC_ARG_WITH(lock-dir,
      [AC_HELP_STRING([--with-lock-dir=DIR], [Specify serial port lock directory (default is OS dependent)])],
-@@ -1543,6 +1557,8 @@
- AC_SUBST(PIDDIR)
- AC_DEFINE_UNQUOTED(LOGDIR, "$LOGDIR")
+@@ -1396,6 +1396,8 @@
  AC_SUBST(LOGDIR)
+ AC_DEFINE_UNQUOTED(NOLOGDIR, "$nologdir", [Default directory in which nologin file is written])
+ AC_SUBST(nologdir)
 +AC_DEFINE_UNQUOTED(STATDIR, "$STATDIR")
 +AC_SUBST(STATDIR)
- AC_DEFINE_UNQUOTED(NOLOGDIR, "$nologdir")
- AC_SUBST(nologdir)
- AC_DEFINE_UNQUOTED(PWRFAILDIR, "$PWRFAILDIR")
+ AC_DEFINE_UNQUOTED(PWRFAILDIR, "$PWRFAILDIR", [Default directory in which powerfail flag file is written])
+ AC_SUBST(PWRFAILDIR)
+ AC_SUBST(LOCKDIR)
 @@ -1713,7 +1729,8 @@
    Install man files:          ${mandir}
    Nologin file in:            ${nologdir}
index b8797a35a0546bfde6e0b52985977c48519b4f50..d0a9277789e9956c29b3a6d58311c41f21b92a00 100644 (file)
 Summary:       Power management software for APC UPS hardware
 Summary(pl.UTF-8):     Oprogramowanie do zarządzania energią dla UPS-ów APC
 Name:          apcupsd
-Version:       3.14.12
+Version:       3.14.13
 Release:       1
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       http://downloads.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
-# Source0-md5: 08bf201acea6b4dd69cf2fb0eecfd55e
+# Source0-md5: c291d9d3923b4d9c0e600b755ad4f489
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
index d9a25449d63f69a2340bcecc6eb1bde32167ae40..1c49c2897097d184c5cdf990805af1974e88c01d 100644 (file)
@@ -1,19 +1,18 @@
 fix FTBFS, c++ linking needs -lstdc++ explicitly
 https://bugzilla.redhat.com/show_bug.cgi?id=631288
 
-diff -up apcupsd-3.14.8/src/Makefile.cxxld apcupsd-3.14.8/src/Makefile
---- apcupsd-3.14.8/src/Makefile.cxxld  2009-09-30 01:20:45.000000000 +0200
-+++ apcupsd-3.14.8/src/Makefile        2010-09-22 11:18:03.550601657 +0200
-@@ -26,10 +26,10 @@ SRCS = $(common_srcs) $(apcupsd_srcs) $(
- all-targets: apcupsd apcaccess apctest smtp 
+--- apcupsd-3.14.13/src/Makefile~      2014-11-04 21:17:43.000000000 +0200
++++ apcupsd-3.14.13/src/Makefile       2015-09-16 16:42:11.150220917 +0300
+@@ -30,10 +30,10 @@
+ all-targets: apcupsd$(EXE) apcaccess$(EXE) apctest$(EXE) smtp$(EXE) 
  
- apcupsd: $(common_obj) $(apcupsd_obj) $(APCDRVLIBS) $(APCLIBS)
--      $(LINK) $(DRVLIBS)
-+      $(LINK) -lstdc++ $(DRVLIBS)
+ apcupsd$(EXE): $(common_obj) $(apcupsd_obj) $(APCDRVLIBS) $(APCLIBS)
+-      $(LINK) $(DRVLIBS) $(BG)
++      $(LINK) -lstdc++ $(DRVLIBS) $(BG)
  
- apctest: $(common_obj) $(apctest_obj) $(APCDRVLIBS) $(APCLIBS)
+ apctest$(EXE): $(common_obj) $(apctest_obj) $(APCDRVLIBS) $(APCLIBS)
 -      $(LINK) $(DRVLIBS)
 +      $(LINK) -lstdc++ $(DRVLIBS)
  
- apcaccess: $(apcaccess_obj) $(APCLIBS)
+ apcaccess$(EXE): $(apcaccess_obj) $(APCLIBS)
        $(LINK)
index 1241bef7440b3db9ef0da1ad08f99e1ad96379bc..a5921bc62c47e46a52abe4160c4fc38d0a1522b0 100644 (file)
@@ -1,9 +1,8 @@
 https://bugzilla.redhat.com/show_bug.cgi?id=1053324
 
-diff -up apcupsd-3.14.10/src/drivers/snmplite/asn.cpp.nodbg apcupsd-3.14.10/src/drivers/snmplite/asn.cpp
---- apcupsd-3.14.10/src/drivers/snmplite/asn.cpp.nodbg 2010-09-07 17:35:13.000000000 +0200
-+++ apcupsd-3.14.10/src/drivers/snmplite/asn.cpp       2014-01-21 17:07:27.603049214 +0100
-@@ -26,10 +26,13 @@
+--- apcupsd-3.14.13/src/drivers/snmplite/asn.cpp~      2014-04-06 18:40:11.000000000 +0300
++++ apcupsd-3.14.13/src/drivers/snmplite/asn.cpp       2015-09-16 16:46:03.485622689 +0300
+@@ -26,6 +26,8 @@
  #include <stdlib.h>
  #include <stdio.h>
  
@@ -11,18 +10,15 @@ diff -up apcupsd-3.14.10/src/drivers/snmplite/asn.cpp.nodbg apcupsd-3.14.10/src/
 +
  using namespace Asn;
  
- void debug(const char *foo, int indent)
- {
-+   if (!debug_level) return;
-    while (indent--)
-       printf(" ");
-    printf("%s\n", foo);
-@@ -86,7 +89,7 @@ Object *Object::Demarshal(unsigned char
+ // *****************************************************************************
+@@ -71,7 +73,9 @@
        obj = new Sequence(type);
        break;      
     default:
 -      printf("UNKNOWN ASN type=0x%02x\n", type);
-+      if (debug_level) printf("UNKNOWN ASN type=0x%02x\n", type);
-       debug("UNKNOWN", indent);
++      if (debug_level) {
++         printf("UNKNOWN ASN type=0x%02x\n", type);
++      }
        obj = NULL;
        break;      
+    }
This page took 0.092532 seconds and 4 git commands to generate.