]> git.pld-linux.org Git - packages/apcupsd.git/blob - apcupsd.spec
- added apcupsd.sysconfig
[packages/apcupsd.git] / apcupsd.spec
1 #
2 # Conditional build:
3 %bcond_without  test    # without TEST support
4 %bcond_with     usb     # with USB support
5 #
6 Summary:        Power management software for APC UPS hardware
7 Summary(pl):    Oprogramowanie do zarz±dzania energi± dla UPS-ów APC
8 Name:           apcupsd
9 Version:        3.10.15
10 Release:        2
11 License:        GPL v2
12 Group:          Networking/Daemons
13 Source0:        http://dl.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
14 # Source0-md5:  21b2b744ebcaa0010367a403a9c5e66c
15 # Source0-size: 3858266
16 Source1:        %{name}.init
17 Source2:        %{name}.logrotate
18 Source3:        %{name}.sysconfig
19 Patch0:         %{name}-configure.patch
20 URL:            http://www.apcupsd.com/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 Requires(post,preun):   /sbin/chkconfig
24 Requires(post): fileutils
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/apcupsd
28
29 %description
30 UPS power management under Linux for APCC Products. It allows your
31 computer/server to run during power problems for a specified length of
32 time or the life of the batteries in your BackUPS, BackUPS Pro,
33 SmartUPS v/s, or SmartUPS, and then properly executes a controlled
34 shutdown during an extended power failure.
35
36 %description -l pl
37 Oprogramowanie do zarz±dzania energi± dla UPS-ów APC. Pozwala
38 komputerowi dzia³aæ po awarii zasilania przez okre¶lony czas lub czas
39 ¿ycia akumulatorów w BackUPS, BackUPS Pro, SmartUPS v/s, SmartUPS oraz
40 odpowiednio uruchamia kontrolowany shutdown przy d³u¿szej awarii
41 zasilania.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 cd autoconf
49 cp -f /usr/share/automake/config.sub .
50 %{__autoconf}
51 cp -f ./configure ..
52 cd ..
53 %configure \
54         --with-log-dir=%{_var}/log \
55         --with-stat-dir=%{_var}/lib/apcupsd \
56 %if %{with test}
57         --enable-test \
58 %endif
59 %if %{with usb}
60         --enable-usb \
61         --with-serial-dev=/dev/usb/hiddev[0-15] \
62         --with-upstype=usb \
63         --with-upscable=usb
64 %endif
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d} \
71         $RPM_BUILD_ROOT/var/{log,lib/apcupsd}
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apcupsd
77 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apcupsd
78 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/apcupsd
79
80 touch $RPM_BUILD_ROOT/var/log/apcupsd.events
81 touch $RPM_BUILD_ROOT/var/lib/apcupsd/apcupsd.status
82
83 cat > $RPM_BUILD_ROOT/etc/rc.d/init.d/halt << EOF
84 #!/bin/sh
85 /etc/rc.d/init.d/apcupsd powerdown
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 /sbin/chkconfig --add apcupsd
93 if [ -f /var/lock/subsys/apcupsd ]; then
94         /etc/rc.d/init.d/apcupsd restart >&2
95 else
96         echo "Run \"/etc/rc.d/init.d/apcupsd start\" to start apcupsd daemon."
97 fi
98
99 %preun
100 if [ "$1" = "0" ]; then
101         if [ -f /var/lock/subsys/apcupsd ]; then
102                 /etc/rc.d/init.d/apcupsd stop >&2
103         fi
104 /sbin/chkconfig --del apcupsd
105 fi
106
107 %files
108 %defattr(644,root,root,755)
109 %doc ChangeLog Developers doc/{README.apcaccess,README.solaris}
110 %{_mandir}/man8/apcupsd.*
111 %attr(755,root,root) %{_sbindir}/*
112 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/apcupsd.conf
113 %attr(640,root,root) %config(noreplace) /etc/sysconfig/apcupsd
114 %attr(754,root,root) %{_sysconfdir}/apccontrol
115 %attr(754,root,root) %{_sysconfdir}/changeme
116 %attr(754,root,root) %{_sysconfdir}/commfailure
117 %attr(754,root,root) %{_sysconfdir}/commok
118 %attr(754,root,root) %{_sysconfdir}/mainsback
119 %attr(754,root,root) %{_sysconfdir}/masterconnect
120 %attr(754,root,root) %{_sysconfdir}/mastertimeout
121 %attr(754,root,root) %{_sysconfdir}/onbattery
122 %attr(754,root,root) /etc/rc.d/init.d/apcupsd
123 %attr(754,root,root) /etc/rc.d/init.d/halt
124 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/logrotate.d/apcupsd
125 %dir /etc/apcupsd
126 %dir /var/lib/apcupsd
127 %attr(640,root,root) %ghost /var/log/apcupsd.events
128 %attr(640,root,root) %ghost /var/lib/apcupsd/apcupsd.status
This page took 0.035713 seconds and 4 git commands to generate.