]> git.pld-linux.org Git - packages/apcupsd.git/blob - apcupsd.spec
450ba29539109498e854644dbc73f8be8927bbc3
[packages/apcupsd.git] / apcupsd.spec
1 #
2 # Conditional build:
3 %bcond_without  cgi     # without CGI program support
4 %bcond_without  gapcmon # without gapcmon GUI
5 %bcond_without  net     # without network support
6 %bcond_with     snmp    # with SNMP support
7 %bcond_without  test    # without TEST support
8 %bcond_without  usb     # without USB support
9
10 Summary:        Power management software for APC UPS hardware
11 Summary(pl.UTF-8):      Oprogramowanie do zarządzania energią dla UPS-ów APC
12 Name:           apcupsd
13 Version:        3.14.10
14 Release:        3
15 License:        GPL v2
16 Group:          Networking/Daemons
17 Source0:        http://downloads.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
18 # Source0-md5:  5928822d855c5cf7ac29655e3e0b8c23
19 Source1:        %{name}.init
20 Source2:        %{name}.logrotate
21 Source3:        %{name}.sysconfig
22 Patch0:         %{name}-configure.patch
23 Patch1:         %{name}-pcnet-seconds.patch
24 Patch2:         format-security.patch
25 URL:            http://www.apcupsd.com/
26 %{?with_gapcmon:BuildRequires:  GConf2-devel >= 2.0}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  gd-devel
30 %{?with_gapcmon:BuildRequires:  gtk+2-devel >= 2:2.4.0}
31 BuildRequires:  man-db
32 %{?with_snmp:BuildRequires:     net-snmp-devel}
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.268
35 BuildRequires:  util-linux
36 Requires(post): fileutils
37 Requires(post,preun):   /sbin/chkconfig
38 Requires:       rc-scripts
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sysconfdir     /etc/apcupsd
42 %define         _cgidir         /home/services/httpd/cgi-bin
43
44 %description
45 UPS power management under Linux for APCC Products. It allows your
46 computer/server to run during power problems for a specified length of
47 time or the life of the batteries in your BackUPS, BackUPS Pro,
48 SmartUPS v/s, or SmartUPS, and then properly executes a controlled
49 shutdown during an extended power failure.
50
51 %description -l pl.UTF-8
52 Oprogramowanie do zarządzania energią dla UPS-ów APC. Pozwala
53 komputerowi działać po awarii zasilania przez określony czas lub czas
54 życia akumulatorów w BackUPS, BackUPS Pro, SmartUPS v/s, SmartUPS oraz
55 odpowiednio uruchamia kontrolowany shutdown przy dłuższej awarii
56 zasilania.
57
58 %package cgi
59 Summary:        upsstats - Web-based UPS status viewer
60 Summary(pl.UTF-8):      upsstats - oparta na WWW przeglądarka stanu UPS-a
61 Group:          Applications/Networking
62 Requires:       webserver
63
64 %description cgi
65 upsstats.cgi builds a lightweight web page containing basic UPS status
66 information.
67
68 %description cgi -l pl.UTF-8
69 upsstats.cgi tworzy lekką stronę WWW zawierającą podstawowe informacje
70 o stanie UPS-a.
71
72 %package gapcmon
73 Summary:        Apcupsd GUI monitoring application
74 Summary(pl.UTF-8):      Aplikacja GUI monitorowania Apcupsd
75 Group:          X11/Applications
76 URL:            http://gapcmon.sourceforge.net/
77
78 %description gapcmon
79 GNOME/GTK+ based application which integrates into most desktop panels
80 (not just GNOME). It monitors one or more Apcupsd instances using
81 Apcupsd's NIS networking server. The status of each UPS is shown with
82 a icon.
83
84 %description gapcmon -l pl.UTF-8
85 Oparta na GNOME/GTK+ aplikacja, która integruje się z panelami (nie
86 tylko Gnome). Monitoruje jedną bądź kilka instancji Apcupsd za pomocą
87 serwera NIS. Status każdego UPS-a przedstawia ikona.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94
95 %build
96 for i in configure.in aclocal.m4 config.h.in; do install autoconf/$i .;done
97 cp -f %{_datadir}/automake/config.sub autoconf
98 %{__autoconf}
99 %configure \
100         APCUPSD_MAIL="/bin/mail" \
101         SHUTDOWN="/sbin/shutdown" \
102         WALL="%{_bindir}/wall" \
103         --with-log-dir=%{_var}/log \
104         --with-stat-dir=%{_var}/lib/apcupsd \
105         --enable-apcsmart \
106         --enable-dumb \
107         --enable-pcnet \
108 %if %{with cgi}
109         --enable-cgi \
110         --with-cgi-bin=/home/services/httpd/cgi-bin \
111 %endif
112         %{?with_test:--enable-test} \
113         %{?with_net:--enable-net} \
114         %{?with_gapcmon:--enable-gapcmon} \
115         %{?with_snmp:--enable-snmp} \
116         %{?with_usb:--enable-usb}
117
118 %{__make} \
119         VERBOSE=2
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d,sysconfig} \
124         $RPM_BUILD_ROOT/var/{log,lib/apcupsd}
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apcupsd
130 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apcupsd
131 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/apcupsd
132
133 touch $RPM_BUILD_ROOT/var/log/apcupsd.events
134 touch $RPM_BUILD_ROOT/var/lib/apcupsd/apcupsd.status
135
136 cat > $RPM_BUILD_ROOT/etc/rc.d/init.d/halt << EOF
137 #!/bin/sh
138 exec /etc/rc.d/init.d/apcupsd powerdown
139 EOF
140
141 # no hal
142 %{__rm} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/20thirdparty/80-apcupsd-ups-policy.fdi
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 /sbin/chkconfig --add apcupsd
149 %service apcupsd restart "apcupsd daemon"
150
151 %preun
152 if [ "$1" = "0" ]; then
153         %service apcupsd stop
154         /sbin/chkconfig --del apcupsd
155 fi
156
157 %files
158 %defattr(644,root,root,755)
159 %doc ChangeLog Developers
160 %attr(755,root,root) %{_sbindir}/apcaccess
161 %attr(755,root,root) %{_sbindir}/apctest
162 %attr(755,root,root) %{_sbindir}/apcupsd
163 %attr(755,root,root) %{_sbindir}/smtp
164 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apcupsd.conf
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/apcupsd
166 %attr(754,root,root) %{_sysconfdir}/apccontrol
167 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/changeme
168 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commfailure
169 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commok
170 #%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mainsback
171 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/onbattery
172 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/offbattery
173 %if %{with cgi}
174 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hosts.conf
175 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/multimon.conf
176 %{_sysconfdir}/apcupsd.css
177 %endif
178 %attr(754,root,root) /etc/rc.d/init.d/apcupsd
179 %attr(754,root,root) /etc/rc.d/init.d/halt
180 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/apcupsd
181 %dir %{_sysconfdir}
182 %dir /var/lib/apcupsd
183 %attr(640,root,root) %ghost /var/log/apcupsd.events
184 %attr(640,root,root) %ghost /var/lib/apcupsd/apcupsd.status
185 %{_mandir}/man8/apcupsd.8*
186 %{_mandir}/man8/apctest.8*
187 %{_mandir}/man8/apcaccess.8*
188 %{_mandir}/man8/apccontrol.8*
189 %{_mandir}/man5/apcupsd.conf.5*
190
191 %if %{with cgi}
192 %files cgi
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_cgidir}/*.cgi
195 %endif
196
197 %if %{with gapcmon}
198 %files gapcmon
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/gapcmon
201 %{_desktopdir}/gapcmon.desktop
202 %{_pixmapsdir}/*.png
203 %endif
This page took 0.547197 seconds and 2 git commands to generate.