]> git.pld-linux.org Git - packages/apache1.git/commitdiff
rel 15; builds master auto/th/apache1-1.3.42-15
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 2 Feb 2023 21:45:12 +0000 (22:45 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 2 Feb 2023 21:45:12 +0000 (22:45 +0100)
apache1-apxs-quiet.patch
apache1-apxs.patch
apache1-autoindex_indexes.patch
apache1-configure_hashbang.patch
apache1-lingerd.patch
apache1-proxy_content_base.patch
apache1-regex_must_conform_to_posix_for_LFS_to_work.patch
apache1-suexec_reopenlog.patch
apache1.spec

index 301529fe55a9d3950084ff6e36a9488fcc60ae01..fd1504dafc86e589d09587906df7dbfd2c0f1154 100644 (file)
@@ -1,14 +1,15 @@
---- apache_1.3.22/src/support/apxs.pl.orig     Fri Dec  7 20:32:18 2001
-+++ apache_1.3.22/src/support/apxs.pl  Fri Dec  7 21:47:25 2001
-@@ -111,6 +111,7 @@
+diff -urNp -x '*.orig' apache_1.3.42.org/src/support/apxs.pl apache_1.3.42/src/support/apxs.pl
+--- apache_1.3.42.org/src/support/apxs.pl      2023-02-02 22:42:09.429834914 +0100
++++ apache_1.3.42/src/support/apxs.pl  2023-02-02 22:42:09.649834915 +0100
+@@ -68,6 +68,7 @@ my $opt_i = 0;
  my $opt_a = 0;
  my $opt_A = 0;
  my $opt_q = 0;
 +my $opt_v = 0;
  
- #   this subroutine is derived from Perl's getopts.pl with the enhancement of
- #   the "+" metacharater at the format string to allow a list to be build by
-@@ -190,7 +191,7 @@
+ #   default for DSO file extension 
+ my $dso_ext = "so";
+@@ -153,7 +154,7 @@ sub usage {
  
  #   option handling
  my $rc;
@@ -17,7 +18,7 @@
  &usage if ($rc == 0);
  &usage if ($#ARGV == -1 and not $opt_g);
  &usage if (not $opt_q and not ($opt_g and $opt_n) and not $opt_i and not $opt_c and not $opt_e);
-@@ -247,7 +248,9 @@
+@@ -210,7 +211,9 @@ sub execute_cmds {
      my ($cmd, $rc);
  
      foreach $cmd (@cmds) {
index 85935223d5db355b49db4b7c2bbb71ee22bc60a5..6f29c7e98079d93e21a4aecc557a6625e1bda49e 100644 (file)
@@ -1,14 +1,15 @@
---- apache_1.3.11/src/support/apxs.pl.apxs     Thu Dec 16 17:10:30 1999
-+++ apache_1.3.11/src/support/apxs.pl  Tue Jan 25 01:19:16 2000
+diff -urNp -x '*.orig' apache_1.3.42.org/src/support/apxs.pl apache_1.3.42/src/support/apxs.pl
+--- apache_1.3.42.org/src/support/apxs.pl      2006-07-12 10:16:05.000000000 +0200
++++ apache_1.3.42/src/support/apxs.pl  2023-02-02 22:41:54.629834912 +0100
 @@ -1,4 +1,4 @@
 -#!/usr/local/bin/perl
 +#!/usr/bin/perl
  #
- # Copyright 1999-2004 The Apache Software Foundation
- #
-@@ -220,15 +220,14 @@
- ##  Initial DSO support check
+ # Licensed to the Apache Software Foundation (ASF) under one or more
+ # contributor license agreements.  See the NOTICE file distributed with
+@@ -188,15 +188,14 @@ if (@opt_S) {
  ##
+ if ($^O ne "MSWin32") {
  if (not -x "$CFG_SBINDIR/$CFG_TARGET") {
 -    print STDERR "apxs:Error: $CFG_SBINDIR/$CFG_TARGET not found or not executable\n";
 -    exit(1);
@@ -27,5 +28,5 @@
 +    print STDERR "apxs:Warning: binary `$CFG_SBINDIR/$CFG_TARGET'.\n";
 +    print STDERR "apxs:Warning: Continuing anyway...\n"; }
  }
+ }
  
- ##
index 61af3d452df9b98cae1dfbf3db4f9b4fb921dfa9..60011d971a6ce393433cc321a1d2979c20e2f74e 100644 (file)
@@ -1,6 +1,7 @@
---- build-tree-apache/apache_1.3.34/src/modules/standard/mod_autoindex.c       Wed Mar 13 22:05:33 2002
-+++ build-tree-apache/apache_1.3.34/src/modules/standard/mod_autoindex.c       Wed Apr 24 17:17:05 2002
-@@ -101,6 +101,7 @@
+diff -urNp -x '*.orig' apache_1.3.42.org/src/modules/standard/mod_autoindex.c apache_1.3.42/src/modules/standard/mod_autoindex.c
+--- apache_1.3.42.org/src/modules/standard/mod_autoindex.c     2023-02-02 22:43:12.489834914 +0100
++++ apache_1.3.42/src/modules/standard/mod_autoindex.c 2023-02-02 22:43:12.716501580 +0100
+@@ -59,6 +59,7 @@ module MODULE_VAR_EXPORT autoindex_modul
  #define TRACK_MODIFIED 1024
  #define SORT_NOCASE 2048
  #define STUDLY_INDEXING 4096
@@ -8,9 +9,9 @@
  
  #define K_PAD 1
  #define K_NOPAD 0
-@@ -463,6 +464,9 @@
+@@ -421,6 +422,9 @@ static const char *add_opts(cmd_parms *c
        else if (!strcasecmp(w, "IgnoreCase")) {
-               option = SORT_NOCASE;
+           option = SORT_NOCASE;
        }
 +      else if (!strcasecmp(w, "Indexes")) {
 +            option = INDEXOPT_INDEXES;
@@ -18,7 +19,7 @@
        else if (!strcasecmp(w, "None")) {
            if (action != '\0') {
                return "Cannot combine '+' or '-' with 'None' keyword";
-@@ -2012,7 +2016,7 @@
+@@ -1970,7 +1974,7 @@ static int index_directory(request_rec *
  static int handle_autoindex(request_rec *r)
  {
      autoindex_config_rec *d;
@@ -27,7 +28,7 @@
  
      d = (autoindex_config_rec *) ap_get_module_config(r->per_dir_config,
                                                      &autoindex_module);
-@@ -2023,8 +2027,12 @@
+@@ -1981,8 +1985,12 @@ static int handle_autoindex(request_rec
      }
  
      /* OK, nothing easy.  Trot out the heavy artillery... */
index 35437b3751e23104c3ae95f7c8d8d7223a76919a..77dae20e525f5ee50b604080e2fff647e0ce6685 100644 (file)
@@ -1,22 +1,22 @@
-diff -Naurd build-tree.orig/apache_1.3.34/configure build-tree/apache_1.3.34/configure
---- build-tree.orig/apache_1.3.34/configure    2004-02-20 23:40:50.000000000 +0100
-+++ build-tree/apache_1.3.34/configure 2004-05-15 00:06:13.000000000 +0200
+diff -urNp -x '*.orig' apache_1.3.42.org/configure apache_1.3.42/configure
+--- apache_1.3.42.org/configure        2023-02-02 22:43:53.016501583 +0100
++++ apache_1.3.42/configure    2023-02-02 22:43:53.329834916 +0100
 @@ -1,4 +1,4 @@
 -#!/bin/sh
 +#!/bin/bash
  #
- # Copyright 1999-2004 The Apache Software Foundation
- #
-diff -Naurd build-tree.orig/apache_1.3.34/src/Configure build-tree/apache_1.3.34/src/Configure
---- build-tree.orig/apache_1.3.34/src/Configure        2004-04-09 19:01:50.000000000 +0200
-+++ build-tree/apache_1.3.34/src/Configure     2004-05-15 00:06:57.000000000 +0200
+ # Licensed to the Apache Software Foundation (ASF) under one or more
+ # contributor license agreements.  See the NOTICE file distributed with
+diff -urNp -x '*.orig' apache_1.3.42.org/src/Configure apache_1.3.42/src/Configure
+--- apache_1.3.42.org/src/Configure    2023-02-02 22:43:53.066501583 +0100
++++ apache_1.3.42/src/Configure        2023-02-02 22:43:53.329834916 +0100
 @@ -1,4 +1,4 @@
 -#!/bin/sh
 +#!/bin/bash
  #
- # Copyright 1999-2004 The Apache Software Foundation
- #
-@@ -208,7 +208,7 @@
+ # Licensed to the Apache Software Foundation (ASF) under one or more
+ # contributor license agreements.  See the NOTICE file distributed with
+@@ -210,7 +210,7 @@ fi
  ##
  DBM_LIB="-ldbm"
  DB_LIB="-ldb"
@@ -25,12 +25,12 @@ diff -Naurd build-tree.orig/apache_1.3.34/src/Configure build-tree/apache_1.3.34
  SUBTARGET="target_static"
  SHLIB_SUFFIX_NAME=""
  SHLIB_SUFFIX_LIST=""
-diff -Naurd build-tree.orig/apache_1.3.34/src/helpers/TestCompile build-tree/apache_1.3.34/src/helpers/TestCompile
---- build-tree.orig/apache_1.3.34/src/helpers/TestCompile      2004-02-16 23:23:09.000000000 +0100
-+++ build-tree/apache_1.3.34/src/helpers/TestCompile   2004-05-15 00:07:11.000000000 +0200
+diff -urNp -x '*.orig' apache_1.3.42.org/src/helpers/TestCompile apache_1.3.42/src/helpers/TestCompile
+--- apache_1.3.42.org/src/helpers/TestCompile  2006-07-12 10:16:05.000000000 +0200
++++ apache_1.3.42/src/helpers/TestCompile      2023-02-02 22:43:53.333168250 +0100
 @@ -1,4 +1,4 @@
 -#!/bin/sh
 +#!/bin/bash
  #
- # Copyright 1999-2004 The Apache Software Foundation
- #
+ # Licensed to the Apache Software Foundation (ASF) under one or more
+ # contributor license agreements.  See the NOTICE file distributed with
index a2cf1d7921eae4ff3ee2a99b68edbe13c6da2213..d9235c36c24750adf462f9f2074309661628d97e 100644 (file)
 #  instead of the regular apache-1.3/aplinger.diff.
 #
 
---- apache_1.3.39/src/main/Makefile.tmpl.org   Sat Dec  2 16:09:32 2000
-+++ apache_1.3.39/src/main/Makefile.tmpl       Sat Dec  2 16:23:34 2000
-@@ -5,13 +5,13 @@
+diff -urNp -x '*.orig' apache_1.3.42.org/src/main/Makefile.tmpl apache_1.3.42/src/main/Makefile.tmpl
+--- apache_1.3.42.org/src/main/Makefile.tmpl   2004-11-24 20:10:19.000000000 +0100
++++ apache_1.3.42/src/main/Makefile.tmpl       2023-02-02 22:44:19.209834916 +0100
+@@ -5,13 +5,13 @@ INCLUDES=$(INCLUDES1) $(INCLUDES0) $(EXT
  LDFLAGS=$(LDFLAGS1) $(EXTRA_LDFLAGS)
  
  LIB=  libmain.a
  
  .c.o:
        $(CC) -c $(INCLUDES) $(CFLAGS) $<
---- apache_1.3.39/src/main/http_main.c~        2007-10-23 01:51:50.000000000 +0300
-+++ apache_1.3.39/src/main/http_main.c 2007-10-23 01:52:32.306586698 +0300
-@@ -102,6 +102,10 @@
+diff -urNp -x '*.orig' apache_1.3.42.org/src/main/http_main.c apache_1.3.42/src/main/http_main.c
+--- apache_1.3.42.org/src/main/http_main.c     2023-02-02 22:44:18.889834915 +0100
++++ apache_1.3.42/src/main/http_main.c 2023-02-02 22:44:19.213168249 +0100
+@@ -60,6 +60,10 @@ int ap_main(int argc, char *argv[]);
  #include "http_vhost.h"
  #include "util_script.h"      /* to force util_script.c linking */
  #include "util_uri.h"
@@ -45,7 +47,7 @@
  #include "scoreboard.h"
  #include "multithread.h"
  #include <sys/stat.h>
-@@ -1575,6 +1578,19 @@
+@@ -1993,6 +1997,19 @@ static void lingering_close(request_rec
        return;
      }
  
@@ -65,9 +67,9 @@
      /* Set up to wait for readable data on socket... */
  
      FD_ZERO(&lfds);
-@@ -4484,6 +4486,8 @@
+@@ -4538,6 +4555,8 @@ static void common_init(void)
+     ap_server_post_read_config = ap_make_array(pcommands, 1, sizeof(char *));
      ap_server_config_defines   = ap_make_array(pcommands, 1, sizeof(char *));
-     pid_table                  = ap_make_table(pglobal, HARD_SERVER_LIMIT);
  
 +    lingerd_connect();
 +
index 0a5a5c2593eba6d91e6870b29ee604e745c38f5d..9ad458e5b9dc33cd842a587a6f59b20b3c6f2902 100644 (file)
@@ -1,7 +1,7 @@
-diff -ruN -x Makefile.in -x '*~' -x build-tree.orig -x 'ap_ctx.[ch]' -x 'ap_hook.[ch]' -x 'ap_mm.[ch]' -x os-inline.c -x os.h build-tree.orig/apache_1.3.34/src/modules/proxy/proxy_http.c build-tree/apache_1.3.34/src/modules/proxy/proxy_http.c
---- build-tree.orig/apache_1.3.34/src/modules/proxy/proxy_http.c       2003-02-03 12:13:26.000000000 -0500
-+++ build-tree/apache_1.3.34/src/modules/proxy/proxy_http.c    2003-10-17 12:24:51.000000000 -0400
-@@ -552,6 +595,8 @@
+diff -urNp -x '*.orig' apache_1.3.42.org/src/modules/proxy/proxy_http.c apache_1.3.42/src/modules/proxy/proxy_http.c
+--- apache_1.3.42.org/src/modules/proxy/proxy_http.c   2023-02-02 22:43:29.949834915 +0100
++++ apache_1.3.42/src/modules/proxy/proxy_http.c       2023-02-02 22:43:30.219834915 +0100
+@@ -604,6 +604,8 @@ int ap_proxy_http_handler(request_rec *r
          ap_table_set(resp_hdrs, "URI", proxy_location_reverse_map(r, urlstr));
      if ((urlstr = ap_table_get(resp_hdrs, "Content-Location")) != NULL)
          ap_table_set(resp_hdrs, "Content-Location", proxy_location_reverse_map(r, urlstr));
@@ -9,4 +9,4 @@ diff -ruN -x Makefile.in -x '*~' -x build-tree.orig -x 'ap_ctx.[ch]' -x 'ap_hook
 +        ap_table_set(resp_hdrs, "Content-Base", proxy_location_reverse_map(r, urlstr));
  
  /* check if NoCache directive on this host */
-     if (nocache == 0) {
+   {
index 44fc273e01db2ecdb3614a5854b53f83344040ed..80e93876a54f8d928bab4df0e302f390c8295c0d 100644 (file)
@@ -1,8 +1,8 @@
-diff -ruN -x Makefile.in -x configure -x *~ -x apache_1.3.14.orig apache_1.3.14.orig/src/include/hsregex.h apache_1.3.14/src/include/hsregex.h
---- build-tree/apache_1.3.34/src/include/hsregex.h     Mon Sep 25 16:48:24 2000
-+++ build-tree/apache_1.3.34/src/include/hsregex.h     Wed Dec  6 15:20:03 2000
-@@ -24,7 +24,7 @@
- #endif
+diff -urNp -x '*.orig' apache_1.3.42.org/src/include/hsregex.h apache_1.3.42/src/include/hsregex.h
+--- apache_1.3.42.org/src/include/hsregex.h    2005-10-10 19:45:29.000000000 +0200
++++ apache_1.3.42/src/include/hsregex.h        2023-02-02 22:42:24.093168248 +0100
+@@ -22,7 +22,7 @@ extern "C" {
+ #define ap_private_extern
  #endif
  
 -typedef off_t regoff_t;
index 4bab1cb8de8f4393e2cdde43d86b5eea07f66c08..8c5f7aa7478c6bd55080063f474069c02838c73b 100644 (file)
@@ -1,9 +1,9 @@
-diff -Naurd build-tree.orig/apache_1.3.34/src/support/suexec.c build-tree/apache_1.3.34/src/support/suexec.c
---- build-tree.orig/apache_1.3.34/src/support/suexec.c 2004-08-23 23:36:55.000000000 +0200
-+++ build-tree/apache_1.3.34/src/support/suexec.c      2004-08-23 23:40:35.000000000 +0200
+diff -urNp -x '*.orig' apache_1.3.42.org/src/support/suexec.c apache_1.3.42/src/support/suexec.c
+--- apache_1.3.42.org/src/support/suexec.c     2006-07-12 10:16:05.000000000 +0200
++++ apache_1.3.42/src/support/suexec.c 2023-02-02 22:42:51.499834914 +0100
 @@ -49,6 +49,10 @@
  #include <stdarg.h>
- #include <strings.h>
  
 +/* for fcntl(fileno(log), F_SETFD, FD_CLOEXEC); */
 +#include <unistd.h>
@@ -12,7 +12,7 @@ diff -Naurd build-tree.orig/apache_1.3.34/src/support/suexec.c build-tree/apache
  #include "suexec.h"
  
  /*
-@@ -151,6 +155,8 @@
+@@ -148,6 +152,8 @@ static void err_output(const char *fmt,
            perror("fopen");
            exit(1);
        }
@@ -21,7 +21,7 @@ diff -Naurd build-tree.orig/apache_1.3.34/src/support/suexec.c build-tree/apache
      }
  
      time(&timevar);
-@@ -823,20 +829,6 @@
+@@ -568,20 +574,6 @@ int main(int argc, char *argv[])
      umask(SUEXEC_UMASK);
  #endif /* SUEXEC_UMASK */
  
index 44c8de08f5c3cff9fa6ffe0b876d9ff07cddb5ea..819c5fae7195cb58339c24d7b38a623d67311f5e 100644 (file)
@@ -31,7 +31,7 @@ Summary(uk.UTF-8):    Найпопулярніший Web-Server
 Summary(zh_CN.UTF-8):  Internet 上应用最广泛的 Web 服务程序。
 Name:          apache1
 Version:       1.3.42
-Release:       14
+Release:       15
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://archive.apache.org/dist/httpd/apache_%{version}.tar.gz
@@ -249,7 +249,7 @@ Requires(pre):      /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(pre): /usr/sbin/usermod
 Requires(pre): textutils
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      /etc/mime.types
 Requires:      mailcap
 Requires:      psmisc >= 20.1
@@ -640,7 +640,7 @@ przeglądarki i umożliwienie użytkownikom współdzielenia URL-i.
 Summary:       Apache module with user authentication which uses Berkeley DB files
 Summary(pl.UTF-8):     Moduł Apache'a z mechanizmem uwierzytelniania używającym plików Berkeley DB
 Group:         Networking/Daemons/HTTP
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      %{name}(EAPI) = %{version}-%{release}
 Provides:      apache(mod_auth_db) = %{version}-%{release}
 Obsoletes:     apache-mod_auth_db < 2.0.0
@@ -674,7 +674,7 @@ Authentication.
 Summary:       Apache module - display index of files
 Summary(pl.UTF-8):     Moduł apache do wyświetlania indeksu plików
 Group:         Networking/Daemons/HTTP
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      %{name}(EAPI) = %{version}-%{release}
 Requires:      %{name}-mod_alias = %{version}-%{release}
 Requires:      apache-icons
@@ -1098,7 +1098,7 @@ dostępnych dokumentów. Są dwie różne implementacje.
 Summary:       Apache module with Web proxy
 Summary(pl.UTF-8):     Moduł dodający obsługę serwera proxy
 Group:         Networking/Daemons/HTTP
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      %{name}(EAPI) = %{version}-%{release}
 Provides:      apache(mod_proxy) = %{version}-%{release}
 Obsoletes:     apache-mod_proxy < 2.0.0
@@ -1185,7 +1185,7 @@ dla tej strategii.
 Summary:       Server status report module for apache
 Summary(pl.UTF-8):     Moduł dostarczający informacje statystyczne o serwerze
 Group:         Networking/Daemons/HTTP
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      %{name}(EAPI) = %{version}-%{release}
 Provides:      apache(mod_status) = %{version}-%{release}
 Obsoletes:     apache-mod_status < 2.0.0
@@ -1261,7 +1261,7 @@ wiele plików logów.
 Summary:       Apache module for dynamically configured mass virtual hosting
 Summary(pl.UTF-8):     Moduł dodający obsługę hostów wirtualnych
 Group:         Networking/Daemons/HTTP
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      %{name}(EAPI) = %{version}-%{release}
 Provides:      apache(mod_vhost_alias) = %{version}-%{release}
 Obsoletes:     apache-mod_vhost_alias < 2.0.0
@@ -1337,16 +1337,16 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch24 -p1
 %patch25 -p1
 
-%patch26 -p2
+%patch26 -p1
 %patch27 -p2
-%patch28 -p2
+%patch28 -p1
 %patch29 -p2
-%patch30 -p2
+%patch30 -p1
 %patch31 -p2
 %patch32 -p2
-%patch33 -p2
+%patch33 -p1
 %patch34 -p2
-%patch35 -p2
+%patch35 -p1
 %patch36 -p2
 %patch37 -p2
 %patch38 -p2
This page took 0.141704 seconds and 4 git commands to generate.