]> git.pld-linux.org Git - packages/apache1.git/commitdiff
- sorted module post scripts
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 5 Mar 2005 17:30:54 +0000 (17:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache1.spec -> 1.83.2.11

apache1.spec

index afc488f7699aa4bb0b14b62ceba357904806730d..95157bb52eed29ceae3da460d9653f4749db26f9 100644 (file)
@@ -1289,7 +1289,6 @@ cat <<EOF
        mod_userdir
 EOF
 
-# XXXXXXXXXXXXXXXXXXX
 %post mod_access
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
@@ -1304,464 +1303,451 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
-%post mod_alias
+%post mod_actions
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_alias
+%postun mod_actions
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_asis
+%post mod_alias
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_asis
+%postun mod_alias
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_cern_meta
+%post mod_asis
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_cern_meta
+%postun mod_asis
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_cgi
+%post mod_auth
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_cgi
+%postun mod_auth
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_env
+%post mod_auth_anon
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_env
+%postun mod_auth_anon
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_include
+%post mod_auth_db
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_include
+%postun mod_auth_db
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_log_agent
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-fi
+%triggerpostun mod_auth_db -- apache-mod_auth_db <= 1.3.20-2
+%{apxs} -e -A -n auth_dbm %{_libexecdir}/mod_auth_dbm.so 1>&2
 
-%postun mod_log_agent
+%post mod_auth_digest
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
+       else
+               echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
        fi
 fi
 
-%post mod_log_config
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-fi
-
-%postun mod_log_config
+%postun mod_auth_digest
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_log_referer
+%post mod_autoindex
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_log_referer
+%postun mod_autoindex
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_mime
+%triggerpostun mod_autoindex -- apache1-mod_autoindex < 1.3.33-1.85
+%{apxs} -e -A -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
+sed -i -e '
+       s,^Include.*mod_autoindex.conf,Include %{_sysconfdir}/conf.d/*_mod_autoindex.conf,
+' /etc/apache/apache.conf
+
+%post mod_cern_meta
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_mime
+%postun mod_cern_meta
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_mime_magic
+%post mod_cgi
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_mime_magic
+%postun mod_cgi
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_negotiation
+%post mod_define
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_negotiation
+%postun mod_define
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_setenvif
+%post mod_digest
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_setenvif
+%postun mod_digest
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_speling
+%post mod_dir
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_speling
+%postun mod_dir
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_userdir
+%post mod_env
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_userdir
+%postun mod_env
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
-# XXXXXXXXXXXXXXXXXXX
 
-%post mod_actions
+%post mod_expires
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_actions
+%postun mod_expires
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_auth
+%post mod_headers
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth
+%postun mod_headers
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_auth_anon
+%post mod_imap
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth_anon
+%postun mod_imap
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_auth_db
+%post mod_include
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth_db
+%postun mod_include
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%triggerpostun mod_auth_db -- apache-mod_auth_db <= 1.3.20-2
-%{apxs} -e -A -n auth_dbm %{_libexecdir}/mod_auth_dbm.so 1>&2
-
-%post mod_auth_digest
-if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache restart 1>&2
-       else
-               echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-       fi
+%post mod_info
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth_digest
+%postun mod_info
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_autoindex
+# XXXXXXXXXXXXXXXXXXX
+
+%post mod_log_agent
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_autoindex
+%postun mod_log_agent
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%triggerpostun mod_autoindex -- apache1-mod_autoindex < 1.3.33-1.85
-%{apxs} -e -A -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
-sed -i -e '
-       s,^Include.*mod_autoindex.conf,Include %{_sysconfdir}/conf.d/*_mod_autoindex.conf,
-' /etc/apache/apache.conf
-
-%post mod_define
+%post mod_log_config
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_define
+%postun mod_log_config
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_digest
+%post mod_log_forensic
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_digest
+%postun mod_log_forensic
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_dir
+%post mod_log_referer
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_dir
+%postun mod_log_referer
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_expires
+%post mod_mime
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_expires
+%postun mod_mime
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_headers
+%post mod_mime_magic
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_headers
+%postun mod_mime_magic
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_imap
+%post mod_mmap_static
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_imap
+%postun mod_mmap_static
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_info
+%post mod_negotiation
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_info
+%postun mod_negotiation
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_log_forensic
+%post mod_proxy
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_log_forensic
+%postun mod_proxy
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_mmap_static
+%triggerpostun mod_proxy -- apache1-mod_proxy < 1.3.33-1.85
+%{apxs} -e -A -n proxy %{_libexecdir}/libproxy.so 1>&2
+sed -i -e '
+       s,^Include.*mod_proxy.conf,Include %{_sysconfdir}/conf.d/*_mod_proxy.conf,
+' /etc/apache/apache.conf
+
+%post mod_rewrite
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_mmap_static
+%postun mod_rewrite
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_proxy
+%post mod_setenvif
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_proxy
+%postun mod_setenvif
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%triggerpostun mod_proxy -- apache1-mod_proxy < 1.3.33-1.85
-%{apxs} -e -A -n proxy %{_libexecdir}/libproxy.so 1>&2
-sed -i -e '
-       s,^Include.*mod_proxy.conf,Include %{_sysconfdir}/conf.d/*_mod_proxy.conf,
-' /etc/apache/apache.conf
-
-%post mod_rewrite
+%post mod_speling
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_rewrite
+%postun mod_speling
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
@@ -1802,6 +1788,20 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
+%post mod_userdir
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
+fi
+
+%postun mod_userdir
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
+       fi
+fi
+
 %post mod_usertrack
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
This page took 0.090217 seconds and 4 git commands to generate.