]> git.pld-linux.org Git - packages/apache1.git/commitdiff
- taken from last revisions for apache 1.3.27
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 31 Dec 2002 10:36:18 +0000 (10:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache1-apxs.patch -> 1.1
    apache1-configdir_skip_backups.patch -> 1.1
    apache1-httpd.conf -> 1.1
    apache1-mod_proxy.conf -> 1.1
    apache1-mod_status.conf -> 1.1
    apache1-mod_vhost_alias.conf -> 1.1
    apache1-suexec.patch -> 1.1
    apache1.init -> 1.1

apache1-apxs.patch [new file with mode: 0644]
apache1-configdir_skip_backups.patch [new file with mode: 0644]
apache1-httpd.conf [new file with mode: 0644]
apache1-mod_proxy.conf [new file with mode: 0644]
apache1-mod_status.conf [new file with mode: 0644]
apache1-mod_vhost_alias.conf [new file with mode: 0644]
apache1-suexec.patch [new file with mode: 0644]
apache1.init [new file with mode: 0644]

diff --git a/apache1-apxs.patch b/apache1-apxs.patch
new file mode 100644 (file)
index 0000000..3229c8e
--- /dev/null
@@ -0,0 +1,31 @@
+--- apache_1.3.11/src/support/apxs.pl.apxs     Thu Dec 16 17:10:30 1999
++++ apache_1.3.11/src/support/apxs.pl  Tue Jan 25 01:19:16 2000
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+ ## ====================================================================
+ ## Copyright (c) 1998-1999 The Apache Group.  All rights reserved.
+ ##
+@@ -220,15 +220,15 @@
+ ##  Initial DSO support check
+ ##
+ if (not -x "$CFG_SBINDIR/$CFG_TARGET") {
+-    print STDERR "apxs:Error: $CFG_SBINDIR/$CFG_TARGET not found or not executable\n";
+-    exit(1);
++    print STDERR "apxs:Warning: $CFG_SBINDIR/$CFG_TARGET not found or not executable\n";
++    print STDERR "apxs:Warning: Continuing anyway...\n";
+ }
+ if (not grep(/mod_so/, `$CFG_SBINDIR/$CFG_TARGET -l`)) {
+-    print STDERR "apxs:Error: Sorry, no DSO support for Apache available\n";
+-    print STDERR "apxs:Error: under your platform. Make sure the Apache\n";
+-    print STDERR "apxs:Error: module mod_so is compiled into your server\n";
+-    print STDERR "apxs:Error: binary `$CFG_SBINDIR/$CFG_TARGET'.\n";
+-    exit(1);
++    print STDERR "apxs:Warning: Sorry, no DSO support for Apache available\n";
++    print STDERR "apxs:Warning: under your platform. Make sure the Apache\n";
++    print STDERR "apxs:Warning: module mod_so is compiled into your server\n";
++    print STDERR "apxs:Warning: binary `$CFG_SBINDIR/$CFG_TARGET'.\n";
++    print STDERR "apxs:Warning: Continuing anyway...\n";
+ }
+ ##
diff --git a/apache1-configdir_skip_backups.patch b/apache1-configdir_skip_backups.patch
new file mode 100644 (file)
index 0000000..68233e4
--- /dev/null
@@ -0,0 +1,35 @@
+--- apache_1.3.17/src/main/http_config.c.wiget Thu May 10 14:41:08 2001
++++ apache_1.3.17/src/main/http_config.c       Thu May 10 15:42:12 2001
+@@ -1287,6 +1287,7 @@
+       DIR *dirp;
+       struct DIR_TYPE *dir_entry;
+       int current;
++      size_t slen;
+       array_header *candidates = NULL;
+       fnames *fnew;
+@@ -1309,13 +1310,21 @@
+       }
+       candidates = ap_make_array(p, 1, sizeof(fnames));
+       while ((dir_entry = readdir(dirp)) != NULL) {
++          slen = strlen(dir_entry->d_name);
+           /* strip out '.' and '..' */
+           if (strcmp(dir_entry->d_name, ".") &&
+               strcmp(dir_entry->d_name, "..") &&
+                 (!ispatt ||
+-                 !ap_fnmatch(pattern,dir_entry->d_name, FNM_PERIOD)) ) {
+-              fnew = (fnames *) ap_push_array(candidates);
+-              fnew->fname = ap_make_full_path(p, path, dir_entry->d_name);
++                !ap_fnmatch(pattern,dir_entry->d_name, FNM_PERIOD)) &&
++              (dir_entry->d_name)[slen-1] != '~') {
++                  if (slen < 8 || strcmp((dir_entry->d_name + slen - 7), ".rpmnew")) {
++                          if (slen < 9 || 
++                              strcmp((dir_entry->d_name + slen - 8), ".rpmorig") && 
++                              strcmp((dir_entry->d_name + slen - 8), ".rpmsave")) {
++                                  fnew = (fnames *) ap_push_array(candidates);
++                                  fnew->fname = ap_make_full_path(p, path, dir_entry->d_name);
++                          }
++                  }
+           }
+       }
+       ap_pclosedir(p, dirp);
diff --git a/apache1-httpd.conf b/apache1-httpd.conf
new file mode 100644 (file)
index 0000000..de4003f
--- /dev/null
@@ -0,0 +1,812 @@
+##
+## httpd.conf -- Apache HTTP server configuration file
+##
+
+##### Global Environment
+# The directives in this section affect the overall operation of Apache,
+# such as the number of concurrent requests it can handle or where it can
+# find its configuration files.
+
+### ServerType
+# is either inetd, or standalone. Inetd mode is only supported on Unix
+# platforms.
+
+ServerType standalone
+
+### PidFile
+# The file in which the server should record its process identification
+# number when it starts.
+
+PidFile /var/run/httpd.pid
+
+### Timeout
+# The number of seconds before receives and sends time out.
+### KeepAliveTimeout
+# Number of seconds to wait for the next request from the same client on the
+# same connection.
+
+Timeout                        300
+KeepAliveTimeout       15
+
+### KeepAlive
+# Whether or not to allow persistent connections (more than one request per
+# connection). Set to "Off" to deactivate.
+### MaxKeepAliveRequests
+# The maximum number of requests to allow during a persistent connection.
+# Set to 0 to allow an unlimited amount. We recommend you leave this number
+# high, for maximum performance.
+
+KeepAlive              On
+MaxKeepAliveRequests   100
+
+### ServerRoot
+# The top of the directory tree under which the server's configuration,
+# error, and log files are kept.
+#
+# NOTE!  If you intend to place this on an NFS (or otherwise network)
+# mounted filesystem then please read the LockFile documentation
+# (available at <URL:http://www.apache.org/docs/mod/core.html#lockfile>);
+# you will save yourself a lot of trouble.
+#
+# Do NOT add a slash at the end of the directory path.
+#
+ServerRoot "/usr"
+
+### LockFile
+# The LockFile directive sets the path to the lockfile used when Apache
+# is compiled with either USE_FCNTL_SERIALIZED_ACCEPT or
+# USE_FLOCK_SERIALIZED_ACCEPT. This directive should normally be left at
+# its default value. The main reason for changing it is if the logs
+# directory is NFS mounted, since the lockfile MUST BE STORED ON A LOCAL
+# DISK. The PID of the main server process is automatically appended to
+# the filename. 
+#
+LockFile /var/run/httpd.lock
+
+### ScoreBoardFile
+# File used to store internal server process information. Not all
+# architectures require this. But if yours does (you'll know because this
+# file will be created when you run Apache) then you *must* ensure that no
+# two invocations of Apache share the same scoreboard file.
+
+ScoreBoardFile /var/run/httpd.scoreboard
+
+#
+# In the standard configuration, the server will process this file,
+# srm.conf, and access.conf in that order.  The latter two files are
+# now distributed empty, as it is recommended that all directives
+# be kept in a single file for simplicity.  The commented-out values
+# below are the built-in defaults.  You can have the server ignore
+# these files altogether by using "/dev/null" (for Unix) or
+# "nul" (for Win32) for the arguments to the directives.
+#
+ResourceConfig  /dev/null
+AccessConfig    /dev/null
+
+#
+# Server-pool size regulation.  Rather than making you guess how many
+# server processes you need, Apache dynamically adapts to the load it
+# sees --- that is, it tries to maintain enough server processes to
+# handle the current load, plus a few spare servers to handle transient
+# load spikes (e.g., multiple simultaneous requests from a single
+# Netscape browser).
+#
+# It does this by periodically checking how many servers are waiting
+# for a request.  If there are fewer than MinSpareServers, it creates
+# a new spare.  If there are more than MaxSpareServers, some of the
+# spares die off.  The default values are probably OK for most sites.
+#
+MinSpareServers 5
+MaxSpareServers 10
+
+#
+# Number of servers to start initially --- should be a reasonable ballpark
+# figure.
+#
+StartServers 5
+
+#
+# Limit on total number of servers running, i.e., limit on the number
+# of clients who can simultaneously connect --- if this limit is ever
+# reached, clients will be LOCKED OUT, so it should NOT BE SET TOO LOW.
+# It is intended mainly as a brake to keep a runaway server from taking
+# the system with it as it spirals down...
+#
+MaxClients 150
+
+#
+# MaxRequestsPerChild: the number of requests each child process is
+# allowed to process before the child dies.  The child will exit so
+# as to avoid problems after prolonged use when Apache (and maybe the
+# libraries it uses) leak memory or other resources.  On most systems, this
+# isn't really needed, but a few (such as Solaris) do have notable leaks
+# in the libraries.  For these platforms, set to something like 10000
+# or so; a setting of 0 means unlimited.
+#
+# NOTE: This value does not include keepalive requests after the initial
+#       request per connection. For example, if a child process handles
+#       an initial request and 10 subsequent "keptalive" requests, it
+#       would only count as 1 request towards this limit.
+
+MaxRequestsPerChild 30
+
+### Listen
+# Allows you to bind Apache to specific IP addresses and/or ports, in
+# addition to the default. See also the <VirtualHost> directive.
+
+#Listen 12.34.56.78:80
+Listen 80
+
+# Listen can take two arguments.
+# (this is an extension for supporting IPv6 addresses)
+#Listen :: 80
+#Listen 0.0.0.0 80
+
+### BindAddress
+# You can support virtual hosts with this option. This directive is used to
+# tell the server which IP address to listen to. It can either contain "*",
+# an IP address, or a fully qualified Internet domain name. See also the
+# <VirtualHost> and Listen directives.
+
+#BindAddress *
+
+
+### Section 2: Dynamic Shared Object (DSO) Support
+#
+# Example:
+# LoadModule foo_module libexec/mod_foo.so
+
+#  Reconstruction of the complete module list from all available modules
+#  (static and shared ones) to achieve correct module execution order.
+#  [WHENEVER YOU CHANGE THE LOADMODULE SECTION ABOVE UPDATE THIS, TOO]
+ClearModuleList
+AddModule mod_so.c
+
+### ExtendedStatus
+# controls whether Apache will generate "full" status information
+# (ExtendedStatus On) or just basic information (ExtendedStatus Off) when
+# the "server-status" handler is called. The default is Off.
+
+#ExtendedStatus On
+
+### Section 3: 'Main' server configuration
+#
+# The directives in this section set up the values used by the 'main'
+# server, which responds to any requests that aren't handled by a
+# <VirtualHost> definition.  These values also provide defaults for
+# any <VirtualHost> containers you may define later in the file.
+#
+# All of these directives may appear inside <VirtualHost> containers,
+# in which case these default settings will be overridden for the
+# virtual host being defined.
+#
+
+#
+# If your ServerType directive (set earlier in the 'Global Environment'
+# section) is set to "inetd", the next few directives don't have any
+# effect since their settings are defined by the inetd configuration.
+# Skip ahead to the ServerAdmin directive.
+#
+
+#
+# Port: The port to which the standalone server listens. For
+# ports < 1023, you will need httpd to be run as root initially.
+#
+Port 80
+
+#
+# If you wish httpd to run as a different user or group, you must run
+# httpd as root initially and it will switch.  
+#
+User  http
+Group http
+
+#
+# ServerAdmin: Your address, where problems with the server should be
+# e-mailed.  This address appears on some server-generated pages, such
+# as error documents.
+#
+ServerAdmin admin@your_domain.org
+
+#
+# ServerName allows you to set a host name which is sent back to clients for
+# your server if it's different than the one the program would get (i.e., use
+# "www" instead of the host's real name).
+#
+# Note: You cannot just invent host names and hope they work. The name you 
+# define here must be a valid DNS name for your host. If you don't understand
+# this, ask your network administrator.
+# If your host doesn't have a registered DNS name, enter its IP address here.
+# You will have to access it by its address (e.g., http://123.45.67.89/)
+# anyway, and this will make redirections work in a sensible way.
+#
+# 127.0.0.1 is the TCP/IP local loop-back address, often named localhost. Your
+# machine always knows itself by this address. If you use Apache strictly for
+# local testing and development, you may use 127.0.0.1 as the server name.
+#
+#ServerName new.host.name
+
+#
+# DocumentRoot: The directory out of which you will serve your
+# documents. By default, all requests are taken from this directory, but
+# symbolic links and aliases may be used to point to other locations.
+#
+DocumentRoot "/home/httpd/html"
+
+#
+# Each directory to which Apache has access, can be configured with respect
+# to which services and features are allowed and/or disabled in that
+# directory (and its subdirectories). 
+#
+# First, we configure the "default" to be a very restrictive set of 
+# permissions.  
+#
+<Directory />
+       Options FollowSymLinks
+       AllowOverride None
+</Directory>
+
+#
+# Note that from this point forward you must specifically allow
+# particular features to be enabled - so if something's not working as
+# you might expect, make sure that you have specifically enabled it
+# below.
+#
+
+#
+# This should be changed to whatever you set DocumentRoot to.
+#
+<Directory "/home/httpd/html">
+
+#
+# This may also be "None", "All", or any combination of "Indexes",
+# "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
+#
+# Note that "MultiViews" must be named *explicitly* --- "Options All"
+# doesn't give it to you.
+#
+       Options Indexes FollowSymLinks MultiViews
+
+#
+# This controls which options the .htaccess files in directories can
+# override. Can also be "All", or any combination of "Options", "FileInfo", 
+# "AuthConfig", and "Limit"
+#
+       AllowOverride None
+
+#
+# Controls who can get stuff from this server.
+#
+       Order allow,deny
+       Allow from all
+</Directory>
+
+#
+# UserDir: The name of the directory which is appended onto a user's home
+# directory if a ~user request is received.
+#
+UserDir public_html
+
+#
+# Control access to UserDir directories.  The following is an example
+# for a site where these directories are restricted to read-only.
+#
+#<Directory /home/users/*/public_html>
+#    AllowOverride FileInfo AuthConfig Limit
+#    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
+#    <Limit GET POST OPTIONS PROPFIND>
+#        Order allow,deny
+#        Allow from all
+#    </Limit>
+#    <LimitExcept GET POST OPTIONS PROPFIND>
+#        Order deny,allow
+#        Deny from all
+#    </LimitExcept>
+#</Directory>
+
+#
+# DirectoryIndex: Name of the file or files to use as a pre-written HTML
+# directory index.  Separate multiple entries with spaces.
+#
+<IfModule mod_dir.c>
+       DirectoryIndex index.html index.htm index.shtml index.cgi index.php
+</IfModule>
+
+#
+# AccessFileName: The name of the file to look for in each directory
+# for access control information.
+#
+AccessFileName .htaccess
+
+#
+# The following lines prevent .htaccess files from being viewed by
+# Web clients.  Since .htaccess files often contain authorization
+# information, access is disallowed for security reasons.  Comment
+# these lines out if you want Web visitors to see the contents of
+# .htaccess files.  If you change the AccessFileName directive above,
+# be sure to make the corresponding changes here.
+#
+# Also, folks tend to use names such as .htpasswd for password
+# files, so this will protect those as well.
+#
+<Files ~ "^\.ht">
+       Order allow,deny
+       Deny from all
+       Satisfy All
+</Files>
+
+#
+# CacheNegotiatedDocs: By default, Apache sends "Pragma: no-cache" with each
+# document that was negotiated on the basis of content. This asks proxy
+# servers not to cache the document. Uncommenting the following line disables
+# this behavior, and proxies will be allowed to cache the documents.
+#
+#CacheNegotiatedDocs
+
+#
+# UseCanonicalName:  (new for 1.3)  With this setting turned on, whenever
+# Apache needs to construct a self-referencing URL (a URL that refers back
+# to the server the response is coming from) it will use ServerName and
+# Port to form a "canonical" name.  With this setting off, Apache will
+# use the hostname:port that the client supplied, when possible.  This
+# also affects SERVER_NAME and SERVER_PORT in CGI scripts.
+#
+UseCanonicalName On
+
+#
+# TypesConfig describes where the mime.types file (or equivalent) is
+# to be found. /etc/mime.types is provided by mailcap package.
+#
+TypesConfig /etc/mime.types
+
+#
+# DefaultType is the default MIME type the server will use for a document
+# if it cannot otherwise determine one, such as from filename extensions.
+# If your server contains mostly text or HTML documents, "text/plain" is
+# a good value.  If most of your content is binary, such as applications
+# or images, you may want to use "application/octet-stream" instead to
+# keep browsers from trying to display binary files as though they are
+# text.
+#
+DefaultType text/plain
+
+#
+# The mod_mime_magic module allows the server to use various hints from the
+# contents of the file itself to determine its type.  The MIMEMagicFile
+# directive tells the module where the hint definitions are located.
+# mod_mime_magic is not part of the default server (you have to add
+# it yourself with a LoadModule [see the DSO paragraph in the 'Global
+# Environment' section], or recompile the server and include mod_mime_magic
+# as part of the configuration), so it's enclosed in an <IfModule> container.
+# This means that the MIMEMagicFile directive will only be processed if the
+# module is part of the server.
+#
+<IfModule mod_mime_magic.c>
+       MIMEMagicFile /etc/httpd/magic
+</IfModule>
+
+#
+# HostnameLookups: Log the names of clients or just their IP addresses
+# e.g., www.apache.org (on) or 204.62.129.132 (off).
+# The default is off because it'd be overall better for the net if people
+# had to knowingly turn this feature on, since enabling it means that
+# each client request will result in AT LEAST one lookup request to the
+# nameserver.
+#
+HostnameLookups Off
+
+#
+# The following directives define some format nicknames for use with
+# a CustomLog directive (see below).
+#
+LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
+LogFormat "%h %l %u %t \"%r\" %>s %b" common
+LogFormat "%{Referer}i -> %U" referer
+LogFormat "%{User-agent}i" agent
+
+#
+# ErrorLog: The location of the error log file.
+# If you do not specify an ErrorLog directive within a <VirtualHost>
+# container, error messages relating to that virtual host will be
+# logged here.  If you *do* define an error logfile for a <VirtualHost>
+# container, that host's errors will be logged there and not here.
+#
+ErrorLog /var/log/httpd/error_log
+#
+# The location and format of the access logfile (Common Logfile Format).
+# If you do not define any access logfiles within a <VirtualHost>
+# container, they will be logged here.  Contrariwise, if you *do*
+# define per-<VirtualHost> access logfiles, transactions will be
+# logged therein and *not* in this file.
+#
+CustomLog /var/log/httpd/access_log common
+CustomLog /var/log/httpd/referer_log referer
+CustomLog /var/log/httpd/agent_log agent
+
+#
+# LogLevel: Control the number of messages logged to the error_log.
+# Possible values include: debug, info, notice, warn, error, crit,
+# alert, emerg.
+#
+LogLevel warn
+
+#
+# Optionally add a line containing the server version and virtual host
+# name to server-generated pages (error documents, FTP directory listings,
+# mod_status and mod_info output etc., but not CGI generated documents).
+# Set to "EMail" to also include a mailto: link to the ServerAdmin.
+# Set to one of:  On | Off | EMail
+#
+ServerSignature Email
+
+#
+# Aliases: Add here as many aliases as you need (with no limit). The format is 
+# Alias fakename realname
+#
+# Note that if you include a trailing / on fakename then the server will
+# require it to be present in the URL.  So "/icons" isn't aliased in this
+# example, only "/icons/"..
+#
+Alias /icons/ "/home/httpd/icons/"
+
+<Directory "/home/httpd/icons">
+       Options Indexes MultiViews
+       AllowOverride None
+       Order allow,deny
+       Allow from all
+</Directory>
+
+
+
+
+Alias /manual "/home/httpd/manual"
+
+<Directory "/home/httpd/manual">
+       Options Indexes MultiViews
+       AllowOverride None
+</Directory>
+
+
+
+#
+# ScriptAlias: This controls which directories contain server scripts.
+# ScriptAliases are essentially the same as Aliases, except that
+# documents in the realname directory are treated as applications and
+# run by the server when requested rather than as documents sent to the client.
+# The same rules about trailing "/" apply to ScriptAlias directives as to
+# Alias.
+#
+ScriptAlias /cgi-bin/ "/home/httpd/cgi-bin/"
+
+#
+# "/home/httpd/cgi-bin" should be changed to whatever your ScriptAliased
+# CGI directory exists, if you have that configured.
+#
+<Directory "/home/httpd/cgi-bin">
+       AllowOverride None
+       Options None
+       Order allow,deny
+       Allow from all
+</Directory>
+
+#
+# Redirect allows you to tell clients about documents which used to exist in
+# your server's namespace, but do not anymore. This allows you to tell the
+# clients where to look for the relocated document.
+# Format: Redirect old-URI new-URL
+#
+
+#
+# Directives controlling the display of server-generated directory listings.
+#
+
+#
+# FancyIndexing is whether you want fancy directory indexing or standard
+#
+IndexOptions FancyIndexing
+
+#
+# AddIcon* directives tell the server which icon to show for different
+# files or filename extensions.  These are only displayed for
+# FancyIndexed directories.
+#
+AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip
+
+AddIconByType (TXT,/icons/text.gif) text/*
+AddIconByType (IMG,/icons/image2.gif) image/*
+AddIconByType (SND,/icons/sound2.gif) audio/*
+AddIconByType (VID,/icons/movie.gif) video/*
+
+AddIcon /icons/binary.gif .bin .exe
+AddIcon /icons/binhex.gif .hqx
+AddIcon /icons/tar.gif .tar
+AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
+AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
+AddIcon /icons/a.gif .ps .ai .eps
+AddIcon /icons/layout.gif .html .shtml .htm .pdf
+AddIcon /icons/text.gif .txt
+AddIcon /icons/c.gif .c
+AddIcon /icons/p.gif .pl .py
+AddIcon /icons/f.gif .for
+AddIcon /icons/dvi.gif .dvi
+AddIcon /icons/uuencoded.gif .uu
+AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
+AddIcon /icons/tex.gif .tex
+AddIcon /icons/bomb.gif core
+
+AddIcon /icons/back.gif ..
+AddIcon /icons/hand.right.gif README
+AddIcon /icons/folder.gif ^^DIRECTORY^^
+AddIcon /icons/blank.gif ^^BLANKICON^^
+
+#
+# DefaultIcon is which icon to show for files which do not have an icon
+# explicitly set.
+#
+DefaultIcon /icons/unknown.gif
+
+#
+# AddDescription allows you to place a short description after a file in
+# server-generated indexes.  These are only displayed for FancyIndexed
+# directories.
+# Format: AddDescription "description" filename
+#
+AddDescription "GZIP compressed document" .gz
+AddDescription "tar archive" .tar
+AddDescription "GZIP compressed tar archive" .tgz
+
+#
+# ReadmeName is the name of the README file the server will look for by
+# default, and append to directory listings.
+#
+# HeaderName is the name of a file which should be prepended to
+# directory indexes. 
+#
+# If MultiViews are amongst the Options in effect, the server will
+# first look for name.html and include it if found.  If name.html
+# doesn't exist, the server will then look for name.txt and include
+# it as plaintext if found.
+#
+ReadmeName README
+HeaderName HEADER
+
+#
+# IndexIgnore is a set of filenames which directory indexing should ignore
+# and not include in the listing.  Shell-style wildcarding is permitted.
+#
+IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t
+
+#
+# AddEncoding allows you to have certain browsers (Mosaic/X 2.1+) uncompress
+# information on the fly. Note: Not all browsers support this.
+# Despite the name similarity, the following Add* directives have nothing
+# to do with the FancyIndexing customization directives above.
+#
+AddEncoding x-compress Z
+AddEncoding x-gzip gz
+
+#
+# AddLanguage allows you to specify the language of a document. You can
+# then use content negotiation to give a browser a file in a language
+# it can understand.
+#
+# Note 1: The suffix does not have to be the same as the language
+# keyword --- those with documents in Polish (whose net-standard
+# language code is pl) may wish to use "AddLanguage pl .po" to
+# avoid the ambiguity with the common suffix for perl scripts.
+#
+# Note 2: The example entries below illustrate that in quite
+# some cases the two character 'Language' abbriviation is not
+# identical to the two character 'Country' code for its country,
+# E.g. 'Danmark/dk' versus 'Danish/da'.
+#
+# Note 3: In the case of 'ltz' we violate the RFC by using a three char
+# specifier. But there is 'work in progress' to fix this and get
+# the reference data for rfc1766 cleaned up.
+#
+# Danish (da) - Dutch (nl) - English (en) - Estonian (ee)
+# French (fr) - German (de) - Greek-Modern (el)
+# Italian (it) - Korean (kr) - Norwegian (no)
+# Portugese (pt) - Luxembourgeois* (ltz)
+# Spanish (es) - Swedish (sv) - Catalan (ca) - Czech(cz)
+# Polish (pl) - Brazilian Portuguese (pt-br) - Japanese (ja)
+# Russian (ru)
+#
+AddLanguage ca .ca
+AddLanguage cz .cz
+AddLanguage da .dk
+AddLanguage de .de
+AddLanguage en .en
+AddLanguage el .el
+AddLanguage es .es
+AddLanguage et .ee
+AddLanguage fr .fr
+AddLanguage he .he
+AddLanguage it .it
+AddLanguage ja .ja
+AddLanguage kr .kr
+AddLanguage ltz .lu
+AddLanguage nl .nl
+AddLanguage nn .nn
+AddLanguage no .no
+AddLanguage pl .po
+AddLanguage pt .pt
+AddLanguage pt-br .pt-br
+AddLanguage ru .ru
+AddLanguage sv .sv
+AddLanguage tw .tw
+AddLanguage zh-tw .tw
+
+AddCharset Big5 .Big5 .big5
+AddCharset CP866 .cp866
+AddCharset ISO-8859-2 .iso-pl
+AddCharset ISO-8859-5 .iso-ru
+AddCharset ISO-8859-8 .iso8859-8
+AddCharset ISO-2022-JP .his
+AddCharset ISO-2022-KR .iso-kr
+AddCharset KOI8-R .koi8-r
+AddCharset UCS-2 .ucs2
+AddCharset UCS-4 .ucs4
+AddCharset UTF-8 .utf8
+AddCharset WINDOWS-1251 .cp-1251
+
+#
+# LanguagePriority allows you to give precedence to some languages
+# in case of a tie during content negotiation.
+# Just list the languages in decreasing order of preference.
+#
+LanguagePriority en pl fr de
+
+#
+# AddType allows you to tweak mime.types without actually editing it, or to
+# make certain files to be certain types.
+#
+# For example, the PHP 3.x module (not part of the Apache distribution - see
+# http://www.php.net) will typically use:
+#
+#AddType application/x-httpd-php3 .php3
+#AddType application/x-httpd-php3-source .phps
+#
+# And for PHP 4.x, use:
+#
+#AddType application/x-httpd-php .php
+#AddType application/x-httpd-php-source .phps
+#
+#AddType application/x-tar .tgz
+
+#
+# AddHandler allows you to map certain file extensions to "handlers",
+# actions unrelated to filetype. These can be either built into the server
+# or added with the Action command (see below)
+#
+# If you want to use server side includes, or CGI outside
+# ScriptAliased directories, uncomment the following lines.
+#
+# To use CGI scripts:
+#
+AddHandler cgi-script .cgi
+
+#
+# To use server-parsed HTML files
+#
+AddType text/html .shtml
+AddHandler server-parsed .shtml
+
+#
+# Uncomment the following line to enable Apache's send-asis HTTP file
+# feature
+#
+AddHandler send-as-is asis
+
+#
+# If you wish to use server-parsed imagemap files, use
+#
+AddHandler imap-file map
+
+#
+# To enable type maps, you might want to use
+#
+AddHandler type-map var
+
+#
+# Action lets you define media types that will execute a script whenever
+# a matching file is called. This eliminates the need for repeated URL
+# pathnames for oft-used CGI file processors.
+# Format: Action media/type /cgi-script/location
+# Format: Action handler-name /cgi-script/location
+#
+
+#
+# MetaDir: specifies the name of the directory in which Apache can find
+# meta information files. These files contain additional HTTP headers
+# to include when sending the document
+#
+MetaDir .web
+
+#
+# MetaSuffix: specifies the file name suffix for the file containing the
+# meta information.
+#
+MetaSuffix .meta
+
+#
+# Customizable error response (Apache style)
+#  these come in three flavors
+#
+#    1) plain text
+#ErrorDocument 500 "The server made a boo boo.
+#  n.b.  the single leading (") marks it as text, it does not get output
+#
+#    2) local redirects
+#ErrorDocument 404 /missing.html
+#  to redirect to local URL /missing.html
+#ErrorDocument 404 /cgi-bin/missing_handler.pl
+#  N.B.: You can redirect to a script or a document using server-side-includes.
+#
+#    3) external redirects
+#ErrorDocument 402 http://some.other-server.com/subscription_info.html
+#  N.B.: Many of the environment variables associated with the original
+#  request will *not* be available to such a script.
+
+Alias /errordocs/ "/home/httpd/errordocs/"
+
+<Directory /home/httpd/errordocs/>
+       AllowOverride none
+       Options IncludesNoExec FollowSymLinks
+</Directory>
+
+ErrorDocument 400      /errordocs/400.shtml
+ErrorDocument 401       /errordocs/401.shtml
+ErrorDocument 403       /errordocs/403.shtml
+ErrorDocument 404       /errordocs/404.shtml
+ErrorDocument 405       /errordocs/405.shtml
+ErrorDocument 406       /errordocs/406.shtml
+ErrorDocument 408       /errordocs/408.shtml
+ErrorDocument 410       /errordocs/410.shtml
+ErrorDocument 411       /errordocs/411.shtml
+ErrorDocument 414       /errordocs/414.shtml
+ErrorDocument 500       /errordocs/500.shtml
+ErrorDocument 503       /errordocs/503.shtml
+
+# The following directives modify normal HTTP response behavior.
+# The first directive disables keepalive for Netscape 2.x and browsers that
+# spoof it. There are known problems with these browser implementations.
+# The second directive is for Microsoft Internet Explorer 4.0b2
+# which has a broken HTTP/1.1 implementation and does not properly
+# support keepalive when it is used on 301 or 302 (redirect) responses.
+#
+BrowserMatch "Mozilla/2" nokeepalive
+BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
+
+#
+# The following directive disables HTTP/1.1 responses to browsers which
+# are in violation of the HTTP/1.0 spec by not being able to grok a
+# basic 1.1 response.
+#
+BrowserMatch "RealPlayer 4\.0" force-response-1.0
+BrowserMatch "Java/1\.0" force-response-1.0
+BrowserMatch "JDK/1\.0" force-response-1.0
+
+#
+# Allow remote server configuration reports, with the URL of
+# http://servername/server-info (requires that mod_info.c be loaded).
+# Change the ".your-domain.com" to match your domain to enable.
+#
+#<Location /server-info>
+#      SetHandler server-info
+#      Order deny,allow
+#      Deny from all
+#      Allow from .your-domain.com
+#</Location>
+
+#
+# There have been reports of people trying to abuse an old bug from pre-1.1
+# days.  This bug involved a CGI script distributed as a part of Apache.
+# By uncommenting these lines you can redirect these attacks to a logging 
+# script on phf.apache.org.  Or, you can record them yourself, using the script
+# support/phf_abuse_log.cgi.
+#
+#<Location /cgi-bin/phf*>
+#      Deny from all
+#      ErrorDocument 403 http://phf.apache.org/phf_abuse_log.cgi
+#</Location>
diff --git a/apache1-mod_proxy.conf b/apache1-mod_proxy.conf
new file mode 100644 (file)
index 0000000..cd7d435
--- /dev/null
@@ -0,0 +1,33 @@
+# Proxy Server directives. Uncomment the following lines to
+# enable the proxy server:
+#
+#<IfModule mod_proxy.c>
+#ProxyRequests On
+#
+#<Directory proxy:*>
+#      Order deny,allow
+#      Deny from all
+#      Allow from .your_domain.com
+#</Directory>
+
+#
+# Enable/disable the handling of HTTP/1.1 "Via:" headers.
+# ("Full" adds the server version; "Block" removes all outgoing Via: headers)
+# Set to one of: Off | On | Full | Block
+#
+#ProxyVia On
+
+#
+# To enable the cache as well, edit and uncomment the following lines:
+# (no cacheing without CacheRoot)
+#
+CacheRoot "/var/cache/www/apache"
+CacheSize 5
+CacheGcInterval 4
+CacheMaxExpire 24
+CacheLastModifiedFactor 0.1
+CacheDefaultExpire 1
+#NoCache a_domain.com another_domain.edu joes.garage_sale.com
+
+#</IfModule>
+# End of proxy directives.
diff --git a/apache1-mod_status.conf b/apache1-mod_status.conf
new file mode 100644 (file)
index 0000000..7f03ba6
--- /dev/null
@@ -0,0 +1,11 @@
+# Allow server status reports, with the URL of http://servername/server-status
+# Change the ".your_domain.com" to match your domain to enable.
+
+<Location /server-status>
+       SetHandler server-status
+
+       order deny,allow
+       deny from all
+       allow from 127.0.0.1
+</Location>
+
diff --git a/apache1-mod_vhost_alias.conf b/apache1-mod_vhost_alias.conf
new file mode 100644 (file)
index 0000000..1bd071a
--- /dev/null
@@ -0,0 +1,17 @@
+# VirtualHost: Allows the daemon to respond to requests for more than one
+# server address, if your server machine is configured to accept IP packets
+# for multiple addresses. This can be accomplished with the ifconfig 
+# alias flag, or through kernel patches like VIF.
+
+# Any httpd.conf or srm.conf directive may go into a VirtualHost command.
+# See also the BindAddress entry.
+#<VirtualHost host.some_domain.com>
+#ServerAdmin webmaster@host.some_domain.com
+#DocumentRoot /www/docs/host.some_domain.com
+#ServerName host.some_domain.com
+#ErrorLog logs/host.some_domain.com-error_log
+#TransferLog logs/host.some_domain.com-access_log
+#</VirtualHost>
+
+
diff --git a/apache1-suexec.patch b/apache1-suexec.patch
new file mode 100644 (file)
index 0000000..c8fd68a
--- /dev/null
@@ -0,0 +1,13 @@
+--- apache_1.3.2/Makefile.tmpl.orig    Fri Sep 25 23:56:02 1998
++++ apache_1.3.2/Makefile.tmpl Fri Sep 25 23:57:37 1998
+@@ -317,10 +317,6 @@
+       -@if [ ".$(suexec)" = .1 ]; then \
+           echo "$(INSTALL_PROGRAM) $(TOP)/$(SRC)/support/suexec $(root)$(sbindir)/suexec"; \
+           $(INSTALL_PROGRAM) $(TOP)/$(SRC)/support/suexec $(root)$(sbindir)/suexec; \
+-          echo "chown root $(root)$(sbindir)/suexec"; \
+-          chown root $(root)$(sbindir)/suexec; \
+-          echo "chmod 4711 $(root)$(sbindir)/suexec"; \
+-          chmod 4711 $(root)$(sbindir)/suexec; \
+           echo "$(INSTALL_DATA) $(TOP)/$(SRC)/support/suexec.8 $(root)$(mandir)/man8/suexec.8"; \
+           $(INSTALL_DATA) $(TOP)/$(SRC)/support/suexec.8 $(root)$(mandir)/man8/suexec.8; \
+       fi
diff --git a/apache1.init b/apache1.init
new file mode 100644 (file)
index 0000000..0432b79
--- /dev/null
@@ -0,0 +1,73 @@
+#!/bin/sh
+#
+# apache       Apache Web Server
+#
+# chkconfig:   345 85 15
+# description: Apache is a World Wide Web server.  It is used to serve \
+#              HTML files and CGI.
+# processname: httpd
+# pidfile:     /var/run/httpd.pid
+# config:      /etc/httpd/httpd.conf
+
+
+# Source function library
+. /etc/rc.d/init.d/functions
+
+# Get network config
+. /etc/sysconfig/network
+
+# Get service config
+[ -f /etc/sysconfig/apache ] && . /etc/sysconfig/apache
+
+# Check that networking is up.
+if is_no "${NETWORKING}"; then
+        # nls "ERROR: Networking is down. %s can't be run." <service>
+        msg_network_down httpd
+        exit 1
+fi
+
+if is_no "${IPV6_NETWORKING}"; then
+        HTTPD_OPTS="$HTTPD_OPTS -4"
+fi
+
+# See how we were called.
+case "$1" in
+  start)
+       # Check if the service is already running?
+        if [ ! -f /var/lock/subsys/httpd ]; then
+               msg_starting httpd
+               daemon httpd $HTTPD_OPTS
+               RETVAL=$?
+               [ $RETVAL -eq 0 ] && touch /var/lock/subsys/httpd
+       else
+               msg_already_running httpd
+               exit 1
+       fi
+       ;;
+  stop)
+        # Stop daemons.
+       if [ -f /var/lock/subsys/httpd ]; then
+                msg_stopping httpd
+                killproc httpd
+                rm -f /var/lock/subsys/httpd /var/run/httpd.pid /var/run/httpd.loc* >/dev/null 2>&1
+        else
+               msg_not_running httpd
+               exit 1
+       fi
+       ;;
+  status)
+       status httpd
+       /usr/sbin/httpd -S
+       exit $?
+       ;;
+  restart|reload)
+       $0 stop
+       $0 start
+       ;;
+  *)
+       msg_usage "$0 {start|stop|restart|status}"
+       exit 1
+       ;;
+esac
+
+exit $RETVAL
This page took 0.08345 seconds and 4 git commands to generate.