]> git.pld-linux.org Git - packages/apache1-mod_xslt.git/commitdiff
- fix in config RA-1_0 STABLE apache-mod_xslt-1_1-4
authorggodlewski <ggodlewski@pld-linux.org>
Fri, 13 Sep 2002 15:31:19 +0000 (15:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- patch for correct module name
- linked with sablot

Changed files:
    apache1-mod_xslt-make.patch -> 1.1
    apache1-mod_xslt-module.patch -> 1.1
    apache1-mod_xslt.conf -> 1.3
    mod_xslt-make.patch -> 1.1
    mod_xslt-module.patch -> 1.1
    mod_xslt.conf -> 1.3

apache1-mod_xslt-make.patch [new file with mode: 0644]
apache1-mod_xslt-module.patch [new file with mode: 0644]
apache1-mod_xslt.conf
mod_xslt-make.patch [new file with mode: 0644]
mod_xslt-module.patch [new file with mode: 0644]
mod_xslt.conf

diff --git a/apache1-mod_xslt-make.patch b/apache1-mod_xslt-make.patch
new file mode 100644 (file)
index 0000000..fbb55e1
--- /dev/null
@@ -0,0 +1,11 @@
+--- modxslt/Makefile.orig      Fri Sep 13 17:09:40 2002
++++ modxslt/Makefile   Fri Sep 13 17:09:21 2002
+@@ -6,7 +6,7 @@
+ #   compile the shared object file
+ mod_xslt.so: mod_xslt.c
+-      $(APXS) -c mod_xslt.c -o mod_xslt.so
++      $(APXS) -c mod_xslt.c -o mod_xslt.so -lsablot
+ #   cleanup
+ clean:
diff --git a/apache1-mod_xslt-module.patch b/apache1-mod_xslt-module.patch
new file mode 100644 (file)
index 0000000..ee65d1b
--- /dev/null
@@ -0,0 +1,38 @@
+--- modxslt/mod_xslt.c.orig    Fri Sep 13 17:24:24 2002
++++ modxslt/mod_xslt.c Fri Sep 13 17:24:05 2002
+@@ -57,7 +57,7 @@
+     int debug;
+ } mod_xslt_cfg;
+-module MODULE_VAR_EXPORT mod_xslt_module;
++module MODULE_VAR_EXPORT xslt_module;
+ const char *mod_xslt_dyndoc_cmd(cmd_parms *cmd, void *m, int flag);
+ const char *mod_xslt_dynss_cmd(cmd_parms *cmd, void *m, int flag);
+@@ -205,7 +205,7 @@
+     void *theproc;
+     mod_xslt_cfg *cfg = (mod_xslt_cfg*) 
+-      ap_get_module_config(r->per_dir_config, &mod_xslt_module);
++      ap_get_module_config(r->per_dir_config, &xslt_module);
+     se = SablotCreateProcessor (&theproc);
+     if (cfg->debug)
+       se |= SablotRegHandler(theproc, HLR_MESSAGE, &sablotMH, (void*)r);
+@@ -246,7 +246,7 @@
+   int cnt1;
+   request_rec * subr = NULL;
+   mod_xslt_cfg *cfg = (mod_xslt_cfg*) 
+-      ap_get_module_config(r->per_dir_config, &mod_xslt_module);
++      ap_get_module_config(r->per_dir_config, &xslt_module);
+   /* Setup some common strings of text, for file not found, etc. */
+@@ -455,7 +455,7 @@
+ };
+ /* Dispatch list for API hooks */
+-module MODULE_VAR_EXPORT mod_xslt_module = {
++module MODULE_VAR_EXPORT xslt_module = {
+     STANDARD_MODULE_STUFF, 
+     mod_xslt_init,                  /* module initializer                  */
+     mod_xslt_create_dir_cfg,    /* create per-dir    config structures */
index 4d3963838074d051acc958d8b104f7078f7d9cf5..b5cd49298cc79ce3f3c4c29e045bc07efb71839e 100644 (file)
@@ -1,8 +1,5 @@
 # Sample configuration for apache-mod_xslt
 
-LoadFile                        lib/libsablot.so
-LoadModule mod_xslt_module      lib/apache/mod_xslt.so
-
 ########
 ########  XSLTDebug
 ########
diff --git a/mod_xslt-make.patch b/mod_xslt-make.patch
new file mode 100644 (file)
index 0000000..fbb55e1
--- /dev/null
@@ -0,0 +1,11 @@
+--- modxslt/Makefile.orig      Fri Sep 13 17:09:40 2002
++++ modxslt/Makefile   Fri Sep 13 17:09:21 2002
+@@ -6,7 +6,7 @@
+ #   compile the shared object file
+ mod_xslt.so: mod_xslt.c
+-      $(APXS) -c mod_xslt.c -o mod_xslt.so
++      $(APXS) -c mod_xslt.c -o mod_xslt.so -lsablot
+ #   cleanup
+ clean:
diff --git a/mod_xslt-module.patch b/mod_xslt-module.patch
new file mode 100644 (file)
index 0000000..ee65d1b
--- /dev/null
@@ -0,0 +1,38 @@
+--- modxslt/mod_xslt.c.orig    Fri Sep 13 17:24:24 2002
++++ modxslt/mod_xslt.c Fri Sep 13 17:24:05 2002
+@@ -57,7 +57,7 @@
+     int debug;
+ } mod_xslt_cfg;
+-module MODULE_VAR_EXPORT mod_xslt_module;
++module MODULE_VAR_EXPORT xslt_module;
+ const char *mod_xslt_dyndoc_cmd(cmd_parms *cmd, void *m, int flag);
+ const char *mod_xslt_dynss_cmd(cmd_parms *cmd, void *m, int flag);
+@@ -205,7 +205,7 @@
+     void *theproc;
+     mod_xslt_cfg *cfg = (mod_xslt_cfg*) 
+-      ap_get_module_config(r->per_dir_config, &mod_xslt_module);
++      ap_get_module_config(r->per_dir_config, &xslt_module);
+     se = SablotCreateProcessor (&theproc);
+     if (cfg->debug)
+       se |= SablotRegHandler(theproc, HLR_MESSAGE, &sablotMH, (void*)r);
+@@ -246,7 +246,7 @@
+   int cnt1;
+   request_rec * subr = NULL;
+   mod_xslt_cfg *cfg = (mod_xslt_cfg*) 
+-      ap_get_module_config(r->per_dir_config, &mod_xslt_module);
++      ap_get_module_config(r->per_dir_config, &xslt_module);
+   /* Setup some common strings of text, for file not found, etc. */
+@@ -455,7 +455,7 @@
+ };
+ /* Dispatch list for API hooks */
+-module MODULE_VAR_EXPORT mod_xslt_module = {
++module MODULE_VAR_EXPORT xslt_module = {
+     STANDARD_MODULE_STUFF, 
+     mod_xslt_init,                  /* module initializer                  */
+     mod_xslt_create_dir_cfg,    /* create per-dir    config structures */
index 4d3963838074d051acc958d8b104f7078f7d9cf5..b5cd49298cc79ce3f3c4c29e045bc07efb71839e 100644 (file)
@@ -1,8 +1,5 @@
 # Sample configuration for apache-mod_xslt
 
-LoadFile                        lib/libsablot.so
-LoadModule mod_xslt_module      lib/apache/mod_xslt.so
-
 ########
 ########  XSLTDebug
 ########
This page took 0.131155 seconds and 4 git commands to generate.