]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/commitdiff
- initial, based a bit on mod_fastcgi
authorbonkey <bonkey@bonkey.pl.eu.org>
Tue, 18 Dec 2001 20:46:03 +0000 (20:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- doesn't compile because of lack of ipv6

Changed files:
    apache1-mod_throttle.spec -> 1.1

apache1-mod_throttle.spec [new file with mode: 0644]

diff --git a/apache1-mod_throttle.spec b/apache1-mod_throttle.spec
new file mode 100644 (file)
index 0000000..1c638f8
--- /dev/null
@@ -0,0 +1,63 @@
+Summary:       Support for the FastCGI protocol for apache webserver
+Name:          apache-mod_throttle
+Version:       3.1.2
+Release:       1
+License:       Anthony Howe
+Group:         Networking/Daemons
+Source0:       http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
+URL:           http://www.snert.com/Software/mod_throttle/
+BuildRequires: apache-devel
+Requires:      apache >= 1.3.1
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define         _libexecdir     %{_libdir}/apache
+%define         _htmldocdir     /home/httpd/manual/mod
+
+%description
+This Apache module is intended to reduce the load on your server &
+bandwidth generated by popular virtual hosts, directories, locations, or
+users according to supported polices (see below) that decide when to delay
+or refuse requests. Also mod_throttle can track and throttle incoming
+connections by IP address or by authenticated remote user.
+
+%prep
+%setup -q -n mod_throttle-%{version}
+
+%build
+apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_throttle.so -c *.c
+# to don't bother about ssi counter inside
+mv index.shtml index.html
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
+
+install mod_throttle.so $RPM_BUILD_ROOT%{_libexecdir}
+install *.html $RPM_BUILD_ROOT%{_htmldocdir}
+
+gzip -9nf *.txt
+
+%post
+%{_sbindir}/apxs -e -a -n throttle %{_libexecdir}/mod_throttle.so 1>&2
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       %{_sbindir}/apxs -e -A -n throttle %{_libexecdir}/mod_throttle.so 1>&2
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
+fi
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc *.gz
+%doc %{_htmldocdir}/index.html
+%attr(755,root,root) %{_libexecdir}/*
This page took 0.104843 seconds and 4 git commands to generate.