]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blob - apache1-mod_throttle.spec
- merged translations from Conectiva.
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
1 Summary:        Bandwidth & Request Throttling
2 Summary(es):    Descompresión instantanea de archivos HTML para Apache
3 Summary(pt_BR): Descompressão "On-the-fly" de arquivos HTML para o Apache
4 Name:           apache-mod_throttle
5 Version:        3.1.2
6 Release:        1
7 License:        Anthony Howe
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
12 URL:            http://www.snert.com/Software/mod_throttle/
13 BuildRequires:  apache-devel
14 Requires:       apache >= 1.3.1
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _libexecdir     %{_libdir}/apache
18 %define         _htmldocdir     /home/httpd/manual/mod
19
20 %description
21 This Apache module is intended to reduce the load on your server &
22 bandwidth generated by popular virtual hosts, directories, locations,
23 or users according to supported polices (see below) that decide when
24 to delay or refuse requests. Also mod_throttle can track and throttle
25 incoming connections by IP address or by authenticated remote user.
26
27 %description -l es
28 Descompresión instantanea de archivos HTML para Apache.
29
30 %description -l pt_BR
31 Descompressão "On-the-fly" de arquivos HTML para o Apache.
32
33 %prep
34 %setup -q -n mod_throttle-%{version}
35
36 %build
37 apxs -D SUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_throttle.so -c *.c
38 # to don't bother about ssi counter inside
39 mv index.shtml index.html
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
44
45 install mod_throttle.so $RPM_BUILD_ROOT%{_libexecdir}
46 install *.html $RPM_BUILD_ROOT%{_htmldocdir}
47
48 gzip -9nf *.txt
49
50 %post
51 %{_sbindir}/apxs -e -a -n throttle %{_libexecdir}/mod_throttle.so 1>&2
52 if [ -f /var/lock/subsys/httpd ]; then
53         /etc/rc.d/init.d/httpd restart 1>&2
54 else
55         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
56 fi
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %{_sbindir}/apxs -e -A -n throttle %{_libexecdir}/mod_throttle.so 1>&2
61         if [ -f /var/lock/subsys/httpd ]; then
62                 /etc/rc.d/init.d/httpd restart 1>&2
63         fi
64 fi
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc *.gz
72 %doc %{_htmldocdir}/index.html
73 %attr(755,root,root) %{_libexecdir}/*
This page took 0.083728 seconds and 3 git commands to generate.