]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blob - apache1-mod_throttle.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
1 %define         apxs    /usr/sbin/apxs
2 Summary:        Bandwidth & Request Throttling for Apache
3 Summary(cs):    Omezení sí»ového provozu pro Apache
4 Summary(de):    Ein Modul, das die Bandbreiten- und Anforderungseinschränkung für Apache implementiert
5 Summary(es):    Módulo que implementa la gestión de ancho de banda y peticiones para Apache
6 Summary(fr):    Module qui met en oeuvre la bande passante et l'étranglement requis pour Apache
7 Summary(it):    Modulo che implementa la larghezza di banda e la richiesta di throttling per Apache
8 Summary(ja):    Apache ÍÑÂÓ°èÉý¤ª¤è¤ÓÍ׵᥹¥í¥Ã¥È¥ë¤ò¼ÂÁõ¤¹¤ë¥â¥¸¥å¡¼¥ë
9 Summary(pl):    T³umienie przepustowo¶ci i zapytañ dla Apache'a
10 Summary(pt_BR): Descompressão "On-the-fly" de arquivos HTML para o Apache
11 Summary(sv):    En modul som implementerar bandvidd- och begäranbegränsningar i Apache
12 Name:           apache-mod_throttle
13 Version:        3.1.2
14 Release:        3
15 License:        Anthony Howe
16 Group:          Networking/Daemons
17 Source0:        http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
18 URL:            http://www.snert.com/Software/mod_throttle/
19 BuildRequires:  apache-devel
20 BuildRequires:  %{apxs}
21 Prereq:         %{_sbindir}/apxs
22 Requires:       apache >= 1.3.1
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _libexecdir     %{_libdir}/apache
26 %define         _htmldocdir     /home/httpd/manual/mod
27
28 %description
29 This Apache module is intended to reduce the load on your server &
30 bandwidth generated by popular virtual hosts, directories, locations,
31 or users according to supported polices (see below) that decide when
32 to delay or refuse requests. Also mod_throttle can track and throttle
33 incoming connections by IP address or by authenticated remote user.
34
35 %description -l cs
36 Balíèek mod_throttle obsahuje modul, který umo¾òuje omezit prùtok dat,
37 která odcházejí z WWW serveru Apache. Limity mohou být nastaveny pro
38 jednotlivé virtuální weby, adresáøe, umístìní nebo autentizované
39 u¾ivatele.
40
41 %description -l de
42 Mod_throttle kann verwendet werden, um die Datenmenge zu beschränken,
43 die Ihr Web-Server behandelt. Diese Einschränkungen können für
44 einzelne virtuelle Rechner, Verzeichnisse, Speicherstellen oder
45 authentifizierte Benutzer eingestellt werden.
46
47 %description -l es
48 Mod_throttle puede usarse para limitar la cantidad de datos que su
49 servidor web va a servir. Estos límites se pueden configurar para
50 hosts virtuales individuales, directorios, lug<res o usuarios
51 autenticados.
52
53 %description -l fr
54 Mod_throttle peut être utilisé pour limiter la quantité de données
55 servies par votre serveur Web. Ces limites peuvent être définies pour
56 des hôtes virtuels individuels, répertoires, emplacements ou
57 utilisateurs authentifiés.
58
59 %description -l it
60 Mod_throttle può essere usato per limitare la quantità di dati che il
61 server Web dovrà servire. Queste limitazioni possono essere
62 configurate per singoli host virtuali, directory, indirizzi o utenti
63 autenticati.
64
65 %description -l ja
66 Mod_throttle ¤Ë¤è¤Ã¤Æ Web ¥µ¡¼¥Ð¡¼¤¬½èÍý¤¹¤ë¥Ç¡¼¥¿Î̤òÀ©¸Â¤Ç¤­¤Þ¤¹
67 ¤³¤ì¤é¤ÎÀ©¸Â¤Ï¡¢¸Ä¡¹¤Î²¾ÁÛ¥Û¥¹¥È¡¢¥Ç¥£¥ì¥¯¥È¥ê¡¢¾ì½ê¡¢¤Þ¤¿¤Ï
68 ǧ¾Ú¥æ¡¼¥¶¡¼ÍѤˤĤ¤¤ÆÀßÄê¤Ç¤­¤Þ¤¹¡£
69
70 %description -l pl
71 Ten modu³ Apache ma s³u¿yæ do zmniejsszania obci±¿enia serwera i ruchu
72 generowanego przez popularne hosty wirtualne, katalogi, pliki lub
73 u¿ytkowników zgodnie z obs³ugiwanymi polisami, które decyduj± kiedy
74 opó¼niæ lub odrzuciæ zapytanie. mod_throttle mo¿e tak¿e ¶ledziæ i
75 t³umiæ po³±czenia przychodz±ce z danego adresu IP lub danego,
76 autentykuj±cego siê, u¿ytkownika.
77
78 %description -l pt_BR
79 Descompressão "On-the-fly" de arquivos HTML para o Apache.
80
81 %description -l sv
82 Mod_throttle kan användas för att begränsa mängden data som din
83 webbserver skickar. Dessa gränser kan sättas för enskilda virtuella
84 värdar, kataloger, platser eller autenticerade användare.
85
86 %prep
87 %setup -q -n mod_throttle-%{version}
88
89 %build
90 %{apxs} -DSUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_throttle.so -c *.c
91 # to don't bother about ssi counter inside
92 mv -f index.shtml index.html
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
97
98 install mod_throttle.so $RPM_BUILD_ROOT%{_libexecdir}
99 install *.html $RPM_BUILD_ROOT%{_htmldocdir}
100
101 gzip -9nf *.txt
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 %{_sbindir}/apxs -e -a -n throttle %{_libexecdir}/mod_throttle.so 1>&2
108 if [ -f /var/lock/subsys/httpd ]; then
109         /etc/rc.d/init.d/httpd restart 1>&2
110 else
111         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
112 fi
113
114 %preun
115 if [ "$1" = "0" ]; then
116         %{_sbindir}/apxs -e -A -n throttle %{_libexecdir}/mod_throttle.so 1>&2
117         if [ -f /var/lock/subsys/httpd ]; then
118                 /etc/rc.d/init.d/httpd restart 1>&2
119         fi
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %doc *.gz
125 %doc %{_htmldocdir}/index.html
126 %attr(755,root,root) %{_libexecdir}/*
This page took 0.039276 seconds and 3 git commands to generate.