]> git.pld-linux.org Git - packages/apache1-mod_suphp.git/commitdiff
- unify with template-apache1_module.spec
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 28 Feb 2005 19:22:05 +0000 (19:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- full confdir apache1 support

Changed files:
    apache1-mod_suphp.spec -> 1.2

apache1-mod_suphp.spec

index 3429804a613f39b0798ef2ff433cd61c75171c70..3c4637e3d07dc347b0605d9e688078d2e9dfcb98 100644 (file)
@@ -1,7 +1,6 @@
 #
 # Available build options:
-%bcond_with    checkpath       # enable check if php execution is within
-                               # DOCUMENT_ROOT of the vhost
+%bcond_with    checkpath       # enable check if php execution is within DOCUMENT_ROOT of the vhost
 #
 %define                mod_name        suphp
 %define        apxs            /usr/sbin/apxs1
@@ -9,31 +8,32 @@ Summary:      Apache module: suPHP - execute PHP scripts with the permissions of thei
 Summary(pl):   Modu³ do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich w³a¶cicieli
 Name:          apache1-mod_%{mod_name}
 Version:       0.5.2
-Release:       1
+Release:       1.4
 License:       GPL
 Group:         Networking/Daemons
-Source0:       http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz     
+Source0:       http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz
 # Source0-md5: 337909e87027af124052baddddbd2994
-Source1:       %{name}.logrotate
-Source2:       %{name}.conf
+Source1:       %{name}.conf
+Source2:       %{name}.logrotate
 URL:           http://www.suphp.org/
-BuildRequires: %{apxs}
-BuildRequires: apache1-devel
+BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: autoconf
 BuildRequires: automake
-Requires(post,preun):  %{apxs}
+Requires(triggerpostun):       %{apxs}
+Requires(triggerpostun):       grep
+Requires(triggerpostun):       sed >= 4.0
 Requires:      apache
 Requires:      php-cgi
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
-suPHP is a tool for executing PHP scripts with the permissions of their
-owners. It consists of an Apache module (mod_suphp) and a setuid root
-binary (suphp) that is called by the Apache module to change the uid of
-the process executing the PHP interpreter.
+suPHP is a tool for executing PHP scripts with the permissions of
+their owners. It consists of an Apache module (mod_suphp) and a setuid
+root binary (suphp) that is called by the Apache module to change the
+uid of the process executing the PHP interpreter.
 
 %description -l pl
 suPHP jest narzêdziem pozwalaj±cym na wykonywanie skryptów w PHP z
@@ -57,43 +57,58 @@ chmod 755 configure
        --with-min-gid=1000 \
        --with-apxs=%{apxs} \
        --disable-checkuid \
-       --disable-checkgid 
+       --disable-checkgid
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir}}
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install src/suphp $RPM_BUILD_ROOT%{_sbindir}
 install src/apache/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod-suphp.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
 
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
+# TODO: apache1-mod_suphp + trigger
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
+# TODO remove the trigger, if no longer needed
+%triggerpostun -- %{name} <= 0.5.2-1
+if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       sed -i -e '
+               /^Include.*mod_%{mod_name}\.conf/d
+       ' /etc/apache/apache.conf
+else
+       # they're still using old apache.conf
+       sed -i -e '
+               s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
+       ' /etc/apache/apache.conf
+fi
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc README AUTHORS ChangeLog doc
 %attr(4755,root,root) %{_sbindir}/suphp
 %attr(755,root,root) %{_pkglibdir}/*
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
This page took 0.114717 seconds and 4 git commands to generate.