]> git.pld-linux.org Git - packages/apache1-mod_suid.git/commitdiff
- initial release
authormisi3k <misi3k@pld-linux.org>
Wed, 14 May 2003 19:24:25 +0000 (19:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache1-mod_suid.spec -> 1.1

apache1-mod_suid.spec [new file with mode: 0644]

diff --git a/apache1-mod_suid.spec b/apache1-mod_suid.spec
new file mode 100644 (file)
index 0000000..ce8983a
--- /dev/null
@@ -0,0 +1,60 @@
+%define                mod_name        suid
+%define                ver             1.1
+%define        apxs            /usr/sbin/apxs
+Summary:       Apache module: execution of scripts under their own uids
+Summary(pl):   Modu³ do apache: wykonywanie skryptow pod wskazanym uidem
+Name:          apache-mod_%{mod_name}
+Version:       %{ver}
+Release:       0.1
+License:       GPL
+Group:         Networking/Daemons
+Source0:       http://www.jdimedia.nl/igmar/mod_%{mod_name}/files/mod_%{mod_name}-%{version}.tar.gz
+URL:           http://www.jdimedia.nl/igmar/mod_%{mod_name}/
+BuildRequires: %{apxs}
+BuildRequires: apache-devel
+BuildRequires: zlib-devel
+Requires(post,preun):  %{apxs}
+Requires:      apache
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+
+%description
+Apache module: execution of scripts under their own uids per-vhost
+
+%description -l pl
+Modu³ do apache: wykonywanie skryptow pod wskazanym uidem per-vhost
+
+%prep
+%setup -q -n mod_%{mod_name}-%{version}
+
+%build
+%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_pkglibdir}
+
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc CHANGES.txt README
+%attr(755,root,root) %{_pkglibdir}/*
This page took 0.082473 seconds and 4 git commands to generate.