]> git.pld-linux.org Git - packages/apache1-mod_rpaf.git/blob - apache1-mod_rpaf.spec
0191b85b60cf01526e57d8039b01c1831db69ed1
[packages/apache1-mod_rpaf.git] / apache1-mod_rpaf.spec
1 # TODO
2 # - compile fails when apache1 is compiled with ipv6
3
4 %bcond_with     ipv6            # disable IPv6 support
5
6 %define         mod_name        rpaf
7 %define         apxs            %{_sbindir}/apxs1
8 Summary:        Reverse proxy add forward module for Apache
9 Summary(pl):    Modu³ Apache'a dodaj±cy przekazywanie dla odwrotnych proxy
10 Name:           apache1-mod_%{mod_name}
11 Version:        0.5
12 Release:        0.14
13 License:        Apache
14 Group:          Networking/Daemons
15 Source0:        http://stderr.net/apache/rpaf/download/mod_%{mod_name}-%{version}.tar.gz
16 # Source0-md5:  471fb059d6223a394f319b7c8ab45c4d
17 Source1:        %{name}.conf
18 URL:            http://stderr.net/apache/rpaf/
19 BuildRequires:  apache1-devel >= 1.3.33-2
20 %{!?with_ipv6:BuildConflicts:   apache1(ipv6)-devel}
21 Requires:       apache1 >= 1.3.33-2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
26
27 %description
28 rpaf is for backend Apache servers what mod_proxy_add_forward is for
29 frontend Apache servers. It does excactly the opposite of
30 mod_proxy_add_forward written by Ask Bjoern Hansen. It will also work
31 with mod_proxy in Apache starting with release 1.3.25.
32
33 %description -n en
34 rpaf is for backend Apache servers what mod_proxy_add_forward is for
35 frontend Apache servers. It does excactly the opposite of
36 mod_proxy_add_forward written by Ask Bjørn Hansen. It will also work
37 with mod_proxy in Apache starting with release 1.3.25.
38
39 %description -l pl
40 rpaf jest dla backendowych serwerów Apache tym, czym
41 mod_proxy_add_forward jest dla frontendowych. Wykonuje dok³adnie
42 przeciwne operacje do mod_proxy_add_forward napisanego przez Aska
43 Bjoerna Hansena. Bêdzie tak¿e dzia³aæ z mod_proxy w Apache'u pocz±wszy
44 od wersji 1.3.25.
45
46 %prep
47 %setup -q -n mod_%{mod_name}-%{version}
48
49 %build
50 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
55
56 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
57 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/99_mod_%{mod_name}.conf
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 if [ -f /var/lock/subsys/apache ]; then
64         /etc/rc.d/init.d/apache restart 1>&2
65 fi
66
67 %postun
68 if [ "$1" = "0" ]; then
69         if [ -f /var/lock/subsys/apache ]; then
70                 /etc/rc.d/init.d/apache restart 1>&2
71         fi
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README CHANGES test.pl
77 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
78 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.026796 seconds and 2 git commands to generate.