]> git.pld-linux.org Git - packages/apache1-mod_ntlm.git/blob - apache1-mod_ntlm.spec
- tabs in preamble
[packages/apache1-mod_ntlm.git] / apache1-mod_ntlm.spec
1 # TODO: review security issues
2 %define         mod_name        ntlm
3 %define         apxs            /usr/sbin/apxs1
4 Summary:        This is the NTLM authentication module for Apache
5 Summary(pl.UTF-8):      Moduł uwierzytelnienia NTLM dla Apache
6 Name:           apache1-mod_%{mod_name}
7 Version:        0.4
8 Release:        0.3
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  5e9b8d1abf872926d6ff01a05a7deb2a
14 Patch0:         %{name}-security.patch
15 URL:            http://modntlm.sourceforge.net/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache1-devel >= 1.3.33-2
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires:       apache1 >= 1.3.33-2
20 Obsoletes:      apache-mod_ntlm <= 1:0.4
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26 %description
27 This is an authentication module for Apache that allows you to
28 authenticate HTTP clients using samba or windows-like server (using
29 NTLM protocol).
30
31 %description -l pl.UTF-8
32 To jest moduł uwierzytelnienia dla Apache pozwalający na
33 uwierzytelnianie klientów HTTP poprzez sambę lub serwer na Windows (z
34 użyciem protokołu NTLM).
35
36 %prep
37 %setup -q -n mod_%{mod_name}-%{version}
38 %patch0 -p1
39
40 %build
41 %{__make} APXS=%{apxs}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
46
47 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
48
49 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
50         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %service -q apache restart
57
58 %postun
59 if [ "$1" = "0" ]; then
60         %service -q apache restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
66 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.053843 seconds and 3 git commands to generate.