]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blob - apache1-mod_mp3.spec
5fcf286f1e6a51a32369f79a11739923 mod_mp3-0.25.tar.gz
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
1 %define         arname          mod_mp3
2 %define         mod_name        mp3
3 Summary:        MP3 Apache module
4 Name:           apache-mod_mp3
5 Version:        0.25
6 Release:        1
7 License:        distributable
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        ftp://ftp.tangent.org/pub/apache/%{arname}-%{version}.tar.gz
12 Source1:        %{arname}.conf
13 URL:            http://media.tangent.org/
14 Requires:       apache >= 1.3.12
15 Prereq:         grep
16 Provides:       %{arname}
17 BuildRequires:  apache >= 1.3.12
18 BuildRequires:  apache-devel >= 1.3.12
19 BuildRequires:  expat-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
23 %define         _sysconfdir     /etc/httpd
24
25 %prep
26 %setup -q -n %{arname}-%{version}
27
28 %description
29 This turns apache into your basic RIAA hating, but every college
30 student loving mp3 streaming server. It can play from a list of files,
31 either straight through or randomly. It can also be used to cache
32 mp3's into memory and have the server operate entirely from memory.
33 Enjoy, groove, mp3s not included.
34
35 %build
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
41
42 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
43 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
44
45 gzip -9nf README ChangeLog LICENSE
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52 if [ -f %{_sysconfdir}/httpd.conf ] && \
53     ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
54         echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
55 fi
56 if [ -f /var/lock/subsys/httpd ]; then
57     /etc/rc.d/init.d/httpd restart 1>&2
58 fi
59         
60 %preun
61 if [ "$1" = "0" ]; then
62     %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
63     grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
64         %{_sysconfdir}/httpd.conf.tmp
65     mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
66     if [ -f /var/lock/subsys/httpd ]; then
67         /etc/rc.d/init.d/httpd restart 1>&2
68     fi
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %config(noreplace) %{_sysconfdir}/mod_mp3.conf
74 %attr(755,root,root) %{_pkglibdir}/mod_mp3.so
75 %doc *.gz faq.html
This page took 0.095882 seconds and 3 git commands to generate.